aboutsummaryrefslogtreecommitdiff
path: root/security/ifd-gempc410
diff options
context:
space:
mode:
authorDag-Erling Smørgrav <des@FreeBSD.org>2003-06-02 15:17:41 +0000
committerDag-Erling Smørgrav <des@FreeBSD.org>2003-06-02 15:17:41 +0000
commitdf74134884434ecce3da8287c30c12c1ab54cb5b (patch)
treef2d9d1510fa56afba30f0ab03cf83953c953fa04 /security/ifd-gempc410
parenta2c29a16caf45cae0a2e803e8693deb3c5759e8a (diff)
downloadports-df74134884434ecce3da8287c30c12c1ab54cb5b.tar.gz
ports-df74134884434ecce3da8287c30c12c1ab54cb5b.zip
PC/SC Lite driver for GemPC 410 serial smart card readers (also sold by IBM)
Notes
Notes: svn path=/head/; revision=82012
Diffstat (limited to 'security/ifd-gempc410')
-rw-r--r--security/ifd-gempc410/Makefile37
-rw-r--r--security/ifd-gempc410/distinfo1
-rw-r--r--security/ifd-gempc410/files/message11
-rw-r--r--security/ifd-gempc410/files/patch-GemPC410::gbpserial.c11
-rw-r--r--security/ifd-gempc410/pkg-descr8
-rw-r--r--security/ifd-gempc410/pkg-plist3
6 files changed, 71 insertions, 0 deletions
diff --git a/security/ifd-gempc410/Makefile b/security/ifd-gempc410/Makefile
new file mode 100644
index 000000000000..b3057ff57b7d
--- /dev/null
+++ b/security/ifd-gempc410/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: ifd-gempc410
+# Date created: 2003-05-09
+# Whom: des
+#
+# $FreeBSD$
+#
+
+PORTNAME= ifd-gempc410
+PORTVERSION= 0.8.0
+CATEGORIES= security
+MASTER_SITES= http://ludovic.rousseau.free.fr/softwares/ifd-GemPC/
+DISTNAME= ifd-gempc-${PORTVERSION}
+
+MAINTAINER= des@freebsd.org
+COMMENT= PC/SC Lite driver for the GemPC 410 serial smart card reader
+
+BUILD_DEPENDS= ${LOCALBASE}/include/ifdhandler.h:${PORTSDIR}/security/ifd-devkit
+LIB_DEPENDS= pcsclite.0:${PORTSDIR}/devel/pcsc-lite
+
+USE_GMAKE= yes
+
+MAKE_ENV+= DESTDIR="${PREFIX}"
+MAKE_ARGS+= -CGemPC410
+
+INSTALLS_SHLIB= yes
+
+NOMAN=
+
+PKGMESSAGE= ${WRKDIR}/message
+
+post-configure:
+ ${SED} -e 's|%%PREFIX%%|${PREFIX}|g' <${FILESDIR}/message >${PKGMESSAGE}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/security/ifd-gempc410/distinfo b/security/ifd-gempc410/distinfo
new file mode 100644
index 000000000000..896c974f5dd4
--- /dev/null
+++ b/security/ifd-gempc410/distinfo
@@ -0,0 +1 @@
+MD5 (ifd-gempc-0.8.0.tar.gz) = 1e3bb5863ee845a00a1c0ed83b830204
diff --git a/security/ifd-gempc410/files/message b/security/ifd-gempc410/files/message
new file mode 100644
index 000000000000..b35370fb99c9
--- /dev/null
+++ b/security/ifd-gempc410/files/message
@@ -0,0 +1,11 @@
+You need to add your reader to %%PREFIX%%/etc/readers.conf. The
+following is an example of a suitable entry:
+
+FRIENDLYNAME "GemPC410"
+DEVICENAME GEMCORE
+LIBPATH %%PREFIX%%/lib/libGemPC410.so
+CHANNELID 1
+
+You will have to adjust the CHANNELID to match the actual port that your
+reader is connected to (0 for /dev/cuaa0, 1 for /dev/cuaa1 etc.)
+
diff --git a/security/ifd-gempc410/files/patch-GemPC410::gbpserial.c b/security/ifd-gempc410/files/patch-GemPC410::gbpserial.c
new file mode 100644
index 000000000000..7e90bd73b5b2
--- /dev/null
+++ b/security/ifd-gempc410/files/patch-GemPC410::gbpserial.c
@@ -0,0 +1,11 @@
+--- GemPC410/gbpserial.c.orig Tue May 13 16:49:38 2003
++++ GemPC410/gbpserial.c Tue May 13 16:53:04 2003
+@@ -410,7 +410,7 @@
+ return STATUS_UNSUCCESSFUL;
+ }
+
+- sprintf(dev_name, "/dev/pcsc/%d", (int) channel);
++ sprintf(dev_name, "/dev/cuaa%d", (int) channel);
+
+ /* check if the same channel is not already used */
+ for (i=0; i<PCSCLITE_MAX_CHANNELS; i++)
diff --git a/security/ifd-gempc410/pkg-descr b/security/ifd-gempc410/pkg-descr
new file mode 100644
index 000000000000..de1c5975c681
--- /dev/null
+++ b/security/ifd-gempc410/pkg-descr
@@ -0,0 +1,8 @@
+This port provides a PC/SC IFD handler implementation for GemPLUS serial
+card readers based on the GemCore chipset. Supported readers include the
+GemPC 410, 413-SL and 415 serial smart card readers. The GemPC 410 is also
+known as the IBM-410p which is part of the IBM Smart Card Security Kit.
+
+Note that older readers such as the GCR400 and GCR410 are not supported.
+
+WWW: http://ludovic.rousseau.free.fr/softwares/ifd-GemPC/ifd-GemPC.html
diff --git a/security/ifd-gempc410/pkg-plist b/security/ifd-gempc410/pkg-plist
new file mode 100644
index 000000000000..83954e26a57c
--- /dev/null
+++ b/security/ifd-gempc410/pkg-plist
@@ -0,0 +1,3 @@
+lib/libGemPC410.so
+lib/libGemPC410.so.0
+lib/libGemPC410.so.0.8.0