aboutsummaryrefslogtreecommitdiff
path: root/security/ipsec-tools
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2008-08-01 12:57:25 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2008-08-01 12:57:25 +0000
commitd31eb81ef00bccbe0c464d97599f152383f8d35a (patch)
tree5cb653119382f35fb2fe60069d843efa7f5d256e /security/ipsec-tools
parentee159afdd867566ad0d55a4d650526cbc1cf1678 (diff)
downloadports-d31eb81ef00bccbe0c464d97599f152383f8d35a.tar.gz
ports-d31eb81ef00bccbe0c464d97599f152383f8d35a.zip
Add an WITH_LDAP option
enable hybrid, xauth and mode-cfg per default PR: 125748 Submitted by: Matthew Grooms Approved by: vanhu (maintainer)
Notes
Notes: svn path=/head/; revision=217919
Diffstat (limited to 'security/ipsec-tools')
-rw-r--r--security/ipsec-tools/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/security/ipsec-tools/Makefile b/security/ipsec-tools/Makefile
index 0bfb7de2e639..f468e060b2e3 100644
--- a/security/ipsec-tools/Makefile
+++ b/security/ipsec-tools/Makefile
@@ -43,10 +43,11 @@ OPTIONS= DEBUG "enable Debug support" on \
NATT "enable NAT-Traversal (kernel-patch required)" on \
NATTF "require NAT-Traversal (fail without kernel-patch)" off \
FRAG "enable IKE fragmentation payload support" on \
- HYBRID "enable Hybrid Mode-cfg and Xauth support" off \
- PAM "enable PAM authentication" off \
+ HYBRID "enable Hybrid, Xauth and Mode-cfg support" on \
+ PAM "enable PAM authentication (Xauth server)" off \
+ RADIUS "enable Radius authentication (Xauth server)" off \
+ LDAP "enable LDAP authentication (Xauth server)" off \
GSSAPI "enable GSS-API authentication" off \
- RADIUS "enable Radius authentication" off \
SAUNSPEC "enable Unspecified SA mode" off \
RC5 "enable RC5 encryption (patented)" off \
IDEA "enable IDEA encryption (patented)" off
@@ -132,6 +133,13 @@ CONFIGURE_ARGS+= --with-libradius
CONFIGURE_ARGS+= --without-libradius
.endif
+.ifdef(WITH_LDAP)
+USE_OPENLDAP= YES
+CONFIGURE_ARGS+= --with-libldap=${LOCALBASE}
+.else
+CONFIGURE_ARGS+= --without-libldap
+.endif
+
.ifdef(WITH_SAUNSPEC)
CONFIGURE_ARGS+= --enable-samode-unspec
.else