aboutsummaryrefslogtreecommitdiff
path: root/security/john
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2010-05-22 11:08:09 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2010-05-22 11:08:09 +0000
commit026cfe3180ff3d6a06cae53e59ab4b82b718593e (patch)
treefb4362ab040de51425b88497c3a903c8450b4bda /security/john
parentf053a0493f28ea220cf24e5aa09e503d1f730508 (diff)
downloadports-026cfe3180ff3d6a06cae53e59ab4b82b718593e.tar.gz
ports-026cfe3180ff3d6a06cae53e59ab4b82b718593e.zip
- Update to version 1.7.5 and the latest contributed patchset [*]
- Prefer HTTP mirrors as they are generally more accessible than FTP ones - Install support scripts in addition to datafiles - Simplify PORTDOCS handling, utilize BUILD_WRKSRC, and clean up things PR: ports/146114 [*] Submitted by: lme
Notes
Notes: svn path=/head/; revision=254824
Diffstat (limited to 'security/john')
-rw-r--r--security/john/Makefile55
-rw-r--r--security/john/distinfo12
-rw-r--r--security/john/files/patch-params.h4
-rw-r--r--security/john/pkg-plist4
4 files changed, 36 insertions, 39 deletions
diff --git a/security/john/Makefile b/security/john/Makefile
index f5e684d19c20..2f647586d8eb 100644
--- a/security/john/Makefile
+++ b/security/john/Makefile
@@ -1,4 +1,4 @@
-# Ports collection makefile for: John the Ripper
+# New ports collection makefile for: John the Ripper
# Date created: Sun Mar 09, 1997
# Whom: David O'Brien <obrien@FreeBSD.org>
#
@@ -6,36 +6,31 @@
#
PORTNAME= john
-PORTVERSION= 1.7.2
-PORTREVISION= 1
+PORTVERSION= 1.7.5
CATEGORIES= security
-MASTER_SITES= http://www.openwall.com/john/f/ \
- ftp://ftp.ru.openwall.com/pub/projects/john/${PORTVERSION}/ \
- ftp://ftp.se.openwall.com/pub/projects/john/${PORTVERSION}/ \
- http://distro.ibiblio.org/pub/linux/distributions/openwall/projects/john/${PORTVERSION}/
+MASTER_SITES= http://www.openwall.com/john/g/ \
+ http://mirrors.kernel.org/openwall/projects/john/${PORTVERSION}/ \
+ http://distro.ibiblio.org/pub/linux/distributions/openwall/projects/john/${PORTVERSION}/ \
+ http://gd.tuwien.ac.at/opsys/linux/openwall/projects/john/${PORTVERSION}/
-PATCH_SITES= ftp://ftp.openwall.com/pub/projects/john/contrib/ \
- http://www.mirrorgeek.com/openwall/projects/john/contrib/ \
- ftp://ftp.cert.dfn.de/pub/tools/net/Openwall/projects/john/contrib/ \
- http://ftp.sunet.se/pub/security/tools/net/Openwall/projects/john/contrib/
-PATCHFILES= john-${PORTVERSION}-all-9.diff.gz
-PATCH_DIST_STRIP= -p2
+PATCH_SITES= ${MASTER_SITES:H:H:S/$/\/contrib\//}
+PATCHFILES= john-${PORTVERSION}-jumbo-3.diff.gz
+PATCH_DIST_STRIP= -p1
MAINTAINER= danfe@FreeBSD.org
COMMENT= Featureful Unix password cracker
-DATAFILES= all.chr alnum.chr alpha.chr digits.chr lanman.chr password.lst
-PORTDOCS= CHANGES CONFIG EXAMPLES EXTERNAL FAQ MODES OPTIONS README \
- RULES CONTACT CREDITS
-
-WRKSRC= ${WRKDIR}/${DISTNAME}/src
USE_BZIP2= yes
+BUILD_WRKSRC= ${WRKDIR}/${DISTNAME}/src
OSNAME= ${OPSYS:L}
CFLAGS+= -DJOHN_SYSTEMWIDE=1 \
-DJOHN_SYSTEMWIDE_HOME=\\"${DATADIR}\\" \
-DCFG_FULL_NAME=\\"${PREFIX}/etc/${PORTNAME}.conf\\"
+PORTDOCS= CHANGES CONFIG EXAMPLES EXTERNAL FAQ MODES OPTIONS README \
+ RULES CONTACT CREDITS
+
.include <bsd.port.pre.mk>
.if ${ARCH} == "i386"
@@ -57,7 +52,9 @@ ALL_TARGET= generic
post-patch:
@${REINPLACE_CMD} -e 's|= gcc|= ${CC}|g' \
-e 's|CFLAGS =.*|CFLAGS = -c ${CFLAGS}|g' \
- ${WRKSRC}/Makefile
+ ${WRKSRC}/src/Makefile
+ @${REINPLACE_CMD} -i '' -e 's|/usr/bin|${LOCALBASE}/bin|' \
+ ${WRKSRC}/run/*.rb
pre-build:
@${ECHO}
@@ -65,26 +62,22 @@ pre-build:
@${ECHO}
do-install:
- ${INSTALL_PROGRAM} ${WRKDIR}/${DISTNAME}/run/john ${PREFIX}/bin
-.for l in xtract unshadow
- ${LN} -sf ${PREFIX}/bin/john ${PREFIX}/bin/${l}
-.endfor
+ ${INSTALL_PROGRAM} ${WRKSRC}/run/john ${PREFIX}/bin
+ ${LN} -sf john ${PREFIX}/bin/xtract
+ ${LN} -sf john ${PREFIX}/bin/unshadow
@${MKDIR} ${DATADIR}
-.for f in ${DATAFILES}
- ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/run/${f} ${DATADIR}
-.endfor
- ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/run/john.conf \
+ ${INSTALL_DATA} ${WRKSRC}/run/*.??? ${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/run/*.?? ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/run/john.conf \
${PREFIX}/etc/john.conf.default
.if !exists(${PREFIX}/etc/john.conf)
- ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/run/john.conf \
+ ${INSTALL_DATA} ${WRKSRC}/run/john.conf \
${PREFIX}/etc/john.conf
.endif
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
-.for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/doc/${f} ${DOCSDIR}
-.endfor
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/doc/|} ${DOCSDIR}
.endif
.include <bsd.port.post.mk>
diff --git a/security/john/distinfo b/security/john/distinfo
index 57ee8f08e2c9..211034c64d00 100644
--- a/security/john/distinfo
+++ b/security/john/distinfo
@@ -1,6 +1,6 @@
-MD5 (john-1.7.2.tar.bz2) = dc6a6c2a885110ccb5da4c1e2010cb07
-SHA256 (john-1.7.2.tar.bz2) = 7e2ca95ce9038771adb009133feb1b508698244449ceed84b6442f83327c5d58
-SIZE (john-1.7.2.tar.bz2) = 691706
-MD5 (john-1.7.2-all-9.diff.gz) = 1f31bea932892bf3de13a748ee82ccde
-SHA256 (john-1.7.2-all-9.diff.gz) = 44555f9c2b630d9c35597f1a4319379f4e3f452ab2103b21cee8d3ebe6d38bbe
-SIZE (john-1.7.2-all-9.diff.gz) = 70430
+MD5 (john-1.7.5.tar.bz2) = ee8dd47bdabb2d6f9e5f3adc2f67d013
+SHA256 (john-1.7.5.tar.bz2) = 3b3516a6c7bce51b43eb2330f18f8836b15013045a53c9fa66fe806109317b31
+SIZE (john-1.7.5.tar.bz2) = 664942
+MD5 (john-1.7.5-jumbo-3.diff.gz) = 6d560ae48c32feb167c35eca6748a6fa
+SHA256 (john-1.7.5-jumbo-3.diff.gz) = 52ee28ef8bc442208c04ad82bdc68b17705832900daa95909a9346cf8e815d22
+SIZE (john-1.7.5-jumbo-3.diff.gz) = 193764
diff --git a/security/john/files/patch-params.h b/security/john/files/patch-params.h
index 03c4150ecfdb..206e9cc7accf 100644
--- a/security/john/files/patch-params.h
+++ b/security/john/files/patch-params.h
@@ -1,5 +1,5 @@
---- params.h.orig Mon May 8 15:14:13 2006
-+++ params.h Mon May 8 15:16:41 2006
+--- src/params.h.orig
++++ src/params.h
@@ -101,7 +101,11 @@
/*
* File names.
diff --git a/security/john/pkg-plist b/security/john/pkg-plist
index 874e09ed9a7b..951881af75d9 100644
--- a/security/john/pkg-plist
+++ b/security/john/pkg-plist
@@ -8,6 +8,10 @@ etc/john.conf.default
%%DATADIR%%/alnum.chr
%%DATADIR%%/alpha.chr
%%DATADIR%%/digits.chr
+%%DATADIR%%/genincstats.rb
%%DATADIR%%/lanman.chr
+%%DATADIR%%/netntlm.pl
+%%DATADIR%%/netscreen.py
%%DATADIR%%/password.lst
+%%DATADIR%%/sap_prepare.pl
@dirrm %%DATADIR%%