aboutsummaryrefslogtreecommitdiff
path: root/security/keepassx
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-11-22 18:48:41 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-11-22 18:48:41 +0000
commitb97da74ba178e9549f263a61096f4290025a49e0 (patch)
treed7320ee297df0faad45e9850d18053f0d7a29e92 /security/keepassx
parent3de3028d382ea1cb335ca8f044442e37d2caa56d (diff)
downloadports-b97da74ba178e9549f263a61096f4290025a49e0.tar.gz
ports-b97da74ba178e9549f263a61096f4290025a49e0.zip
- Convert to USES=qmake (and other USES while I'm here)
- Add state support - Convert LIB_DEPENDS to new style, adjust USE_QT4 components, etc. Approved by: portmgr (blanket approval)
Notes
Notes: svn path=/head/; revision=334603
Diffstat (limited to 'security/keepassx')
-rw-r--r--security/keepassx/Makefile16
-rw-r--r--security/keepassx/pkg-plist2
2 files changed, 3 insertions, 15 deletions
diff --git a/security/keepassx/Makefile b/security/keepassx/Makefile
index a5a6f2bcb4fb..103ab100a931 100644
--- a/security/keepassx/Makefile
+++ b/security/keepassx/Makefile
@@ -11,25 +11,15 @@ DISTNAME= ${PORTNAME:L}-${PORTVERSION}
MAINTAINER= swills@FreeBSD.org
COMMENT= Cross Platform Password Manager
-RUN_DEPENDS= update-mime-database:${PORTSDIR}/misc/shared-mime-info
-
DATADIR= ${PREFIX}/share/${PORTNAME:L}
WRKSRC= ${WRKDIR}/${PORTNAME:L}-${PORTVERSION}
-USE_QT4= qmake_build moc_build uic_build qt3support_build rcc_build \
+USES= qmake shared-mime-info
+USE_QT4= moc_build uic_build qt3support_build rcc_build \
corelib gui xml
-HAS_CONFIGURE= yes
USE_XORG= xt inputproto xtst xrender xrandr xfixes xcursor\
xext x11 sm ice xi
-NO_STAGE= yes
-do-configure:
- @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
- ${QMAKE} -unix PREFIX=${PREFIX} \
- INCLUDEPATH+=${LOCALBASE}/include LIBS+=-L${LOCALBASE}/lib \
- keepassx.pro
-
-post-install:
- -@update-mime-database ${LOCALBASE}/share/mime
+QMAKE_ARGS+= INCLUDEPATH+=${LOCALBASE}/include LIBS+=-L${LOCALBASE}/lib
.include <bsd.port.mk>
diff --git a/security/keepassx/pkg-plist b/security/keepassx/pkg-plist
index bd1705ef11e9..03a4f2537b05 100644
--- a/security/keepassx/pkg-plist
+++ b/security/keepassx/pkg-plist
@@ -103,5 +103,3 @@ share/pixmaps/keepassx.xpm
@dirrmtry share/mimelnk
@dirrmtry share/mime/packages
@dirrmtry share/mime
-@exec %%LOCALBASE%%/bin/update-mime-database %D/share/mime
-@unexec %%LOCALBASE%%/bin/update-mime-database %D/share/mime