aboutsummaryrefslogtreecommitdiff
path: root/security/krb5
diff options
context:
space:
mode:
authorJacques Vidrine <nectar@FreeBSD.org>2000-01-16 19:10:58 +0000
committerJacques Vidrine <nectar@FreeBSD.org>2000-01-16 19:10:58 +0000
commit001fea0ac5122bce806af0559126b4acea59e2a9 (patch)
tree18760dda569ccb8bfa5faa7a46d4d11dc496e0fe /security/krb5
parentbaf5904ba8907feb7e071a5dcc398c7b7d028d0e (diff)
downloadports-001fea0ac5122bce806af0559126b4acea59e2a9.tar.gz
ports-001fea0ac5122bce806af0559126b4acea59e2a9.zip
Update 1.1 -> 1.1.1
Notes
Notes: svn path=/head/; revision=24777
Diffstat (limited to 'security/krb5')
-rw-r--r--security/krb5/Makefile2
-rw-r--r--security/krb5/distinfo2
-rw-r--r--security/krb5/files/patch-as338
-rw-r--r--security/krb5/files/patch-ba20
-rw-r--r--security/krb5/files/patch-bb10
5 files changed, 156 insertions, 216 deletions
diff --git a/security/krb5/Makefile b/security/krb5/Makefile
index 3c37aafcaeeb..ddbae5cc5440 100644
--- a/security/krb5/Makefile
+++ b/security/krb5/Makefile
@@ -6,7 +6,7 @@
# $FreeBSD$
#
-DISTNAME= krb5-1.1
+DISTNAME= krb5-1.1.1
CATEGORIES= security
MASTER_SITES= # manual download
EXTRACT_SUFX= .tar
diff --git a/security/krb5/distinfo b/security/krb5/distinfo
index e465f8c0c7b1..75d29331a2be 100644
--- a/security/krb5/distinfo
+++ b/security/krb5/distinfo
@@ -1 +1 @@
-MD5 (krb5-1.1.tar) = 7a2c9796f40cd5d0c71e4caa75d2aa7b
+MD5 (krb5-1.1.1.tar) = 33ab7d6e99fc09787f0ecce21df46086
diff --git a/security/krb5/files/patch-as b/security/krb5/files/patch-as
index 519a1c74d4cb..badcda3daa6b 100644
--- a/security/krb5/files/patch-as
+++ b/security/krb5/files/patch-as
@@ -1,194 +1,144 @@
-*** clients/ksu/main.c.ORIG Fri Feb 6 19:41:57 1998
---- clients/ksu/main.c Tue Jun 30 19:46:02 1998
-***************
-*** 56,62 ****
- ill specified arguments to commands */
-
- void usage (){
-! fprintf(stderr, "Usage: %s [target user] [-n principal] [-c source cachename] [-C target cachename] [-k] [-D] [-r time] [-pf] [-l lifetime] [-zZ] [-q] [-e command [args... ] ] [-a [args... ] ]\n", prog_name);
-
- }
-
---- 56,62 ----
- ill specified arguments to commands */
-
- void usage (){
-! fprintf(stderr, "Usage: %s [target user] [-m] [-n principal] [-c source cachename] [-C target cachename] [-k] [-D] [-r time] [-pf] [-l lifetime] [-zZ] [-q] [-e command [args... ] ] [-a [args... ] ]\n", prog_name);
-
- }
-
-***************
-*** 75,80 ****
---- 75,81 ----
- int argc;
- char ** argv;
- {
-+ int asme = 0;
- int hp =0;
- int some_rest_copy = 0;
- int all_rest_copy = 0;
-***************
-*** 90,95 ****
---- 91,97 ----
- char * cc_target_tag = NULL;
- char * target_user = NULL;
- char * source_user;
-+ char * source_shell;
-
- krb5_ccache cc_source = NULL;
- char * cc_source_tag = NULL;
-***************
-*** 174,180 ****
- }
-
-
-! while(!done && ((option = getopt(pargc, pargv,"n:c:C:r:a:zZDfpkql:e:")) != -1)){
- switch (option) {
- case 'r':
- options.opt |= KDC_OPT_RENEWABLE;
---- 176,182 ----
- }
-
-
-! while(!done && ((option = getopt(pargc, pargv,"n:c:C:r:a:zZDfpkmql:e:")) != -1)){
- switch (option) {
- case 'r':
- options.opt |= KDC_OPT_RENEWABLE;
-***************
-*** 216,221 ****
---- 218,226 ----
- errflg++;
- }
- break;
-+ case 'm':
-+ asme = 1;
-+ break;
- case 'n':
- if ((retval = krb5_parse_name(ksu_context, optarg, &client))){
- com_err(prog_name, retval, "when parsing name %s", optarg);
-***************
-*** 355,362 ****
- exit(1);
- }
-
-! /* allocate space and copy the usernamane there */
- source_user = strdup(pwd->pw_name);
- source_uid = pwd->pw_uid;
- source_gid = pwd->pw_gid;
-
---- 360,368 ----
- exit(1);
- }
-
-! /* allocate space and copy the username there */
- source_user = strdup(pwd->pw_name);
-+ source_shell = strdup(pwd->pw_shell);
- source_uid = pwd->pw_uid;
- source_gid = pwd->pw_gid;
-
-***************
-*** 727,769 ****
- /* get the shell of the user, this will be the shell used by su */
- target_pwd = getpwnam(target_user);
-
-! if (target_pwd->pw_shell)
-! shell = strdup(target_pwd->pw_shell);
-! else {
-! shell = _DEF_CSH; /* default is cshell */
-! }
-
- #ifdef HAVE_GETUSERSHELL
-
- /* insist that the target login uses a standard shell (root is omited) */
-
-! if (!standard_shell(target_pwd->pw_shell) && source_uid) {
-! fprintf(stderr, "ksu: permission denied (shell).\n");
-! sweep_up(ksu_context, use_source_cache, cc_target);
-! exit(1);
- }
- #endif /* HAVE_GETUSERSHELL */
-
-! if (target_pwd->pw_uid){
-!
-! if(set_env_var("USER", target_pwd->pw_name)){
-! fprintf(stderr,"ksu: couldn't set environment variable USER\n");
-! sweep_up(ksu_context, use_source_cache, cc_target);
-! exit(1);
-! }
-! }
-!
-! if(set_env_var( "HOME", target_pwd->pw_dir)){
-! fprintf(stderr,"ksu: couldn't set environment variable USER\n");
-! sweep_up(ksu_context, use_source_cache, cc_target);
-! exit(1);
-! }
-!
-! if(set_env_var( "SHELL", shell)){
-! fprintf(stderr,"ksu: couldn't set environment variable USER\n");
-! sweep_up(ksu_context, use_source_cache, cc_target);
-! exit(1);
-! }
-
- /* set the cc env name to target */
-
---- 733,792 ----
- /* get the shell of the user, this will be the shell used by su */
- target_pwd = getpwnam(target_user);
-
-! if (asme) {
-! if (source_shell && *source_shell) {
-! shell = strdup(source_shell);
-! } else {
-! shell = _DEF_CSH;
-! }
-! } else {
-! if (target_pwd->pw_shell)
-! shell = strdup(target_pwd->pw_shell);
-! else {
-! shell = _DEF_CSH; /* default is cshell */
-! }
-! }
-
- #ifdef HAVE_GETUSERSHELL
-
- /* insist that the target login uses a standard shell (root is omited) */
-
-! if (asme) {
-! if (!standard_shell(pwd->pw_shell) && source_uid) {
-! fprintf(stderr, "ksu: permission denied (shell).\n");
-! sweep_up(ksu_context, use_source_cache, cc_target);
-! exit(1);
-! }
-! } else {
-! if (!standard_shell(target_pwd->pw_shell) && source_uid) {
-! fprintf(stderr, "ksu: permission denied (shell).\n");
-! sweep_up(ksu_context, use_source_cache, cc_target);
-! exit(1);
-! }
- }
- #endif /* HAVE_GETUSERSHELL */
-
-! if (!asme) {
-! if (target_pwd->pw_uid){
-! if (set_env_var("USER", target_pwd->pw_name)){
-! fprintf(stderr,"ksu: couldn't set environment variable USER\n");
-! sweep_up(ksu_context, use_source_cache, cc_target);
-! exit(1);
-! }
-! }
-!
-! if (set_env_var( "HOME", target_pwd->pw_dir)){
-! fprintf(stderr,"ksu: couldn't set environment variable USER\n");
-! sweep_up(ksu_context, use_source_cache, cc_target);
-! exit(1);
-! }
-!
-! if (set_env_var( "SHELL", shell)){
-! fprintf(stderr,"ksu: couldn't set environment variable USER\n");
-! sweep_up(ksu_context, use_source_cache, cc_target);
-! exit(1);
-! }
-! }
-
- /* set the cc env name to target */
-
+--- clients/ksu/main.c.ORIG Fri Dec 17 14:44:39 1999
++++ clients/ksu/main.c Fri Dec 17 18:52:57 1999
+@@ -56,7 +56,7 @@
+ ill specified arguments to commands */
+
+ void usage (){
+- fprintf(stderr, "Usage: %s [target user] [-n principal] [-c source cachename] [-C target cachename] [-k] [-D] [-r time] [-pf] [-l lifetime] [-zZ] [-q] [-e command [args... ] ] [-a [args... ] ]\n", prog_name);
++ fprintf(stderr, "Usage: %s [target user] [-m] [-n principal] [-c source cachename] [-C target cachename] [-k] [-D] [-r time] [-pf] [-l lifetime] [-zZ] [-q] [-e command [args... ] ] [-a [args... ] ]\n", prog_name);
+
+ }
+
+@@ -75,6 +75,7 @@
+ int argc;
+ char ** argv;
+ {
++int asme = 0;
+ int hp =0;
+ int some_rest_copy = 0;
+ int all_rest_copy = 0;
+@@ -90,6 +91,7 @@
+ char * cc_target_tag = NULL;
+ char * target_user = NULL;
+ char * source_user;
++char * source_shell;
+
+ krb5_ccache cc_source = NULL;
+ const char * cc_source_tag = NULL;
+@@ -173,7 +175,7 @@
+ }
+
+
+- while(!done && ((option = getopt(pargc, pargv,"n:c:r:a:zZDfpkql:e:")) != -1)){
++ while(!done && ((option = getopt(pargc, pargv,"n:c:r:a:zZDfpkmql:e:")) != -1)){
+ switch (option) {
+ case 'r':
+ options.opt |= KDC_OPT_RENEWABLE;
+@@ -219,6 +221,9 @@
+ errflg++;
+ }
+ break;
++ case 'm':
++ asme = 1;
++ break;
+ case 'n':
+ if ((retval = krb5_parse_name(ksu_context, optarg, &client))){
+ com_err(prog_name, retval, "when parsing name %s", optarg);
+@@ -326,6 +331,7 @@
+
+ /* allocate space and copy the usernamane there */
+ source_user = xstrdup(pwd->pw_name);
++ source_shell = xstrdup(pwd->pw_shell);
+ source_uid = pwd->pw_uid;
+ source_gid = pwd->pw_gid;
+
+@@ -699,43 +705,60 @@
+ /* get the shell of the user, this will be the shell used by su */
+ target_pwd = getpwnam(target_user);
+
+- if (target_pwd->pw_shell)
+- shell = xstrdup(target_pwd->pw_shell);
+- else {
+- shell = _DEF_CSH; /* default is cshell */
+- }
++ if (asme) {
++ if (source_shell && *source_shell) {
++ shell = strdup(source_shell);
++ } else {
++ shell = _DEF_CSH;
++ }
++ } else {
++ if (target_pwd->pw_shell)
++ shell = strdup(target_pwd->pw_shell);
++ else {
++ shell = _DEF_CSH; /* default is cshell */
++ }
++ }
+
+ #ifdef HAVE_GETUSERSHELL
+
+ /* insist that the target login uses a standard shell (root is omited) */
+
+- if (!standard_shell(target_pwd->pw_shell) && source_uid) {
+- fprintf(stderr, "ksu: permission denied (shell).\n");
+- sweep_up(ksu_context, use_source_cache, cc_target);
+- exit(1);
++ if (asme) {
++ if (!standard_shell(pwd->pw_shell) && source_uid) {
++ fprintf(stderr, "ksu: permission denied (shell).\n");
++ sweep_up(ksu_context, use_source_cache, cc_target);
++ exit(1);
++ }
++ } else {
++ if (!standard_shell(target_pwd->pw_shell) && source_uid) {
++ fprintf(stderr, "ksu: permission denied (shell).\n");
++ sweep_up(ksu_context, use_source_cache, cc_target);
++ exit(1);
++ }
+ }
+ #endif /* HAVE_GETUSERSHELL */
+
+- if (target_pwd->pw_uid){
+-
+- if(set_env_var("USER", target_pwd->pw_name)){
+- fprintf(stderr,"ksu: couldn't set environment variable USER\n");
+- sweep_up(ksu_context, use_source_cache, cc_target);
+- exit(1);
+- }
+- }
+-
+- if(set_env_var( "HOME", target_pwd->pw_dir)){
+- fprintf(stderr,"ksu: couldn't set environment variable USER\n");
+- sweep_up(ksu_context, use_source_cache, cc_target);
+- exit(1);
+- }
+-
+- if(set_env_var( "SHELL", shell)){
+- fprintf(stderr,"ksu: couldn't set environment variable USER\n");
+- sweep_up(ksu_context, use_source_cache, cc_target);
+- exit(1);
+- }
++ if (!asme) {
++ if (target_pwd->pw_uid){
++ if (set_env_var("USER", target_pwd->pw_name)){
++ fprintf(stderr,"ksu: couldn't set environment variable USER\n");
++ sweep_up(ksu_context, use_source_cache, cc_target);
++ exit(1);
++ }
++ }
++
++ if (set_env_var( "HOME", target_pwd->pw_dir)){
++ fprintf(stderr,"ksu: couldn't set environment variable USER\n");
++ sweep_up(ksu_context, use_source_cache, cc_target);
++ exit(1);
++ }
++
++ if (set_env_var( "SHELL", shell)){
++ fprintf(stderr,"ksu: couldn't set environment variable USER\n");
++ sweep_up(ksu_context, use_source_cache, cc_target);
++ exit(1);
++ }
++ }
+
+ /* set the cc env name to target */
+
diff --git a/security/krb5/files/patch-ba b/security/krb5/files/patch-ba
index f346d9b8e80e..9c4a82b10e66 100644
--- a/security/krb5/files/patch-ba
+++ b/security/krb5/files/patch-ba
@@ -1,13 +1,5 @@
--- appl/bsd/login.c.ORIG Wed Oct 13 12:55:47 1999
+++ appl/bsd/login.c Wed Oct 13 12:56:29 1999
-@@ -518,6 +518,7 @@
- if (!getenv(KRB5_ENV_CCNAME)) {
- sprintf(ccfile, "FILE:/tmp/krb5cc_p%d", getpid());
- setenv(KRB5_ENV_CCNAME, ccfile, 1);
-+ krb5_cc_set_default_name(kcontext, ccfile);
- unlink(ccfile+strlen("FILE:"));
- } else {
- /* note it correctly */
@@ -1303,19 +1304,6 @@
setpriority(PRIO_PROCESS, 0, 0 + PRIO_OFFSET);
}
@@ -86,15 +78,3 @@
setenv("HOME", pwd->pw_dir, 1);
setenv("PATH", LPATH, 1);
-@@ -1748,8 +1749,10 @@
-
- #ifdef KRB5_GET_TICKETS
- /* ccfile[0] is only set if we got tickets above */
-- if (login_krb5_get_tickets && ccfile[0])
-+ if (login_krb5_get_tickets && ccfile[0]) {
- (void) setenv(KRB5_ENV_CCNAME, ccfile, 1);
-+ krb5_cc_set_default_name(kcontext, ccfile);
-+ }
- #endif /* KRB5_GET_TICKETS */
-
- if (tty[sizeof("tty")-1] == 'd')
diff --git a/security/krb5/files/patch-bb b/security/krb5/files/patch-bb
new file mode 100644
index 000000000000..6545ae682c53
--- /dev/null
+++ b/security/krb5/files/patch-bb
@@ -0,0 +1,10 @@
+--- appl/telnet/telnet/Makefile.in.orig Sat Dec 18 10:47:05 1999
++++ appl/telnet/telnet/Makefile.in Sat Dec 18 10:47:13 1999
+@@ -58,7 +58,6 @@
+ $(INSTALL_DATA) $(srcdir)/$$f.1 \
+ ${DESTDIR}$(CLIENT_MANDIR)/`echo $$f|sed '$(transform)'`.1; \
+ done
+- $(INSTALL_DATA) $(srcdir)/tmac.doc ${DESTDIR}$(CLIENT_MANDIR)/tmac.doc
+
+ authenc.o: defines.h externs.h general.h ring.h types.h $(ARPA_TELNET)
+ commands.o: defines.h externs.h general.h ring.h types.h $(ARPA_TELNET)