aboutsummaryrefslogtreecommitdiff
path: root/security/kwallet/Makefile
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2010-05-11 14:21:05 +0000
committerDima Panov <fluffy@FreeBSD.org>2010-05-11 14:21:05 +0000
commit746dafd424713f46f27e6561400a22ae505afdca (patch)
treef4e7e7d7651a2a2e8d4dd6af2b664e2d2f9b6ad3 /security/kwallet/Makefile
parentd23523dad66e233a7e17b2182e13d5ad2cfb641d (diff)
downloadports-746dafd424713f46f27e6561400a22ae505afdca.tar.gz
ports-746dafd424713f46f27e6561400a22ae505afdca.zip
- The FreeBSD KDE team is pleased to announce KDE SC 4.4.3 for FreeBSD
With hat on: kde@
Notes
Notes: svn path=/head/; revision=254138
Diffstat (limited to 'security/kwallet/Makefile')
-rw-r--r--security/kwallet/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/security/kwallet/Makefile b/security/kwallet/Makefile
index 0897812f0847..d5fafbfcb9cb 100644
--- a/security/kwallet/Makefile
+++ b/security/kwallet/Makefile
@@ -6,7 +6,7 @@
PORTNAME= kdeutils
PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 2
+PORTREVISION= 0
CATEGORIES= misc kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
@@ -16,8 +16,6 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Utilities for the KDE4 integrated X11 Desktop
LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp \
- zip.1:${PORTSDIR}/archivers/libzip \
- lzma.0:${PORTSDIR}/archivers/xz \
qimageblitz.4:${PORTSDIR}/x11/qimageblitz \
qca.2:${PORTSDIR}/devel/qca
RUN_DEPENDS= gpg2:${PORTSDIR}/security/gnupg
@@ -28,7 +26,7 @@ USE_BZIP2= yes
USE_QT_VER= 4
USE_PYTHON= 2.5+
KDE4_BUILDENV= yes
-USE_KDE4= kdelibs pimlibs kdeprefix kdehier automoc4 kdeexp kdebase
+USE_KDE4= kdelibs pimlibs kdeprefix kdehier automoc4 kdebase workspace
QT_COMPONENTS= network gui porting xml \
qmake_build moc_build rcc_build uic_build
MAKE_JOBS_SAFE= yes
@@ -37,7 +35,11 @@ MAN1= ark.1
OPTIONS= PRINTER_APPLET "Install printer system tray utility" off
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
+
+.if ${OSVERSION} < 900012
+LIB_DEPENDS+= lzma.0:${PORTSDIR}/archivers/xz
+.endif
.if defined(WITH_PRINTER_APPLET)
RUN_DEPENDS+= ${KDE4_PREFIX}/bin/printer-applet:${PORTSDIR}/print/kdeutils4-printer-applet
@@ -48,4 +50,4 @@ post-patch:
${REINPLACE_CMD} -e '/add_subdirectory.*printer-applet/d' \
${PATCH_WRKSRC}/CMakeLists.txt
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>