aboutsummaryrefslogtreecommitdiff
path: root/security/kwallet
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-12-04 03:47:18 +0000
committerWill Andrews <will@FreeBSD.org>2001-12-04 03:47:18 +0000
commit1d206a3483e848f4589962473bdf169313ea740f (patch)
tree269caee3e56d61cd6318b44d85c3ff64b32d57b6 /security/kwallet
parentfb2c030e15fb4b426c06fee701c06b7f44c272ab (diff)
downloadports-1d206a3483e848f4589962473bdf169313ea740f.tar.gz
ports-1d206a3483e848f4589962473bdf169313ea740f.zip
Upgrade KDE to 2.2.2:
* General: - Support for objprelink. - Hack for autoconf 2.13/automake 1.4. Note that we can't use the standard USE_AUTO* because they change things in work/*; KDE has its own way of doing that. - Light cleanup of extra dirs in the PLISTs provided by my mkplistpkg[1] script. - Speedups of both compile and runtime through the usage of --disable-debug and --enable-final. The latter did not work with the kdemultimedia package, unfortunately. - Patch updates. * audio/kdemultimedia2: - Patch to fix KSCD on FreeBSD[2]. It works very well now. * deskutils/kdepim: - Enable kpilot[3]. Pull in the latest pilot-link stuff. * devel/kdesdk, * devel/kdevelop: - No specific changes. * devel/qt-designer: - Make this port depend almost entirely on qt23 to make it more maintainable, so I don't have to keep hacking the patches to get them to apply. * editors/koffice, * games/kdegames, * graphics/kdegraphics: - No specific changes. * misc/kdeaddons: - SDL is required now. Cull SDL PLIST_SUB and such. - Fix breakage from hardcoding "sdl-config". * misc/kdeutils2: - Fix problem with klaptopdaemon[4] where it didn't properly display the battery time. This patch is untested, but applied. * net/kdenetwork2: - Fix DCC for KSIRC[5]. - Remove ktalkd from the build. It requires some weird thing in the configure script that I don't have time to look at. * sysutils/kdeadmin: - No specific changes. * textproc/kdoc: - Remove bogus requirement that kdoc requires Perl 5.6.0; it sure seems to operate fine with >= 5.005. But I'll let time tell. * www/quanta: - No specific changes (--disable-debug support only). * x11/kde2: - No specific changes. * x11/kdebase2: - Fix ksysguard compile by merging the files from the HEAD branch of KDE CVS that were missing at release time for FreeBSD[6]. :\ * x11/kdelibs2: - Recognize CUPS' spinoff[7]. - Add libxslt dependency since it was removed from kdelibs. - Fix libxml compile problems[8] (accomplished by upgrading). - Remove libkformula from port Makefile; this library has been spun off into koffice. - Fix mode problems with DCOP[9]. This allows you to save files properly. It also seems to be a FreeBSD specific problem. - Fix bashisms in kdeprint/imagetops script[10]. * x11-clocks/kdetoys2: - No specific changes. * x11-toolkits/qt23: - Do NOT upgrade to QT 2.3.2[11]. - Allow devel/qt-designer to depend on this port entirely for the patches by adding a perlre to accomplish this. * x11-wm/kdeartwork: - No specific changes. Thanks to the FreeBSD/KDE[1] team[12] who helped me test these out! [1] http://freebsd.kde.org/; http://www.databits.net/cgi-bin/cvsweb.cgi/scripts/portbuild/mkplistpkg [2] Submitted by: Matthew Holmes <matt@speakeasy.net> [3] PR: 31914 Submitted by: Alan Eldridge <alane@geeksrus.net> [4] PR: 28475 Submitted by: Arun Sharma <arun@sharmas.dhs.org> [5] Submitted by: Luc Morin <luc_m@videotron.ca> [6] Found at: http://webcvs.kde.org/kdebase/ksysguard/ksysguardd/FreeBSD/ [7] PR: 32321 Reported by: gad Submitted by: James A. Halstead <jah4007@cs.rit.edu> [8] PR: 32055 Reported by: William Richard <wrichard@trivalley.com>, others [9] PR: 31629 Submitted by: Alan Eldridge <alane@geeksrus.net> [10] PR: 32358 Submitted by: Alexander N. Kabaev <ak03@gte.com> [11] PR: 31809 Requested by: Nathan Ahlstrom <nrahlstr@winternet.com> (denied) [12] http://freebsd.kde.org/contact.shtml; http://lists.csociety.org/pipermail/kde-freebsd; http://lists.csociety.org/listinfo/kde-freebsd
Notes
Notes: svn path=/head/; revision=51005
Diffstat (limited to 'security/kwallet')
-rw-r--r--security/kwallet/Makefile24
-rw-r--r--security/kwallet/distinfo2
-rw-r--r--security/kwallet/files/patch-portable.cpp20
-rw-r--r--security/kwallet/pkg-plist3
4 files changed, 44 insertions, 5 deletions
diff --git a/security/kwallet/Makefile b/security/kwallet/Makefile
index 42d7e7fffe93..d1ab1df6523f 100644
--- a/security/kwallet/Makefile
+++ b/security/kwallet/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= kdeutils
-PORTVERSION= 2.2.1
+PORTVERSION= 2.2.2
CATEGORIES?= misc kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
@@ -14,11 +14,33 @@ DIST_SUBDIR= KDE
MAINTAINER?= kde@FreeBSD.org
+BUILD_DEPENDS= autoconf213:${PORTSDIR}/devel/autoconf213 \
+ automake14:${PORTSDIR}/devel/automake14 \
+ objprelink:${PORTSDIR}/devel/objprelink
+
USE_KDELIBS_VER=2
USE_BZIP2= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-objprelink
+.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_FINAL)
+CONFIGURE_ARGS+=--enable-final
+.endif
+.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
+CONFIGURE_ARGS+=--disable-debug
+.endif
USE_GMAKE= yes
MAN1= efax.1 efix.1 fax.1
+pre-configure:
+ ${MKDIR} ${WRKSRC}/auto-bin
+.for AC in autoconf autoheader
+ ${LN} -sf ${LOCALBASE}/bin/${AC}213 ${WRKSRC}/auto-bin/${AC}
+.endfor
+.for AM in automake aclocal
+ ${LN} -sf ${LOCALBASE}/bin/${AM}14 ${WRKSRC}/auto-bin/${AM}
+.endfor
+ cd ${WRKSRC} && env PATH=$$PATH:${WRKSRC}/auto-bin \
+ ${GMAKE} -f Makefile.cvs
+
.include <bsd.port.mk>
diff --git a/security/kwallet/distinfo b/security/kwallet/distinfo
index 562818721e98..2a396fa164aa 100644
--- a/security/kwallet/distinfo
+++ b/security/kwallet/distinfo
@@ -1 +1 @@
-MD5 (KDE/kdeutils-2.2.1.tar.bz2) = a511f6be6949d5b1c2f943f3f9ce27a5
+MD5 (KDE/kdeutils-2.2.2.tar.bz2) = 68c3c86d97c3a95079f81b2c7f4bf35a
diff --git a/security/kwallet/files/patch-portable.cpp b/security/kwallet/files/patch-portable.cpp
new file mode 100644
index 000000000000..d6746dc1c282
--- /dev/null
+++ b/security/kwallet/files/patch-portable.cpp
@@ -0,0 +1,20 @@
+--- klaptopdaemon/portable.cpp- Thu Jun 28 00:08:02 2001
++++ klaptopdaemon/portable.cpp Thu Jun 28 00:08:22 2001
+@@ -453,7 +453,7 @@
+ if (ret == -1)
+ return 0;
+
+- return (info.ai_batt_time != 0xffff);
++ return (info.ai_batt_time != -1);
+ }
+
+ //
+@@ -638,7 +638,7 @@
+
+ p.powered = info.ai_acline;
+ p.percentage = (info.ai_batt_life==255 ? 100 : info.ai_batt_life);
+- p.time = (info.ai_batt_time != 0xffff ? info.ai_batt_time/60 : -1);
++ p.time = (info.ai_batt_time != -1 ? info.ai_batt_time/60 : -1);
+ return(p);
+
+ bad:
diff --git a/security/kwallet/pkg-plist b/security/kwallet/pkg-plist
index 451d3587f1ef..a26fa72c3a97 100644
--- a/security/kwallet/pkg-plist
+++ b/security/kwallet/pkg-plist
@@ -251,7 +251,6 @@ share/services/arkpart.desktop
@dirrm share/icons/locolor
@dirrm share/icons/hicolor/48x48/apps
@dirrm share/icons/hicolor/32x32/apps
-@dirrm share/icons/hicolor/16x16/apps
@dirrm share/doc/HTML/en/kpm
@dirrm share/doc/HTML/en/knotes
@dirrm share/doc/HTML/en/klprfax
@@ -308,7 +307,6 @@ share/services/arkpart.desktop
@dirrm share/apps/ark/icons/hicolor
@dirrm share/apps/ark/icons
@dirrm share/apps/ark
-@dirrm share/apps
@dirrm share/applnk/Utilities
@dirrm share/applnk/System
@dirrm share/applnk/Settings/PowerControl
@@ -316,4 +314,3 @@ share/services/arkpart.desktop
@dirrm share/applnk/Settings
@dirrm share/applnk/Editors
@dirrm share/applnk
-@dirrm lib/kde2