aboutsummaryrefslogtreecommitdiff
path: root/security/libgnomesu
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2005-01-12 17:57:48 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2005-01-12 17:57:48 +0000
commit9e8cf22af25119845c29da3ffb2351b1c68c1bda (patch)
tree4042b84d4f9e7374ff9760b8ac58aed8765dc44e /security/libgnomesu
parent1fcf66691d0c3772198f5a53c04a08c836518a51 (diff)
downloadports-9e8cf22af25119845c29da3ffb2351b1c68c1bda.tar.gz
ports-9e8cf22af25119845c29da3ffb2351b1c68c1bda.zip
libgnomesu is a library for providing superuser privileges to GNOME
applications. It supports consolehelper, PAM and su. libgnomesu will use one the following services (in order of priority), depending on which one is available: - consolehelper - PAM - su libgnomesu will use the su-based backend as final fallback, if no other services are available. This service uses a backend which is a modified version of GNU su. libgnomesu comes with the GUI frontend 'gnomesu' and a Nautilus component for Nautilus integration. WWW: http://members1.chello.nl/~h.lai/libgnomesu/
Notes
Notes: svn path=/head/; revision=126241
Diffstat (limited to 'security/libgnomesu')
-rw-r--r--security/libgnomesu/Makefile29
-rw-r--r--security/libgnomesu/distinfo2
-rw-r--r--security/libgnomesu/pkg-descr17
-rw-r--r--security/libgnomesu/pkg-plist46
4 files changed, 94 insertions, 0 deletions
diff --git a/security/libgnomesu/Makefile b/security/libgnomesu/Makefile
new file mode 100644
index 000000000000..39ada7dc83ca
--- /dev/null
+++ b/security/libgnomesu/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: libgnomesu
+# Date created: 12 January 2005
+# Whom: Adam Weinberger <adamw@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libgnomesu
+PORTVERSION= 0.9.6
+CATEGORIES= security gnome
+MASTER_SITES= http://members1.chello.nl/~h.lai/libgnomesu/
+
+MAINTAINER= adamw@FreeBSD.org
+COMMENT= Library for su integration with GNOME apps
+
+USE_X_PREFIX= yes
+USE_GETOPT_LONG=yes
+USE_LIBTOOL_VER=15
+USE_GMAKE= yes
+USE_GNOME= gnomehack gnomeprefix libgnomeui
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/api.html ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/libgnomesu.css ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/libgnomesu/distinfo b/security/libgnomesu/distinfo
new file mode 100644
index 000000000000..bee77c788985
--- /dev/null
+++ b/security/libgnomesu/distinfo
@@ -0,0 +1,2 @@
+MD5 (libgnomesu-0.9.6.tar.gz) = 60b38df9aeee0b6dc9ec3b68e0d23d38
+SIZE (libgnomesu-0.9.6.tar.gz) = 435623
diff --git a/security/libgnomesu/pkg-descr b/security/libgnomesu/pkg-descr
new file mode 100644
index 000000000000..fdeaecac4b4c
--- /dev/null
+++ b/security/libgnomesu/pkg-descr
@@ -0,0 +1,17 @@
+libgnomesu is a library for providing superuser privileges to GNOME
+applications. It supports consolehelper, PAM and su.
+
+libgnomesu will use one the following services (in order of priority),
+depending on which one is available:
+- consolehelper
+- PAM
+- su
+
+libgnomesu will use the su-based backend as final fallback, if no other
+services are available. This service uses a backend which is a modified
+version of GNU su.
+
+libgnomesu comes with the GUI frontend 'gnomesu' and a Nautilus component
+for Nautilus integration.
+
+WWW: http://members1.chello.nl/~h.lai/libgnomesu/
diff --git a/security/libgnomesu/pkg-plist b/security/libgnomesu/pkg-plist
new file mode 100644
index 000000000000..6809005e8936
--- /dev/null
+++ b/security/libgnomesu/pkg-plist
@@ -0,0 +1,46 @@
+bin/gnomesu
+include/libgnomesu-1.0/libgnomesu/gnomesu-auth-dialog.h
+include/libgnomesu-1.0/libgnomesu/libgnomesu.h
+lib/libgnomesu.a
+lib/libgnomesu.so
+lib/libgnomesu.so.1
+libdata/pkgconfig/libgnomesu-1.0.pc
+libexec/gnomesu-backend
+libexec/gnomesu-pam-backend
+%%PORTDOCS%%%%DOCSDIR%%/api.html
+%%PORTDOCS%%%%DOCSDIR%%/libgnomesu.css
+share/gnome/application-registry/gnomesu-nautilus.applications
+share/gnome/mime-info/gnomesu-nautilus.keys
+share/locale/az/LC_MESSAGES/libgnomesu-1.0.mo
+share/locale/bg/LC_MESSAGES/libgnomesu-1.0.mo
+share/locale/bs/LC_MESSAGES/libgnomesu-1.0.mo
+share/locale/ca/LC_MESSAGES/libgnomesu-1.0.mo
+share/locale/cs/LC_MESSAGES/libgnomesu-1.0.mo
+share/locale/da/LC_MESSAGES/libgnomesu-1.0.mo
+share/locale/de/LC_MESSAGES/libgnomesu-1.0.mo
+share/locale/el/LC_MESSAGES/libgnomesu-1.0.mo
+share/locale/en_CA/LC_MESSAGES/libgnomesu-1.0.mo
+share/locale/en_GB/LC_MESSAGES/libgnomesu-1.0.mo
+share/locale/es/LC_MESSAGES/libgnomesu-1.0.mo
+share/locale/fi/LC_MESSAGES/libgnomesu-1.0.mo
+share/locale/fr/LC_MESSAGES/libgnomesu-1.0.mo
+share/locale/gu/LC_MESSAGES/libgnomesu-1.0.mo
+share/locale/hr/LC_MESSAGES/libgnomesu-1.0.mo
+share/locale/hu/LC_MESSAGES/libgnomesu-1.0.mo
+share/locale/ko/LC_MESSAGES/libgnomesu-1.0.mo
+share/locale/lt/LC_MESSAGES/libgnomesu-1.0.mo
+share/locale/ms/LC_MESSAGES/libgnomesu-1.0.mo
+share/locale/nb/LC_MESSAGES/libgnomesu-1.0.mo
+share/locale/nl/LC_MESSAGES/libgnomesu-1.0.mo
+share/locale/pa/LC_MESSAGES/libgnomesu-1.0.mo
+share/locale/pl/LC_MESSAGES/libgnomesu-1.0.mo
+share/locale/pt/LC_MESSAGES/libgnomesu-1.0.mo
+share/locale/pt_BR/LC_MESSAGES/libgnomesu-1.0.mo
+share/locale/sk/LC_MESSAGES/libgnomesu-1.0.mo
+share/locale/sr/LC_MESSAGES/libgnomesu-1.0.mo
+share/locale/sr@Latn/LC_MESSAGES/libgnomesu-1.0.mo
+share/locale/sv/LC_MESSAGES/libgnomesu-1.0.mo
+share/locale/zh_CN/LC_MESSAGES/libgnomesu-1.0.mo
+share/locale/zh_TW/LC_MESSAGES/libgnomesu-1.0.mo
+@dirrm include/libgnomesu-1.0/libgnomesu
+%%PORTDOCS%%@dirrm %%DOCSDIR%%