aboutsummaryrefslogtreecommitdiff
path: root/security/libidea
diff options
context:
space:
mode:
authorFoxfair Hu <foxfair@FreeBSD.org>2003-03-25 13:04:56 +0000
committerFoxfair Hu <foxfair@FreeBSD.org>2003-03-25 13:04:56 +0000
commit5282cf001de18d7f2814c68ff0baa4e2fcf74479 (patch)
treec1012d713636087149debcb4a1774e689d37c651 /security/libidea
parent33e059c87ec6c39e86e6adecdd5ed6dd3f5a8c50 (diff)
downloadports-5282cf001de18d7f2814c68ff0baa4e2fcf74479.tar.gz
ports-5282cf001de18d7f2814c68ff0baa4e2fcf74479.zip
Add libidea 0.8.2b, iDEA block cipher library.
PR: 43793 Submitted by: Jim Geovedi <jim@corebsd.or.id>
Notes
Notes: svn path=/head/; revision=77451
Diffstat (limited to 'security/libidea')
-rw-r--r--security/libidea/Makefile29
-rw-r--r--security/libidea/distinfo1
-rw-r--r--security/libidea/files/patch-Makefile25
-rw-r--r--security/libidea/pkg-descr10
-rw-r--r--security/libidea/pkg-plist4
5 files changed, 69 insertions, 0 deletions
diff --git a/security/libidea/Makefile b/security/libidea/Makefile
new file mode 100644
index 000000000000..45f858ebd079
--- /dev/null
+++ b/security/libidea/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: libidea
+# Date created: Sep 30, 2002
+# Whom: Jim Geovedi <jim@corebsd.or.id>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libidea
+PORTVERSION= 0.8.2b
+CATEGORIES= security
+MASTER_SITES= ftp://ftp.funet.fi/pub/mirrors/ftp.psy.uq.oz.au/libeay/ \
+ ftp://ftp.psy.uq.oz.au/pub/Crypto/libeay/ \
+ ftp://ftp.ntnu.no/pub/unix/security/ \
+ ftp://ftp.sunsite.org.uk/Mirrors/ftp.psy.uq.oz.au/pub/Crypto/libeay/
+
+MAINTAINER= jim@corebsd.or.id
+COMMENT= IDEA block cipher library
+
+RESTRICTED= "Crypto; export-controlled"
+
+WRKSRC= ${WRKDIR}/idea
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/ideatest ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/idea_spd ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/libidea.a ${PREFIX}/lib
+ ${INSTALL_DATA} ${WRKSRC}/idea.h ${PREFIX}/include
+
+.include <bsd.port.mk>
diff --git a/security/libidea/distinfo b/security/libidea/distinfo
new file mode 100644
index 000000000000..cc199e7f2b9d
--- /dev/null
+++ b/security/libidea/distinfo
@@ -0,0 +1 @@
+MD5 (libidea-0.8.2b.tar.gz) = d67b25dd2e4a6f3331f4061724d0056a
diff --git a/security/libidea/files/patch-Makefile b/security/libidea/files/patch-Makefile
new file mode 100644
index 000000000000..8dd4813466d3
--- /dev/null
+++ b/security/libidea/files/patch-Makefile
@@ -0,0 +1,25 @@
+--- Makefile.orig Thu Dec 4 20:35:38 1997
++++ Makefile Mon Sep 30 02:55:39 2002
+@@ -5,20 +5,14 @@
+
+ DIR= cast
+ TOP= .
+-CC= gcc
+-CFLAG= -O3 -fomit-frame-pointer
+
+-CPP= $(CC) -E
+-INCLUDES=
+-INSTALLTOP=/usr/local/lib
++CPP?= $(CC) -E
++INSTALLTOP= ${PREFIX}/lib
+ MAKE= make
+ MAKEDEPEND= makedepend
+-MAKEFILE= Makefile.uni
+ AR= ar r
+
+ IDEA_ENC=i_cbc.o
+-
+-CFLAGS= $(INCLUDES) $(CFLAG)
+
+ GENERAL=Makefile
+ TEST=ideatest
diff --git a/security/libidea/pkg-descr b/security/libidea/pkg-descr
new file mode 100644
index 000000000000..6aa2c8b8a738
--- /dev/null
+++ b/security/libidea/pkg-descr
@@ -0,0 +1,10 @@
+IDEA is a block cipher invented by Xuejia Lai and James Massey in
+1991. A block cipher is an encryption algorithm that encrypts the
+data in blocks. IDEA has a block size of 64 bits, and a keylength of
+128 bits. IDEA is a symmetrical algorithm, which means that the same
+key is used both for encryption and for decryption.
+
+WWW: http://www.mediacrypt.com/engl/Community/index.asp
+
+ -- Jim Geovedi
+ jim@corebsd.or.id
diff --git a/security/libidea/pkg-plist b/security/libidea/pkg-plist
new file mode 100644
index 000000000000..f61bf752f369
--- /dev/null
+++ b/security/libidea/pkg-plist
@@ -0,0 +1,4 @@
+bin/ideatest
+bin/idea_spd
+include/idea.h
+lib/libidea.a