aboutsummaryrefslogtreecommitdiff
path: root/security/libkleo/Makefile
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-04-10 19:09:05 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-04-10 19:09:05 +0000
commit39fa5f95a7f2bf0a028e458c3104f66d433200e6 (patch)
treeb52ff8a578bde97936b79f311d6970fac2593475 /security/libkleo/Makefile
parent34e997ccb06a8f151001292998a5c99019fa9d5a (diff)
downloadports-39fa5f95a7f2bf0a028e458c3104f66d433200e6.tar.gz
ports-39fa5f95a7f2bf0a028e458c3104f66d433200e6.zip
New ports: KDE Applications net/ and dependencies
* deskutils/grantleetheme * deskutils/kdepim * deskutils/kdepim-apps-libs * deskutils/libkdepim * net/akonadi-calendar * net/akonadi-contacts * net/akonadi-mime * net/akonadi-notes * net/akonadi-search * net/calendarsupport * net/eventviews * net/incidenceeditor * net/kalarmcal * net/kblog * net/kcalcore * net/kcalutils * net/kcontacts * net/kdav * net/kdenetwork-filesharing * net/kget * net/kidentitymanagement * net/kimap * net/kldap * net/kmailtransport * net/kmbox * net/kmime * net/kontactinterface * net/kpimtextedit * net/krdc * net/krfb * net/ksmtp * net/ktnef * net/libgravatar * net/libkgapi * net/libksieve * net/mailcommon * net/mailimporter * net/messagelib * net/pimcommon * net/zeroconf-ioslave * security/libkleo This is the current version of KDE Applications <foo>. Note that users of KDE SC4 should stick with <foo>-kde4. This adds a slew of KDE Pim related ports and some of their dependencies. Note, that KDE Pim has a history of working poorly on FreeBSD.
Notes
Notes: svn path=/head/; revision=467007
Diffstat (limited to 'security/libkleo/Makefile')
-rw-r--r--security/libkleo/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/security/libkleo/Makefile b/security/libkleo/Makefile
new file mode 100644
index 000000000000..0052d70cdc27
--- /dev/null
+++ b/security/libkleo/Makefile
@@ -0,0 +1,33 @@
+# $FreeBSD$
+
+PORTNAME= libkleo
+DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+CATEGORIES= security kde kde-applications
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Certificate manager for KDE
+
+LIB_DEPENDS= libassuan.so:security/libassuan \
+ libgpg-error.so:security/libgpg-error \
+ libgpgme.so:security/gpgme \
+ libqgpgme.so:security/gpgme-qt5 \
+ libgpgmepp.so:security/gpgme-cpp
+RUN_DEPENDS= ${LOCALBASE}/bin/gmd5sum:sysutils/coreutils
+
+
+USES= cmake:outsource gettext kde:5 tar:xz
+USE_KDE= codecs completion config coreaddons i18n itemmodels \
+ widgetsaddons windowsystem \
+ pimtextedit
+USE_QT5= core gui widgets \
+ buildtools_build qmake_build
+
+post-extract:
+# use the binaries of coreutils
+ ${REINPLACE_CMD} -e '/create-command/ s#sha1sum#gsha1sum#' \
+ -e '/create-command/ s#md5sum#gmd5sum#' \
+ -e '/verify-command/ s#sha1sum#gsha1sum#' \
+ -e '/verify-command/ s#md5sum#gmd5sum#' \
+ ${PATCH_WRKSRC}/src/libkleopatrarc.desktop
+
+.include <bsd.port.mk>