aboutsummaryrefslogtreecommitdiff
path: root/security/libparanoia
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-08-03 07:52:47 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-08-03 07:52:47 +0000
commite5f34fc2bed43e9f7dbfb1db9e1c7f7c187d9b74 (patch)
tree646fb06dc4de9e27720eb170d0a5fdb6e517ce1c /security/libparanoia
parenta5ab426486eaaf44339f7ef9f85e1b5bceacc89d (diff)
downloadports-e5f34fc2bed43e9f7dbfb1db9e1c7f7c187d9b74.tar.gz
ports-e5f34fc2bed43e9f7dbfb1db9e1c7f7c187d9b74.zip
In gets(), two return's exist, and both should be wrapped with exit_violation.
In current version, one is forgotten. Bump PORTREVISION. PR: 41277 Submitted by: Valentin Nechayev <netch@netch.kiev.ua>
Notes
Notes: svn path=/head/; revision=63892
Diffstat (limited to 'security/libparanoia')
-rw-r--r--security/libparanoia/Makefile1
-rw-r--r--security/libparanoia/files/patch-ab14
2 files changed, 15 insertions, 0 deletions
diff --git a/security/libparanoia/Makefile b/security/libparanoia/Makefile
index 2da637f1a10a..c6065de59ec4 100644
--- a/security/libparanoia/Makefile
+++ b/security/libparanoia/Makefile
@@ -6,6 +6,7 @@
PORTNAME= libparanoia
PORTVERSION= 1.4
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= ftp://ftp.lexa.ru/pub/domestic/snar/
diff --git a/security/libparanoia/files/patch-ab b/security/libparanoia/files/patch-ab
new file mode 100644
index 000000000000..43ff3e9a36ef
--- /dev/null
+++ b/security/libparanoia/files/patch-ab
@@ -0,0 +1,14 @@
+--- gets.c.orig Wed Dec 30 17:05:40 1998
++++ gets.c Fri Mar 22 23:29:05 2002
+@@ -68,8 +68,10 @@
+ }
+ for (s = buf; (c = getchar()) != '\n';)
+ if (c == EOF)
+- if (s == buf)
++ if (s == buf) {
++ exit_violation();
+ return (NULL);
++ }
+ else
+ break;
+ else