aboutsummaryrefslogtreecommitdiff
path: root/security/libprelude
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-06-07 15:07:26 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-06-07 15:07:26 +0000
commit5fd25bccece3d8585cdc0a8c09887bc6a54d21df (patch)
treebee69b0bc63c58db51b852e0cf36d09950304181 /security/libprelude
parent7c6729fa0885bc7c69a7bef93c48072385d58df2 (diff)
downloadports-5fd25bccece3d8585cdc0a8c09887bc6a54d21df.tar.gz
ports-5fd25bccece3d8585cdc0a8c09887bc6a54d21df.zip
- Update to 0.9.9
PR: ports/98585 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=164725
Diffstat (limited to 'security/libprelude')
-rw-r--r--security/libprelude/Makefile6
-rw-r--r--security/libprelude/distinfo6
-rw-r--r--security/libprelude/files/patch-bindings_Makefile.in11
-rw-r--r--security/libprelude/files/patch-bindings_perl_Prelude.c13
-rw-r--r--security/libprelude/files/patch-src_include_libmissing.h12
5 files changed, 29 insertions, 19 deletions
diff --git a/security/libprelude/Makefile b/security/libprelude/Makefile
index 772100209009..dafa2f8b5786 100644
--- a/security/libprelude/Makefile
+++ b/security/libprelude/Makefile
@@ -4,7 +4,7 @@
# $FreeBSD$
PORTNAME= libprelude
-PORTVERSION= 0.9.8
+PORTVERSION= 0.9.9
CATEGORIES= security
MASTER_SITES= http://www.prelude-ids.org/download/releases/ \
http://www.prelude-ids.org/download/releases/old/
@@ -43,11 +43,9 @@ PLIST_SUB+= WITH_PYTHON="@comment "
.if !defined(NOPORTDOCS)
CONFIGURE_ARGS+= --with-html-dir=${PREFIX}/share/doc
-.include <bsd.port.pre.mk>
-
post-install:
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/docs/api/html/* ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/libprelude/distinfo b/security/libprelude/distinfo
index 568ba013b436..389cf20fdc31 100644
--- a/security/libprelude/distinfo
+++ b/security/libprelude/distinfo
@@ -1,3 +1,3 @@
-MD5 (libprelude-0.9.8.tar.gz) = d46527e7b036d20c3cc72c887486d773
-SHA256 (libprelude-0.9.8.tar.gz) = e4d9e54ba6a55881c33f9e008eb9e70862d17e7fa3210a8a6476aafa09053ee8
-SIZE (libprelude-0.9.8.tar.gz) = 1759203
+MD5 (libprelude-0.9.9.tar.gz) = dc416fa0ef9ed792a84a43cb8a9f6025
+SHA256 (libprelude-0.9.9.tar.gz) = cf713230c2a2f3a9c637abe0cae24b56bb625eee1255dda2f04e0d21645cbc77
+SIZE (libprelude-0.9.9.tar.gz) = 1760237
diff --git a/security/libprelude/files/patch-bindings_Makefile.in b/security/libprelude/files/patch-bindings_Makefile.in
new file mode 100644
index 000000000000..851d1253b525
--- /dev/null
+++ b/security/libprelude/files/patch-bindings_Makefile.in
@@ -0,0 +1,11 @@
+--- bindings/Makefile.in.orig Wed Jun 7 09:35:04 2006
++++ bindings/Makefile.in Wed Jun 7 09:35:50 2006
+@@ -471,7 +471,7 @@
+ #
+ # Workaround invalid Makefile generated by MakeMaker when UTF-8 is enabled.
+ #
+-@HAVE_PERL_TRUE@ cd perl && DESTDIR=$(DESTDIR) LANG="" $(PERL) Makefile.PL && $(MAKE) LD_RUN_PATH="" install
++@HAVE_PERL_TRUE@ cd perl && DESTDIR=$(DESTDIR) LANG="" $(PERL) Makefile.PL && $(MAKE) LD_RUN_PATH="" pure_install
+
+ @HAVE_PYTHON_TRUE@ cd python && $(PYTHON) setup.py install `test -n "$(DESTDIR)" && echo --root $(DESTDIR)`
+
diff --git a/security/libprelude/files/patch-bindings_perl_Prelude.c b/security/libprelude/files/patch-bindings_perl_Prelude.c
new file mode 100644
index 000000000000..738d29fdbe34
--- /dev/null
+++ b/security/libprelude/files/patch-bindings_perl_Prelude.c
@@ -0,0 +1,13 @@
+--- bindings/perl/Prelude.c.orig Tue Jun 6 10:46:03 2006
++++ bindings/perl/Prelude.c Tue Jun 6 10:46:46 2006
+@@ -14,6 +14,10 @@
+ * declarations/attributes, and other compiler dependent labels.
+ *
+ ************************************************************************/
++/* workaround to build with perl-5.005 */
++#ifndef INT2PTR
++# define INT2PTR(type, pointer) (type)(pointer)
++#endif
+
+ /* template workaround for compilers that cannot correctly implement the C++ standard */
+ #ifndef SWIGTEMPLATEDISAMBIGUATOR
diff --git a/security/libprelude/files/patch-src_include_libmissing.h b/security/libprelude/files/patch-src_include_libmissing.h
deleted file mode 100644
index f676366f61c0..000000000000
--- a/security/libprelude/files/patch-src_include_libmissing.h
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/include/libmissing.h.orig Mon May 15 09:10:13 2006
-+++ src/include/libmissing.h Mon May 15 09:09:54 2006
-@@ -35,8 +35,8 @@
- #include <stdbool.h>
- #include <stdlib.h>
- #include <string.h>
--#include <sys/socket.h>
- #include <sys/types.h>
-+#include <sys/socket.h>
- #include <time.h>
- #include "ftw_.h"
- #include "getaddrinfo.h"