aboutsummaryrefslogtreecommitdiff
path: root/security/libsectok
diff options
context:
space:
mode:
authorBruce M Simpson <bms@FreeBSD.org>2003-09-29 00:05:14 +0000
committerBruce M Simpson <bms@FreeBSD.org>2003-09-29 00:05:14 +0000
commit9c94da82a8e41ea42a2e574616b867d8850eb4b5 (patch)
tree66592d94a98bc4713fcbcd8e25e2ac87b6cc410a /security/libsectok
parenta5b076053ebbcdb7ec73c600dcdc88dc90c30fb0 (diff)
downloadports-9c94da82a8e41ea42a2e574616b867d8850eb4b5.tar.gz
ports-9c94da82a8e41ea42a2e574616b867d8850eb4b5.zip
New port: security/libsectok
PR: ports/39777
Notes
Notes: svn path=/head/; revision=89729
Diffstat (limited to 'security/libsectok')
-rw-r--r--security/libsectok/Makefile23
-rw-r--r--security/libsectok/distinfo1
-rw-r--r--security/libsectok/files/patch-Makefile24
-rw-r--r--security/libsectok/pkg-descr8
-rw-r--r--security/libsectok/pkg-plist4
5 files changed, 60 insertions, 0 deletions
diff --git a/security/libsectok/Makefile b/security/libsectok/Makefile
new file mode 100644
index 000000000000..c04c706a948a
--- /dev/null
+++ b/security/libsectok/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: libsectok
+# Date created: 29 September 2003
+# Whom: Bruce M Simpson <bms@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libsectok
+PORTVERSION= 20030619
+CATEGORIES= security
+MASTER_SITES= http://www.citi.umich.edu/projects/smartcard/
+DISTNAME= libsectok-${PORTVERSION}
+
+MAINTAINER= bms@FreeBSD.org
+COMMENT= ISO 7816 Smartcard API Library
+
+INSTALLS_SHLIB= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+USE_OPENSSL= YES
+
+MAN3= sectok.3
+
+.include <bsd.port.mk>
diff --git a/security/libsectok/distinfo b/security/libsectok/distinfo
new file mode 100644
index 000000000000..cc8a6ef69d1a
--- /dev/null
+++ b/security/libsectok/distinfo
@@ -0,0 +1 @@
+MD5 (libsectok-20030619.tar.gz) = 60dac935e7997f0fba3d9bc91f0e7d41
diff --git a/security/libsectok/files/patch-Makefile b/security/libsectok/files/patch-Makefile
new file mode 100644
index 000000000000..42a45b03cb86
--- /dev/null
+++ b/security/libsectok/files/patch-Makefile
@@ -0,0 +1,24 @@
+--- Makefile.orig Thu Jan 3 20:26:00 2002
++++ Makefile Fri Aug 23 13:12:59 2002
+@@ -1,10 +1,10 @@
+ VERSION= 3.1
+ TARGETS= libsectok.a libsectok.so.$(VERSION)
+-PREFIX= /usr/local
++PREFIX?= /usr/local
+
+ # You might have to add -I/usr/include/openssl to CFLAGS
+ CFLAGS= -g -Wall -DDL_READERS
+-LDFLAGS= -x -Bshareable -Bforcearchive -shared
++LDFLAGS= -shared -x --whole-archive
+
+ # You may have to add getopt.c to SRC if your getopt doesn't have optreset
+ SRC= atr.c cmdtab.c cyberflex.c input.c r1r2.c readers.c sc7816.c sectok.c
+@@ -47,6 +47,8 @@
+ install :
+ $(INSTALL) -m 755 sectok.h $(PREFIX)/include
+ $(INSTALL) -m 755 $(TARGETS) $(PREFIX)/lib
++ ln -s $(PREFIX)/lib/libsectok.so.${VERSION} $(PREFIX)/lib/libsectok.so.3
++ $(INSTALL) -m 644 sectok.3 $(PREFIX)/man/man3
+
+ release :
+ rm -rf $(RELEASE)
diff --git a/security/libsectok/pkg-descr b/security/libsectok/pkg-descr
new file mode 100644
index 000000000000..036da163435e
--- /dev/null
+++ b/security/libsectok/pkg-descr
@@ -0,0 +1,8 @@
+This is the libsectok library from citi.umich.edu. Originally targeted
+for OpenBSD. This is a quick port of the library itself; it contains an
+API for working with ISO 7816 Smart Card devices.
+
+WWW: http://www.citi.umich.edu/projects/smartcard/sectok.html
+
+Bruce
+bms@FreeBSD.org
diff --git a/security/libsectok/pkg-plist b/security/libsectok/pkg-plist
new file mode 100644
index 000000000000..75c213f7feb4
--- /dev/null
+++ b/security/libsectok/pkg-plist
@@ -0,0 +1,4 @@
+include/sectok.h
+lib/libsectok.a
+lib/libsectok.so.3.1
+@unexec rm -f lib/libsectok.so.3