aboutsummaryrefslogtreecommitdiff
path: root/security/libsparkcrypto/Makefile
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2013-07-21 14:31:45 +0000
committerJohn Marino <marino@FreeBSD.org>2013-07-21 14:31:45 +0000
commit2d60de8ed2825470a8ed9a2a427f248d2e9ae645 (patch)
tree4c436836600ac9038f2b69ef64b3b7f132040688 /security/libsparkcrypto/Makefile
parent42c75472fbddbfbce1d6e9ab3a01cef6a965387c (diff)
downloadports-2d60de8ed2825470a8ed9a2a427f248d2e9ae645.tar.gz
ports-2d60de8ed2825470a8ed9a2a427f248d2e9ae645.zip
security/libsparkcrypto: Optionally generate documentation
It was not possible to generate libsparkcrypto documentation before the textproc/adabrowse port was created. Now that AdaBrowse is available, add a "DOCS" options to generate the documentation. While here, convert USE_GMAKE to USES+=gmake and fix DESTDIR to work properly instead of installing during the build phase. The Makefile also had to altered to install the documentation as well. Approved by: bapt (mentor)
Notes
Notes: svn path=/head/; revision=323394
Diffstat (limited to 'security/libsparkcrypto/Makefile')
-rw-r--r--security/libsparkcrypto/Makefile28
1 files changed, 18 insertions, 10 deletions
diff --git a/security/libsparkcrypto/Makefile b/security/libsparkcrypto/Makefile
index 552122baab10..7bcf2f0e6674 100644
--- a/security/libsparkcrypto/Makefile
+++ b/security/libsparkcrypto/Makefile
@@ -3,6 +3,7 @@
PORTNAME= libsparkcrypto
PORTVERSION= 0.1.1
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://senier.net/libsparkcrypto/
EXTRACT_SUFX= .tgz
@@ -12,28 +13,35 @@ COMMENT= Cryptographic library implemented in SPARK
LICENSE= BSD
-USES= ada
-USE_GMAKE= yes
+USES= ada gmake
USE_DOS2UNIX= Makefile build/libsparkcrypto.gpr
SPARKARCH:= ${ARCH:S/amd64/x86_64/:S/i386/i686/}
-
-# The APIDOC requires AdaBrowse which in turn requires ASIS which is
-# coupled with the compiler. There is a question whether Adacore's
-# GPL ASIS is even compatible with FSF GNAT, which is what gcc-aux is.
-# Until this question is answered, skip API document building.
+DESTINY= ${WRKDIR}/destino
MAKE_ENV+= SPARKARCH=${SPARKARCH} \
SPARK_DIR=${WRKSRC}/src/spark \
- DESTDIR=${LOCALBASE} \
+ DESTDIR=${DESTINY} \
MODE=release \
RUNTIME=native \
NO_TESTS=true \
- NO_PROOF=true \
- NO_APIDOC=true
+ NO_PROOF=true
+
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
+BUILD_DEPENDS+= adabrowse:${PORTSDIR}/textproc/adabrowse
+.else
+MAKE_ENV+= NO_APIDOC=true
+.endif
post-patch:
# ports passed unwanted ARCH definition to Makefile
@${REINPLACE_CMD} -e 's|ARCH|SPARKARCH|g' \
${WRKSRC}/Makefile
+post-install:
+ ${CP} -pR ${DESTINY}${PREFIX}/ ${PREFIX}/
+
.include <bsd.port.mk>