aboutsummaryrefslogtreecommitdiff
path: root/security/libsparkcrypto/Makefile
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-07-01 16:36:08 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-07-01 16:36:08 +0000
commitec93240f13c45849ce746bd90352037a13921a5d (patch)
tree42be6ec38144d868919b2eaef6a32910e69c6263 /security/libsparkcrypto/Makefile
parent645a48e8a5e70578ac19927e186c81ffe04179fd (diff)
downloadports-ec93240f13c45849ce746bd90352037a13921a5d.tar.gz
ports-ec93240f13c45849ce746bd90352037a13921a5d.zip
security/libsparkcrypto: Cryptographic library implemented in SPARK
libsparkcrypto is a formally verified implementation of several widely used symmetric cryptographic algorithms using the SPARK programming language and toolset. For the complete library proofs of the absence of run-time errors like type range violations, division by zero and numerical overflows are available. Some of its subprograms include proofs of partial correctness. The distribution contains test cases for all implemented algorithms and a benchmark to compare its performance with the OpenSSL library. The achieved speed has been found to be very close to the optimized C and Assembler implementations of OpenSSL. WWW: http://senier.net/libsparkcrypto/ PR: ports/180015 Submitted by: John Marino <draco@marino.st>
Notes
Notes: svn path=/head/; revision=322131
Diffstat (limited to 'security/libsparkcrypto/Makefile')
-rw-r--r--security/libsparkcrypto/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/security/libsparkcrypto/Makefile b/security/libsparkcrypto/Makefile
new file mode 100644
index 000000000000..50742a6e9680
--- /dev/null
+++ b/security/libsparkcrypto/Makefile
@@ -0,0 +1,39 @@
+# Created by: John Marino <draco@marino.st>
+# $FreeBSD$
+
+PORTNAME= libsparkcrypto
+PORTVERSION= 0.1.1
+CATEGORIES= security
+MASTER_SITES= http://senier.net/libsparkcrypto/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= draco@marino.st
+COMMENT= Cryptographic library implemented in SPARK
+
+LICENSE= BSD
+
+USES= ada
+USE_GMAKE= yes
+USE_DOS2UNIX= Makefile build/libsparkcrypto.gpr
+SPARKARCH:= ${ARCH:S/amd64/x86_64/:S/i386/i686/}
+
+# The APIDOC requires AdaBrowse which in turn requires ASIS which is
+# coupled with the compiler. There is a question whether Adacore's
+# GPL ASIS is even compatible with FSF GNAT, which is what gcc-aux is.
+# Until this question is answered, skip API document building.
+
+MAKE_ENV+= SPARKARCH=${SPARKARCH} \
+ SPARK_DIR=${WRKSRC}/src/spark \
+ DESTDIR=${LOCALBASE} \
+ MODE=release \
+ RUNTIME=native \
+ NO_TESTS=true \
+ NO_PROOF=true \
+ NO_APIDOC=true
+
+post-patch:
+ # ports passed unwanted ARCH definition to Makefile
+ @${REINPLACE_CMD} -e 's|ARCH|SPARKARCH|g' \
+ ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>