aboutsummaryrefslogtreecommitdiff
path: root/security/libssh2
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2006-09-07 20:04:19 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2006-09-07 20:04:19 +0000
commit3b3202afc1439bf17dd8ac49cd3c0d76deecc944 (patch)
treebcb84e0fb1709be743a3c33d935d348520a69542 /security/libssh2
parent51cc77af478fa5e305d80458af90a411dcd85cec (diff)
downloadports-3b3202afc1439bf17dd8ac49cd3c0d76deecc944.tar.gz
ports-3b3202afc1439bf17dd8ac49cd3c0d76deecc944.zip
- Provide a patch to fix a bug in the configure script that caused the include
and library directory flags to gcc to be wrong - Bump PORTREVISION PR: 102920 Submitted by: David Thiel <lx@redundancy.redundancy.org> (maintainer)
Notes
Notes: svn path=/head/; revision=172523
Diffstat (limited to 'security/libssh2')
-rw-r--r--security/libssh2/Makefile3
-rw-r--r--security/libssh2/files/patch-configure13
2 files changed, 15 insertions, 1 deletions
diff --git a/security/libssh2/Makefile b/security/libssh2/Makefile
index 1186af64ecc5..0cc50c3fa125 100644
--- a/security/libssh2/Makefile
+++ b/security/libssh2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libssh2
PORTVERSION= 0.14
+PORTREVISION= 1
CATEGORIES= security devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -17,7 +18,7 @@ COMMENT= A library implementing the SSH2 protocol
USE_OPENSSL= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
PLIST_FILES= include/libssh2.h \
include/libssh2_publickey.h \
diff --git a/security/libssh2/files/patch-configure b/security/libssh2/files/patch-configure
new file mode 100644
index 000000000000..c2fa0cb5060c
--- /dev/null
+++ b/security/libssh2/files/patch-configure
@@ -0,0 +1,13 @@
+--- configure.orig Tue Sep 5 13:14:03 2006
++++ configure Tue Sep 5 13:14:17 2006
+@@ -3738,8 +3738,8 @@
+ if test "$found_openssl" = "no" && test -x "$PKG_CONFIG" && $PKG_CONFIG --exists openssl; then
+ found_openssl=yes
+ pkgcfg_openssl=yes
+- OPENSSL_LIBLINE=`$PKG_CONFIG --libs openssl`
+- OPENSSL_INCLINE=`$PKG_CONFIG --variable=includedir openssl`
++ OPENSSL_LIBLINE=-L`$PKG_CONFIG --libs openssl`
++ OPENSSL_INCLINE=-I`$PKG_CONFIG --variable=includedir openssl`
+ echo "$as_me:$LINENO: result: Using paths from pkg-config" >&5
+ echo "${ECHO_T}Using paths from pkg-config" >&6
+ fi