aboutsummaryrefslogtreecommitdiff
path: root/security/libtasn1
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-01-07 13:44:33 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-01-07 13:44:33 +0000
commit6035bc589a2685219b2ca9737d139205e70d3268 (patch)
tree2350e9130bfd85d3548e2e00a7de2e5f7323448a /security/libtasn1
parent3fd3b50a40dfe6f46aa355b9073825e56a13ae03 (diff)
downloadports-6035bc589a2685219b2ca9737d139205e70d3268.tar.gz
ports-6035bc589a2685219b2ca9737d139205e70d3268.zip
[NEW PORT] security/libtasn1: ASN.1 parser library for GnuTLS
XASN.1 structure parser library PR: ports/45347 Submitted by: Sergei Kolobov <sergei@kolobov.com>
Notes
Notes: svn path=/head/; revision=72694
Diffstat (limited to 'security/libtasn1')
-rw-r--r--security/libtasn1/Makefile39
-rw-r--r--security/libtasn1/distinfo1
-rw-r--r--security/libtasn1/files/patch-src::asn1Coding.c11
-rw-r--r--security/libtasn1/files/patch-src::asn1Decoding.c11
-rw-r--r--security/libtasn1/files/patch-src::asn1Parser.c11
-rw-r--r--security/libtasn1/pkg-comment1
-rw-r--r--security/libtasn1/pkg-descr13
-rw-r--r--security/libtasn1/pkg-plist13
8 files changed, 100 insertions, 0 deletions
diff --git a/security/libtasn1/Makefile b/security/libtasn1/Makefile
new file mode 100644
index 000000000000..d3809640c747
--- /dev/null
+++ b/security/libtasn1/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: libtasn1
+# Date created: 15 Nov 2002
+# Whom: Sergei Kolobov <sergei@kolobov.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libtasn1
+PORTVERSION= 0.1.2
+CATEGORIES= security
+MASTER_SITES= ftp://ftp.gnutls.org/pub/gnutls/libtasn1/ \
+ ftp://ftp.gnupg.org/pub/gcrypt/alpha/gnutls/libtasn1/ \
+ http://www.mirrors.wiretapped.net/security/network-security/gnutls/libtasn1/ \
+ ftp://ftp.mirrors.wiretapped.net/security/network-security/gnutls/libtasn1/
+
+MAINTAINER= sergei@kolobov.com
+
+LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
+
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
+
+DOCS= AUTHORS NEWS README THANKS
+DOCS2= asn1.ps asn1.tex fdl.tex
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.for file in ${DOCS2}
+ ${INSTALL_DATA} ${WRKSRC}/doc/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/libtasn1/distinfo b/security/libtasn1/distinfo
new file mode 100644
index 000000000000..bf49d272e206
--- /dev/null
+++ b/security/libtasn1/distinfo
@@ -0,0 +1 @@
+MD5 (libtasn1-0.1.2.tar.gz) = 6c8c376e5582f6845371a939869166dd
diff --git a/security/libtasn1/files/patch-src::asn1Coding.c b/security/libtasn1/files/patch-src::asn1Coding.c
new file mode 100644
index 000000000000..9bed2ff1a2d4
--- /dev/null
+++ b/security/libtasn1/files/patch-src::asn1Coding.c
@@ -0,0 +1,11 @@
+--- src/asn1Coding.c.orig Tue Jan 7 05:39:32 2003
++++ src/asn1Coding.c Tue Jan 7 05:39:36 2003
+@@ -28,7 +28,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <libtasn1.h>
+-#include <malloc.h>
++#include <stdlib.h>
+ #include <config.h>
+
+ #ifdef HAVE_GETOPT_H
diff --git a/security/libtasn1/files/patch-src::asn1Decoding.c b/security/libtasn1/files/patch-src::asn1Decoding.c
new file mode 100644
index 000000000000..4c7fca6ba7b9
--- /dev/null
+++ b/security/libtasn1/files/patch-src::asn1Decoding.c
@@ -0,0 +1,11 @@
+--- src/asn1Decoding.c.orig Tue Jan 7 05:40:14 2003
++++ src/asn1Decoding.c Tue Jan 7 05:40:20 2003
+@@ -28,7 +28,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <libtasn1.h>
+-#include <malloc.h>
++#include <stdlib.h>
+ #include <config.h>
+
+ #ifdef HAVE_GETOPT_H
diff --git a/security/libtasn1/files/patch-src::asn1Parser.c b/security/libtasn1/files/patch-src::asn1Parser.c
new file mode 100644
index 000000000000..85072d72cf4c
--- /dev/null
+++ b/security/libtasn1/files/patch-src::asn1Parser.c
@@ -0,0 +1,11 @@
+--- src/asn1Parser.c.orig Tue Jan 7 05:38:03 2003
++++ src/asn1Parser.c Tue Jan 7 05:38:09 2003
+@@ -28,7 +28,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <libtasn1.h>
+-#include <malloc.h>
++#include <stdlib.h>
+ #include <config.h>
+
+ #ifdef HAVE_GETOPT_H
diff --git a/security/libtasn1/pkg-comment b/security/libtasn1/pkg-comment
new file mode 100644
index 000000000000..b4d2399bf256
--- /dev/null
+++ b/security/libtasn1/pkg-comment
@@ -0,0 +1 @@
+ASN.1 structure parser library
diff --git a/security/libtasn1/pkg-descr b/security/libtasn1/pkg-descr
new file mode 100644
index 000000000000..5e06833874b6
--- /dev/null
+++ b/security/libtasn1/pkg-descr
@@ -0,0 +1,13 @@
+libtasn1 library was developed for ASN1 (Abstract Syntax Notation One)
+structures management.
+
+The main features of this library are:
+
+- on-line ASN1 structure management that does not require any C code
+ file generation;
+- off-line ASN1 structure management with C code file generation
+ containing an array;
+- DER (Distinguish Encoding Rules) encoding;
+- no limits for INTEGER and ENUMERATED values
+
+WWW: http://www.gnutls.org/
diff --git a/security/libtasn1/pkg-plist b/security/libtasn1/pkg-plist
new file mode 100644
index 000000000000..3591d8045175
--- /dev/null
+++ b/security/libtasn1/pkg-plist
@@ -0,0 +1,13 @@
+include/libtasn1.h
+lib/libtasn1.so.0
+lib/libtasn1.so
+lib/libtasn1.la
+lib/libtasn1.a
+%%PORTDOCS%%share/doc/libtasn1/AUTHORS
+%%PORTDOCS%%share/doc/libtasn1/NEWS
+%%PORTDOCS%%share/doc/libtasn1/README
+%%PORTDOCS%%share/doc/libtasn1/THANKS
+%%PORTDOCS%%share/doc/libtasn1/asn1.ps
+%%PORTDOCS%%share/doc/libtasn1/asn1.tex
+%%PORTDOCS%%share/doc/libtasn1/fdl.tex
+%%PORTDOCS%%@dirrm share/doc/libtasn1