aboutsummaryrefslogtreecommitdiff
path: root/security/lsh
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2003-06-13 04:26:24 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2003-06-13 04:26:24 +0000
commit1d60b799627d6feda51cb3283d916a0f09807473 (patch)
tree432a57b350ef0726f343a2ad354b429a1fb5b44c /security/lsh
parent2b138f401f4c8442e81db68525b3e647d8b8bd90 (diff)
downloadports-1d60b799627d6feda51cb3283d916a0f09807473.tar.gz
ports-1d60b799627d6feda51cb3283d916a0f09807473.zip
- Update to 1.5.2
- removed patches that are now part of distribution - New option: WITH_THREADS or WITH_LSH_THREADS
Notes
Notes: svn path=/head/; revision=82916
Diffstat (limited to 'security/lsh')
-rw-r--r--security/lsh/Makefile8
-rw-r--r--security/lsh/distinfo2
-rw-r--r--security/lsh/files/patch-argp-help.c21
-rw-r--r--security/lsh/files/patch-io.c14
-rw-r--r--security/lsh/files/patch-nettle-benchmark.c70
-rw-r--r--security/lsh/files/patch-sftp-buffer.c11
-rw-r--r--security/lsh/files/patch-unix_random.c13
-rw-r--r--security/lsh/pkg-plist2
8 files changed, 8 insertions, 133 deletions
diff --git a/security/lsh/Makefile b/security/lsh/Makefile
index 5b53b6788386..1a113c691514 100644
--- a/security/lsh/Makefile
+++ b/security/lsh/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= lsh
-PORTVERSION= 1.5.1
+PORTVERSION= 1.5.2
CATEGORIES= security ipv6
MASTER_SITES= ${MASTER_SITE_GNUPG} \
ftp://ftp.lysator.liu.se/pub/security/%SUBDIR%/
@@ -24,14 +24,16 @@ USE_GMAKE= yes
INSTALL_TARGET= install
CONFIGURE_ARGS+= --with-include-path=${LOCALBASE}/include
CONFIGURE_ARGS+= --with-lib-path=${LOCALBASE}/lib
-LDFLAGS+= ${PTHREAD_LIBS}
-CFLAGS+= ${PTHREAD_CFLAGS:S=""==}
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
.if defined(KRB5_HOME) && exists(${KRB5_HOME})
PLIST_SUB+= KRB=""
.else
PLIST_SUB+= KRB="@comment "
.endif
+.if defined(WITH_THREADS) || defined(WITH_LSH_THREADS)
+LDFLAGS+= ${PTHREAD_LIBS}
+CFLAGS+= ${PTHREAD_CFLAGS:S=""==}
+.endif
.include <bsd.port.pre.mk>
diff --git a/security/lsh/distinfo b/security/lsh/distinfo
index ac4db9577c25..76499dc8cb30 100644
--- a/security/lsh/distinfo
+++ b/security/lsh/distinfo
@@ -1 +1 @@
-MD5 (lsh-1.5.1.tar.gz) = a8bb8806d990b0907bb251d8be014a63
+MD5 (lsh-1.5.2.tar.gz) = 6318d963aaa3a34a5e752ac657575b46
diff --git a/security/lsh/files/patch-argp-help.c b/security/lsh/files/patch-argp-help.c
deleted file mode 100644
index 4dded4517c03..000000000000
--- a/security/lsh/files/patch-argp-help.c
+++ /dev/null
@@ -1,21 +0,0 @@
---- src/argp/argp-help.c.orig Tue Jan 2 22:36:35 2001
-+++ src/argp/argp-help.c Wed Dec 18 05:22:38 2002
-@@ -50,7 +50,9 @@
- #include <string.h>
- #include <assert.h>
- #include <stdarg.h>
-+#ifndef __FreeBSD__
- #include <malloc.h>
-+#endif
- #include <ctype.h>
-
-
-@@ -1114,7 +1116,7 @@
- int old_wm = __argp_fmtstream_wmargin (stream);
- /* PEST is a state block holding some of our variables that we'd like to
- share with helper functions. */
--#ifdef __GNUC__
-+#if defined(__GNUC__) && !defined(__FreeBSD__)
- struct pentry_state pest = { entry, stream, hhstate, 1, state };
- #else /* !__GNUC__ */
- /* Decent initializers are a GNU extension */
diff --git a/security/lsh/files/patch-io.c b/security/lsh/files/patch-io.c
deleted file mode 100644
index a75b70a39fec..000000000000
--- a/security/lsh/files/patch-io.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/io.c.orig Sun Feb 16 20:46:23 2003
-+++ src/io.c Sun Mar 2 10:11:18 2003
-@@ -34,7 +34,11 @@
- #endif
-
- /* For the popen code */
-+#ifdef __FreeBSD__
-+#include <sys/wait.h>
-+#else
- #include <wait.h>
-+#endif
-
- #ifdef HAVE_POLL
- # if HAVE_POLL_H
diff --git a/security/lsh/files/patch-nettle-benchmark.c b/security/lsh/files/patch-nettle-benchmark.c
deleted file mode 100644
index 6c9e881d190a..000000000000
--- a/security/lsh/files/patch-nettle-benchmark.c
+++ /dev/null
@@ -1,70 +0,0 @@
---- src/nettle/examples/nettle-benchmark.c.orig Fri Feb 15 11:09:13 2002
-+++ src/nettle/examples/nettle-benchmark.c Wed Dec 18 05:34:29 2002
-@@ -169,8 +169,15 @@
- init_data(data);
-
- {
-+#ifndef __FreeBSD__
- struct bench_cipher_info info
- = { ctx, cipher->encrypt, data };
-+#else
-+ struct bench_cipher_info info;
-+ info.ctx = ctx;
-+ info.crypt = cipher->encrypt;
-+ info.data = data;
-+#endif
-
- init_key(cipher->key_size, key);
- cipher->set_encrypt_key(ctx, cipher->key_size, key);
-@@ -180,8 +187,15 @@
- }
-
- {
-+#ifndef __FreeBSD__
- struct bench_cipher_info info
- = { ctx, cipher->decrypt, data };
-+#else
-+ struct bench_cipher_info info;
-+ info.ctx = ctx;
-+ info.crypt = cipher->decrypt;
-+ info.data = data;
-+#endif
-
- init_key(cipher->key_size, key);
- cipher->set_decrypt_key(ctx, cipher->key_size, key);
-@@ -196,8 +210,17 @@
-
- /* Do CBC mode */
- {
-+#ifndef __FreeBSD__
- struct bench_cbc_info info
- = { ctx, cipher->encrypt, data, cipher->block_size, iv };
-+#else
-+ struct bench_cbc_info info;
-+ info.ctx = ctx;
-+ info.crypt = cipher->encrypt;
-+ info.data = data;
-+ info.block_size = cipher->block_size;
-+ info.iv = iv;
-+#endif
-
- memset(iv, 0, sizeof(iv));
-
-@@ -208,8 +231,17 @@
- }
-
- {
-+#ifndef __FreeBSD__
- struct bench_cbc_info info
- = { ctx, cipher->decrypt, data, cipher->block_size, iv };
-+#else
-+ struct bench_cbc_info info;
-+ info.ctx = ctx;
-+ info.crypt = cipher->decrypt;
-+ info.data = data;
-+ info.block_size = cipher->block_size;
-+ info.iv = iv;
-+#endif
-
- memset(iv, 0, sizeof(iv));
-
diff --git a/security/lsh/files/patch-sftp-buffer.c b/security/lsh/files/patch-sftp-buffer.c
deleted file mode 100644
index fd148bdeeedd..000000000000
--- a/security/lsh/files/patch-sftp-buffer.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/sftp/buffer.c.orig Sun Feb 23 19:34:44 2003
-+++ src/sftp/buffer.c Sun Mar 2 09:52:24 2003
-@@ -227,7 +227,7 @@
- {
- uint8_t buf[8];
-
-- WRITE_uint64_t(buf, value);
-+ WRITE_UINT64(buf, value);
- PUT_DATA(o, buf);
- }
-
diff --git a/security/lsh/files/patch-unix_random.c b/security/lsh/files/patch-unix_random.c
deleted file mode 100644
index e4600c0412ad..000000000000
--- a/security/lsh/files/patch-unix_random.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/unix_random.c.orig Sun Feb 16 21:27:45 2003
-+++ src/unix_random.c Sun Mar 2 10:18:35 2003
-@@ -36,9 +36,9 @@
- #endif
-
- #include <sys/types.h>
-+#include <sys/time.h>
- #include <sys/resource.h>
- #include <sys/stat.h>
--#include <sys/time.h>
-
- #include "randomness.h"
-
diff --git a/security/lsh/pkg-plist b/security/lsh/pkg-plist
index 65ef315ae835..39dcae11903d 100644
--- a/security/lsh/pkg-plist
+++ b/security/lsh/pkg-plist
@@ -2,10 +2,12 @@ bin/lsftp
bin/lsh
bin/lsh-authorize
bin/lsh-decode-key
+bin/lsh-decrypt-key
bin/lsh-export-key
bin/lsh-keygen
bin/lsh-make-seed
bin/lsh-upgrade
+bin/lsh-upgrade-key
bin/lsh-writekey
bin/lshg
bin/sexp-conv