aboutsummaryrefslogtreecommitdiff
path: root/security/mac-robber
diff options
context:
space:
mode:
authorMark Pulford <markp@FreeBSD.org>2003-02-17 09:19:01 +0000
committerMark Pulford <markp@FreeBSD.org>2003-02-17 09:19:01 +0000
commitdb1157510b1f01752b231f3d7b8aef5d6ed18632 (patch)
tree5b5c7300221270520d00109a1443511e45cf3645 /security/mac-robber
parent6f6780ceb99870c18c02d2a8368474664cc91cad (diff)
downloadports-db1157510b1f01752b231f3d7b8aef5d6ed18632.tar.gz
ports-db1157510b1f01752b231f3d7b8aef5d6ed18632.zip
Add mac-robber 1.00, a tool for listing Modify, Access, Create
timestamps from files. PR: 47011 Submitted by: Yonatan <Yonatan@xpert.com>
Notes
Notes: svn path=/head/; revision=75690
Diffstat (limited to 'security/mac-robber')
-rw-r--r--security/mac-robber/Makefile22
-rw-r--r--security/mac-robber/distinfo1
-rw-r--r--security/mac-robber/pkg-descr11
-rw-r--r--security/mac-robber/pkg-plist2
4 files changed, 36 insertions, 0 deletions
diff --git a/security/mac-robber/Makefile b/security/mac-robber/Makefile
new file mode 100644
index 000000000000..5f50164724f4
--- /dev/null
+++ b/security/mac-robber/Makefile
@@ -0,0 +1,22 @@
+# Ports collection makefile for: mac-robber
+# Date created: Jan 12 2003
+# Whom: Yonatan <Yonatan@xpert.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mac-robber
+PORTVERSION= 1.00
+CATEGORIES= security
+MASTER_SITES= http://www.atstake.com/research/tools/
+
+MAINTAINER= Yonatan@xpert.com
+COMMENT= A tool for listing Modify, Access, Create timestamps from files
+
+do-build:
+ cd ${WRKSRC}; ${CC} ${CFLAGS} -o mac-robber mac-robber.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/mac-robber ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/security/mac-robber/distinfo b/security/mac-robber/distinfo
new file mode 100644
index 000000000000..0812c6e09b70
--- /dev/null
+++ b/security/mac-robber/distinfo
@@ -0,0 +1 @@
+MD5 (mac-robber-1.00.tar.gz) = 4fa05cf85dd0d28c2780b6151b74f9f0
diff --git a/security/mac-robber/pkg-descr b/security/mac-robber/pkg-descr
new file mode 100644
index 000000000000..1611afb1c094
--- /dev/null
+++ b/security/mac-robber/pkg-descr
@@ -0,0 +1,11 @@
+mac-robber is a Forensics & Incident Response tool used to collect
+the Modified, Access, and Change (MAC) times from allocated files.
+It recursively reads MAC times of files and directories and prints
+them in 'time machine' format to STDOUT. This format is the same
+that the mactime tool from The Coroners Toolkit (TCT) reads.
+
+mac-robber is based on the grave-robber tool from The Coroners
+Toolkit (TCT) when using the '-m' flag, except it does not require
+Perl!
+
+WWW: http://www.atstake.com/research/tools/forensic/
diff --git a/security/mac-robber/pkg-plist b/security/mac-robber/pkg-plist
new file mode 100644
index 000000000000..98a05252dad5
--- /dev/null
+++ b/security/mac-robber/pkg-plist
@@ -0,0 +1,2 @@
+@comment $FreeBSD$
+bin/mac-robber