aboutsummaryrefslogtreecommitdiff
path: root/security/mcrypt
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2002-05-08 22:00:26 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2002-05-08 22:00:26 +0000
commitf19ba78f253fc3ba3310a10977dd7a53bace5cf4 (patch)
tree32935f243fda284f286044b54948f561f01f57a5 /security/mcrypt
parent156b71b59f6afc3092ffb99270dc62b994d39002 (diff)
downloadports-f19ba78f253fc3ba3310a10977dd7a53bace5cf4.tar.gz
ports-f19ba78f253fc3ba3310a10977dd7a53bace5cf4.zip
This version of mcrypt requires autoconf 2.50 or newer. Accordingly,
use that instead of the old autoconf. Add a pre-configure target to run autoconf, because bsd.port.mk only supports the old autoconf. Left to its own devices, the program now installs files with strange names such as /usr/local/man/man1/i386-portbld-freebsd4.4-mcrypt.1 and /usr/local/bin/i386-portbld-freebsd4.4-mcrypt. To avoid this, the whole installation now happens in a do-install target in the port's Makefile, which also does the former post-install tasks. Install supplementary documentation, unless NOPORTDOCS is defined. Use EXAMPLESDIR. The mdecrypt utility was removed. It has been replaced by a -d option to mcrypt. Drop USE_LIBTOOL and add back GNU_CONFIGURE. PORTVERSION remains nil, since this did not build. Add a warning about my laziness.
Notes
Notes: svn path=/head/; revision=58757
Diffstat (limited to 'security/mcrypt')
-rw-r--r--security/mcrypt/Makefile41
1 files changed, 31 insertions, 10 deletions
diff --git a/security/mcrypt/Makefile b/security/mcrypt/Makefile
index fe2a45d073d7..a9589df853ac 100644
--- a/security/mcrypt/Makefile
+++ b/security/mcrypt/Makefile
@@ -16,38 +16,59 @@ MASTER_SITES= ftp://argeas.cs-net.gr/pub/unix/mcrypt/ \
MAINTAINER= trevor@FreeBSD.org
+BUILD_DEPENDS= autoconf:${PORTSDIR}/devel/autoconf \
+ automake:${PORTSDIR}/devel/automake
LIB_DEPENDS= mcrypt.7:${PORTSDIR}/security/libmcrypt/ \
mhash.2:${PORTSDIR}/security/mhash/ \
intl.2:${PORTSDIR}/devel/gettext
-post-patch:
- ${RM} -f ${WRKSRC}/configure
-
CONFIGURE_ARGS+= ${CONFIGURE_SHARED}
CONFIGURE_ARGS+= --enable-static --with-catgets
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -lintl -lltdl"
+GNU_CONFIGURE= yes
+DOCS= FORMAT magic
MAN1= mcrypt.1
+PKGMESSAGE= ${WRKDIR}/pkg-message
PLIST= ${WRKDIR}/pkg-plist
-USE_AUTOCONF= yes
-USE_LIBTOOL= yes
+
+pre-configure:
+ cd ${WRKSRC} && automake -i && autoconf
pre-install:
${ECHO_CMD} bin/${PORTNAME} > ${PLIST}
- ${ECHO_CMD} bin/mdecrypt >> ${PLIST}
.for i in cs el pl
${ECHO_CMD} share/locale/${i}/LC_MESSAGES/mcrypt.mo >> ${PLIST}
.endfor
.if !defined(NOPORTDOCS)
${ECHO_CMD} share/examples/${PORTNAME}/sample.mcryptrc >> ${PLIST}
${ECHO_CMD} @dirrm share/examples/${PORTNAME} >> ${PLIST}
+.for i in ${DOCS}
+ ${ECHO_CMD} share/doc/${PORTNAME}/${i} >> ${PLIST}
+.endfor
+ ${ECHO_CMD} @dirrm share/doc/${PORTNAME} >> ${PLIST}
.endif
+ ${ECHO_CMD} "*** WARNING ***" > ${PKGMESSAGE}
+ ${ECHO_CMD} \
+"The source for this package has not been reviewed by the FreeBSD maintainer." \
+ >> ${PKGMESSAGE}
-post-install:
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/mcrypt ${PREFIX}/bin/
+.for i in el cs pl
+ ${MKDIR} ${PREFIX}/share/locale/${i}/LC_MESSAGES
+ ${INSTALL_DATA} ${WRKSRC}/po/${i}.gmo \
+ ${PREFIX}/share/locale/${i}/LC_MESSAGES/mcrypt.mo
+.endfor
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/sample.mcryptrc ${EXAMPLESDIR}/
+ ${INSTALL_MAN} ${WRKSRC}/doc/${MAN1} ${PREFIX}/man/man1/
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/examples/${PORTNAME}
- ${INSTALL_DATA} ${WRKSRC}/doc/sample.mcryptrc \
- ${PREFIX}/share/examples/${PORTNAME}/
+ ${MKDIR} ${PREFIX}/share/examples/${PORTNAME} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/sample.mcryptrc ${EXAMPLESDIR}/
+.for i in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/doc/${i} ${DOCSDIR}/
+.endfor
.endif
.include <bsd.port.mk>