aboutsummaryrefslogtreecommitdiff
path: root/security/nbaudit
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>1998-02-14 04:10:33 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>1998-02-14 04:10:33 +0000
commit762df7a75661bb23ef8e28f319bdebec63f3f2ac (patch)
tree43ae951029e3111124fed5ff4cc5a5d7473c8d6e /security/nbaudit
parent944b65328288017f9f059fa89600e6b533a98301 (diff)
downloadports-762df7a75661bb23ef8e28f319bdebec63f3f2ac.tar.gz
ports-762df7a75661bb23ef8e28f319bdebec63f3f2ac.zip
NetBIOS Auditing Tool / Security Kit
Notes
Notes: svn path=/head/; revision=9711
Diffstat (limited to 'security/nbaudit')
-rw-r--r--security/nbaudit/Makefile28
-rw-r--r--security/nbaudit/distinfo1
-rw-r--r--security/nbaudit/files/patch-0122
-rw-r--r--security/nbaudit/pkg-comment1
-rw-r--r--security/nbaudit/pkg-descr9
-rw-r--r--security/nbaudit/pkg-plist6
6 files changed, 67 insertions, 0 deletions
diff --git a/security/nbaudit/Makefile b/security/nbaudit/Makefile
new file mode 100644
index 000000000000..8f94d76af416
--- /dev/null
+++ b/security/nbaudit/Makefile
@@ -0,0 +1,28 @@
+# ex:ts=8
+# Ports collection makefile for: nat/nbaudit
+# Version required: 1.0
+# Date created: Mon Feb 03, 1997
+# Whom: David O'Brien (obrien@FreeBSD.org)
+#
+# $Id: Makefile,v 1.1.1.1 1998/01/21 11:37:54 obrien Exp $
+#
+
+DISTNAME= nat10
+PKGNAME= nbaudit-1.0
+CATEGORIES= security net
+MASTER_SITES= ftp://ftp.secnet.com/pub/tools/nat10/
+
+MAINTAINER= obrien@NUXI.com
+
+WRKSRC= ${WRKDIR}/${DISTNAME}
+MAN1= nat.1
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/nat ${PREFIX}/bin
+ @ln -f ${PREFIX}/bin/nat ${PREFIX}/bin/nbaudit
+ @${INSTALL_MAN} ${WRKSRC}/nat.1 ${PREFIX}/man/man1
+
+after-install:
+ @ln -f ${PREFIX}/man/man1/nat.1.gz ${PREFIX}/man/man1/nbaudit.1.gz
+
+.include <bsd.port.mk>
diff --git a/security/nbaudit/distinfo b/security/nbaudit/distinfo
new file mode 100644
index 000000000000..9e5fcffd0967
--- /dev/null
+++ b/security/nbaudit/distinfo
@@ -0,0 +1 @@
+MD5 (nat10.tar.gz) = b8e020ac21e35caa35a8bbd99e41b5e4
diff --git a/security/nbaudit/files/patch-01 b/security/nbaudit/files/patch-01
new file mode 100644
index 000000000000..bc7eeffcb9ce
--- /dev/null
+++ b/security/nbaudit/files/patch-01
@@ -0,0 +1,22 @@
+--- Makefile.orig Sun Feb 16 19:18:04 1997
++++ Makefile Wed Jan 21 03:02:33 1998
+@@ -189,8 +189,8 @@
+ # This is for FreeBSD
+ # contributed by kuku@acds.physik.rwth-aachen.de
+ # NOTE: You may need to add -DBSD44 if you have password problems
+-# FLAGSM = -DFreeBSD
+-# LIBSM = -lcrypt
++FLAGSM = -DFreeBSD
++LIBSM = -lcrypt
+
+
+ # This is for NEXTSTEP Release 2.X
+@@ -366,7 +366,7 @@
+ OBJS = nat.o client.o util.o system.o nmb.o charset.o parse_ip.o
+ CFLAGS1 = -DSTEPPING -DSCANNER -DVERBOSE
+ CFLAGS2 = -DWORKGROUP=\"$(WORKGROUP)\" -DGUEST_ACCOUNT=\"$(GUESTACCOUNT)\"
+-CFLAGS = $(CFLAGS1) $(CFLAGS2) $(FLAGSM)
++CFLAGS += $(CFLAGS1) $(CFLAGS2) $(FLAGSM)
+ LIBS = $(LIBSM)
+
+ all : nat
diff --git a/security/nbaudit/pkg-comment b/security/nbaudit/pkg-comment
new file mode 100644
index 000000000000..30bf9e142ce5
--- /dev/null
+++ b/security/nbaudit/pkg-comment
@@ -0,0 +1 @@
+NetBIOS Auditing Tool / Security Kit
diff --git a/security/nbaudit/pkg-descr b/security/nbaudit/pkg-descr
new file mode 100644
index 000000000000..1213f8383f35
--- /dev/null
+++ b/security/nbaudit/pkg-descr
@@ -0,0 +1,9 @@
+NetBIOS Auditing Tool / Security Kit
+
+The intention of this package is to perform various security checks on
+remote servers running NetBIOS file sharing services.
+nat will attempt to retrieve all information availible from the remote
+server, and attempt to access any services provided by the server.
+
+-- David O'Brien
+ obrien@NUXI.com
diff --git a/security/nbaudit/pkg-plist b/security/nbaudit/pkg-plist
new file mode 100644
index 000000000000..364d20282ce3
--- /dev/null
+++ b/security/nbaudit/pkg-plist
@@ -0,0 +1,6 @@
+bin/nat
+@exec ln -fs %D/%F %B/nbaudit
+@unexec rm %B/nbaudit
+man/man1/nat.1.gz
+@exec ln -fs %D/%F %B/nbaudit.1.gz
+@unexec rm %B/nbaudit.1.gz