aboutsummaryrefslogtreecommitdiff
path: root/security/nmap
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2011-01-07 20:51:25 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2011-01-07 20:51:25 +0000
commit3f0360cc96f74da759e966c69a1abc3f25941c37 (patch)
treeb1abca93e0426b60f53978ec969ba76d9c24f101 /security/nmap
parent3b77b810aa9df925aeb9529376bc673cabbbac9d (diff)
downloadports-3f0360cc96f74da759e966c69a1abc3f25941c37.tar.gz
ports-3f0360cc96f74da759e966c69a1abc3f25941c37.zip
- update nmap to version 5.36TEST3
- remove dead mirror servers Changelog: http://nmap.org/changelog.html Mayjor changes are NSE script related, some highlihts: o [NSE] Added stuxnet-detect.nse o [NSE] Added the ftp-proftpd-backdoor.nse and many more interesting NSE scripts.
Notes
Notes: svn path=/head/; revision=267490
Diffstat (limited to 'security/nmap')
-rw-r--r--security/nmap/Makefile31
-rw-r--r--security/nmap/distinfo5
-rw-r--r--security/nmap/files/patch-configure12
-rw-r--r--security/nmap/files/patch-libdnet-stripped__include__dnet__sctp.h65
-rw-r--r--security/nmap/files/patch-nse_openssl.cc35
-rw-r--r--security/nmap/files/patch-scan_engine.cc20
-rw-r--r--security/nmap/pkg-plist83
7 files changed, 94 insertions, 157 deletions
diff --git a/security/nmap/Makefile b/security/nmap/Makefile
index e41c160032a2..6ef369bd51c3 100644
--- a/security/nmap/Makefile
+++ b/security/nmap/Makefile
@@ -6,19 +6,19 @@
#
PORTNAME= nmap
-DISTVERSION= 5.35DC1
+DISTVERSION= 5.36TEST3
CATEGORIES= security ipv6
MASTER_SITES= http://nmap.org/dist/ \
- http://nmap.ucsd.edu/dist/ \
- http://www.mirrors.wiretapped.net/security/network-mapping/nmap/ \
- http://www.mirrorservice.org/sites/ftp.wiretapped.net/pub/security/network-mapping/nmap/ \
- http://mirror.sg.depaul.edu/pub/security/nmap/
+ LOCAL/ohauer
MAINTAINER= ohauer@FreeBSD.org
COMMENT= Port scanning utility for large networks
LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
+# http://nmap.org/book/man-legal.html
+LICENSE= GPLv2
+
USE_LUA= 5.1
LUA_COMPS= lua
USE_BZIP2= yes
@@ -34,8 +34,6 @@ CONFIGURE_ENV= LUA_INCDIR="${LUA_INCDIR}" LUA_LIBDIR="${LUA_LIBDIR}"
MANLANG= "" de es fr hr hu it jp pl pt_BR pt_PT ro ru sk zh
MAN1= nmap.1
MAN1_EN= ncat.1 nping.1
-PLIST_SUB+= NCATDATADIR=share/ncat \
- NPINGDIR=share/nping
.ifndef WITHOUT_SSL
USE_OPENSSL= yes
@@ -43,12 +41,17 @@ CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
CONFIGURE_ENV+= CFLAGS="${CFLAGS} -I${OPENSSLINC}"
PLIST_SUB+= WITHSSL=""
.else
+PKGNAMESUFFIX= -nossl
CONFIGURE_ARGS+= --without-openssl
PLIST_SUB+= WITHSSL="@comment "
.endif
+PORTDOCS= CHANGELOG HACKING
+EXAMPLES= docs/sample-script.nse
+PORTEXAMPLES= ${EXAMPLES:T}
+
# XXX limit results if we do a grep in the sources!
-post-patch:
+post-extract:
@${RM} -rf ${WRKSRC}/mswin32
post-configure:
@@ -57,9 +60,15 @@ post-configure:
post-install:
.ifndef NOPORTDOCS
@${MKDIR} ${DOCSDIR}
- @for doc in CHANGELOG HACKING docs/nmap.dtd; do \
- ${INSTALL_DATA} ${WRKSRC}/$${doc} ${DOCSDIR}; \
- done
+. for i in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+. endfor
+.endif
+.ifndef NOPORTEXAMPLES
+ @${MKDIR} ${EXAMPLESDIR}
+. for i in ${EXAMPLES}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${EXAMPLESDIR}
+. endfor
.endif
.include <bsd.port.mk>
diff --git a/security/nmap/distinfo b/security/nmap/distinfo
index ef565cf4d865..753ef385f7dc 100644
--- a/security/nmap/distinfo
+++ b/security/nmap/distinfo
@@ -1,3 +1,2 @@
-MD5 (nmap-5.35DC1.tar.bz2) = 5bc2f8629f26716aa78d4bfe474a5d3a
-SHA256 (nmap-5.35DC1.tar.bz2) = 51a6cde0a6afee50799d59b1968f1a4011753bb535f070114fd60be62f59ad44
-SIZE (nmap-5.35DC1.tar.bz2) = 11302092
+SHA256 (nmap-5.36TEST3.tar.bz2) = c722f6f811f224aaba84047a05c6c4874dd683709c06f1c82cf414a1e94bd162
+SIZE (nmap-5.36TEST3.tar.bz2) = 16830247
diff --git a/security/nmap/files/patch-configure b/security/nmap/files/patch-configure
index abafbd354df6..8d75fd5f948c 100644
--- a/security/nmap/files/patch-configure
+++ b/security/nmap/files/patch-configure
@@ -1,15 +1,15 @@
---- configure.orig 2009-06-24 23:35:54.000000000 +0200
-+++ configure 2009-07-03 19:35:52.000000000 +0200
-@@ -2047,7 +2047,7 @@
+--- ./configure.orig 2010-09-29 18:09:26.000000000 +0200
++++ ./configure 2011-01-07 19:27:04.000000000 +0100
+@@ -3265,7 +3265,7 @@
ac_compiler_gnu=$ac_cv_c_compiler_gnu
if test -n "$ac_tool_prefix"; then
# Extract the first word of "${ac_tool_prefix}gcc", so it can be a program name with args.
-set dummy ${ac_tool_prefix}gcc; ac_word=$2
+set dummy ${ac_tool_prefix}$CXX; ac_word=$2
- { $as_echo "$as_me:$LINENO: checking for $ac_word" >&5
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
$as_echo_n "checking for $ac_word... " >&6; }
- if test "${ac_cv_prog_CC+set}" = set; then
-@@ -7878,8 +7878,8 @@
+ if test "${ac_cv_prog_CC+set}" = set; then :
+@@ -6452,8 +6452,8 @@
no_lua="yes"
;;
*)
diff --git a/security/nmap/files/patch-libdnet-stripped__include__dnet__sctp.h b/security/nmap/files/patch-libdnet-stripped__include__dnet__sctp.h
deleted file mode 100644
index 79ba3de78bc9..000000000000
--- a/security/nmap/files/patch-libdnet-stripped__include__dnet__sctp.h
+++ /dev/null
@@ -1,65 +0,0 @@
---- ./libdnet-stripped/include/dnet/sctp.h.orig 2009-07-05 23:02:43.000000000 +0200
-+++ ./libdnet-stripped/include/dnet/sctp.h 2010-09-03 21:04:28.000000000 +0200
-@@ -36,7 +36,7 @@
- sctp_pack_p->sh_vtag = htonl(vtag); \
- } while (0)
-
--struct sctp_chunkhdr {
-+struct dnet_sctp_chunkhdr {
- uint8_t sch_type; /* chunk type */
- uint8_t sch_flags; /* chunk flags */
- uint16_t sch_length; /* chunk length */
-@@ -70,7 +70,7 @@
- #define SCTP_TYPEFLAG_SKIP 2
-
- #define sctp_pack_chunkhdr(hdr, type, flags, length) do { \
-- struct sctp_chunkhdr *sctp_pack_chp = (struct sctp_chunkhdr *)(hdr);\
-+ struct dnet_sctp_chunkhdr *sctp_pack_chp = (struct dnet_sctp_chunkhdr *)(hdr);\
- sctp_pack_chp->sch_type = type; \
- sctp_pack_chp->sch_flags = flags; \
- sctp_pack_chp->sch_length = htons(length); \
-@@ -80,7 +80,7 @@
- * INIT chunk
- */
- struct sctp_chunkhdr_init {
-- struct sctp_chunkhdr chunkhdr;
-+ struct dnet_sctp_chunkhdr chunkhdr;
-
- uint32_t schi_itag; /* Initiate Tag */
- uint32_t schi_arwnd; /* Advertised Receiver Window Credit */
-@@ -105,7 +105,7 @@
- * INIT ACK chunk
- */
- struct sctp_chunkhdr_init_ack {
-- struct sctp_chunkhdr chunkhdr;
-+ struct dnet_sctp_chunkhdr chunkhdr;
-
- uint32_t schia_itag; /* Initiate Tag */
- uint32_t schia_arwnd; /* Advertised Receiver Window Credit */
-@@ -130,7 +130,7 @@
- * ABORT chunk
- */
- struct sctp_chunkhdr_abort {
-- struct sctp_chunkhdr chunkhdr;
-+ struct dnet_sctp_chunkhdr chunkhdr;
-
- /* empty */
- } __attribute__((__packed__));
-@@ -145,7 +145,7 @@
- * SHUTDOWN ACK chunk
- */
- struct sctp_chunkhdr_shutdown_ack {
-- struct sctp_chunkhdr chunkhdr;
-+ struct dnet_sctp_chunkhdr chunkhdr;
-
- /* empty */
- } __attribute__((__packed__));
-@@ -160,7 +160,7 @@
- * COOKIE ECHO chunk
- */
- struct sctp_chunkhdr_cookie_echo {
-- struct sctp_chunkhdr chunkhdr;
-+ struct dnet_sctp_chunkhdr chunkhdr;
-
- /* empty */
- } __attribute__((__packed__));
diff --git a/security/nmap/files/patch-nse_openssl.cc b/security/nmap/files/patch-nse_openssl.cc
deleted file mode 100644
index 2a02a830b7ef..000000000000
--- a/security/nmap/files/patch-nse_openssl.cc
+++ /dev/null
@@ -1,35 +0,0 @@
---- ./nse_openssl.cc.orig 2010-03-28 23:18:02.000000000 +0200
-+++ ./nse_openssl.cc 2010-08-29 21:25:18.000000000 +0200
-@@ -8,7 +8,6 @@
- #include <openssl/crypto.h>
- #include <openssl/bn.h>
- #include <openssl/rand.h>
--#include <openssl/md2.h>
- #include <openssl/md4.h>
- #include <openssl/md5.h>
- #include <openssl/sha.h>
-@@ -219,16 +218,6 @@
- return 1;
- }
-
--static int l_md2(lua_State *L) /** md2(string s) */
--{
-- size_t len;
-- const unsigned char *s = (unsigned char *) luaL_checklstring( L, 1, &len );
-- unsigned char digest[16];
--
-- lua_pushlstring( L, (char *) MD2( s, len, digest ), 16 );
-- return 1;
--}
--
- static int l_md4(lua_State *L) /** md4(string s) */
- {
- size_t len;
-@@ -515,7 +504,6 @@
- { "bignum_mod_exp", l_bignum_mod_exp },
- { "rand_bytes", l_rand_bytes },
- { "rand_pseudo_bytes", l_rand_pseudo_bytes },
-- { "md2", l_md2 },
- { "md4", l_md4 },
- { "md5", l_md5 },
- { "sha1", l_sha1 },
diff --git a/security/nmap/files/patch-scan_engine.cc b/security/nmap/files/patch-scan_engine.cc
deleted file mode 100644
index 60941269dc3f..000000000000
--- a/security/nmap/files/patch-scan_engine.cc
+++ /dev/null
@@ -1,20 +0,0 @@
---- ./scan_engine.cc.orig 2010-06-22 19:24:34.000000000 +0200
-+++ ./scan_engine.cc 2010-09-03 21:04:29.000000000 +0200
-@@ -4124,7 +4124,7 @@
- }
- } else if (ip->ip_p == IPPROTO_SCTP && !USI->prot_scan) {
- struct sctp_hdr *sctp = (struct sctp_hdr *) ((u8 *) ip + ip->ip_hl * 4);
-- struct sctp_chunkhdr *chunk = (struct sctp_chunkhdr *) ((u8 *) sctp + 12);
-+ struct dnet_sctp_chunkhdr *chunk = (struct dnet_sctp_chunkhdr *) ((u8 *) sctp + 12);
- /* Now ensure this host is even in the incomplete list */
- memset(&sin, 0, sizeof(sin));
- sin.sin_addr.s_addr = ip->ip_src.s_addr;
-@@ -4737,7 +4737,7 @@
- }
- } else if (ip->ip_p == IPPROTO_SCTP && USI->ptech.rawsctpscan) {
- struct sctp_hdr *sctp = (struct sctp_hdr *) (((char *) ip) + 4 * ip->ip_hl);
-- struct sctp_chunkhdr *chunk = (struct sctp_chunkhdr *) ((u8 *) sctp + 12);
-+ struct dnet_sctp_chunkhdr *chunk = (struct dnet_sctp_chunkhdr *) ((u8 *) sctp + 12);
- /* Search for this host on the incomplete list */
- memset(&sin, 0, sizeof(sin));
- sin.sin_addr.s_addr = ip->ip_src.s_addr;
diff --git a/security/nmap/pkg-plist b/security/nmap/pkg-plist
index d943fec8bf4e..a7d548a6ac83 100644
--- a/security/nmap/pkg-plist
+++ b/security/nmap/pkg-plist
@@ -1,10 +1,7 @@
bin/ncat
bin/nmap
bin/nping
-%%PORTDOCS%%%%DOCSDIR%%/CHANGELOG
-%%PORTDOCS%%%%DOCSDIR%%/HACKING
-%%PORTDOCS%%%%DOCSDIR%%/nmap.dtd
-%%WITHSSL%%%%NCATDATADIR%%/ca-bundle.crt
+%%WITHSSL%%share/ncat/ca-bundle.crt
%%DATADIR%%/nmap-mac-prefixes
%%DATADIR%%/nmap-os-db
%%DATADIR%%/nmap-payloads
@@ -18,11 +15,12 @@ bin/nping
%%DATADIR%%/nselib/afp.lua
%%DATADIR%%/nselib/asn1.lua
%%DATADIR%%/nselib/base64.lua
+%%DATADIR%%/nselib/brute.lua
%%DATADIR%%/nselib/citrixxml.lua
%%DATADIR%%/nselib/comm.lua
%%DATADIR%%/nselib/data/favicon-db
-%%DATADIR%%/nselib/data/folders.lst
-%%DATADIR%%/nselib/data/http-fingerprints
+%%DATADIR%%/nselib/data/http-fingerprints.lua
+%%DATADIR%%/nselib/data/http-folders.txt
%%DATADIR%%/nselib/data/oracle-sids
%%DATADIR%%/nselib/data/passwords.lst
%%DATADIR%%/nselib/data/psexec/README
@@ -36,13 +34,18 @@ bin/nping
%%DATADIR%%/nselib/data/psexec/nmap_service.vcproj
%%DATADIR%%/nselib/data/psexec/pwdump.lua
%%DATADIR%%/nselib/data/usernames.lst
-%%DATADIR%%/nselib/data/yokoso-fingerprints
%%DATADIR%%/nselib/datafiles.lua
-%%DATADIR%%/nselib/db2.lua
+%%DATADIR%%/nselib/dhcp.lua
%%DATADIR%%/nselib/dns.lua
+%%DATADIR%%/nselib/dnssd.lua
+%%DATADIR%%/nselib/drda.lua
+%%DATADIR%%/nselib/ftp.lua
+%%DATADIR%%/nselib/giop.lua
%%DATADIR%%/nselib/http.lua
%%DATADIR%%/nselib/imap.lua
+%%DATADIR%%/nselib/informix.lua
%%DATADIR%%/nselib/ipOps.lua
+%%DATADIR%%/nselib/iscsi.lua
%%DATADIR%%/nselib/json.lua
%%DATADIR%%/nselib/ldap.lua
%%DATADIR%%/nselib/listop.lua
@@ -54,11 +57,13 @@ bin/nping
%%DATADIR%%/nselib/mssql.lua
%%DATADIR%%/nselib/mysql.lua
%%DATADIR%%/nselib/netbios.lua
+%%DATADIR%%/nselib/nrpc.lua
%%DATADIR%%/nselib/nsedebug.lua
%%DATADIR%%/nselib/packet.lua
%%DATADIR%%/nselib/pgsql.lua
%%DATADIR%%/nselib/pop3.lua
%%DATADIR%%/nselib/proxy.lua
+%%DATADIR%%/nselib/rmi.lua
%%DATADIR%%/nselib/rpc.lua
%%DATADIR%%/nselib/shortport.lua
%%DATADIR%%/nselib/smb.lua
@@ -70,8 +75,13 @@ bin/nping
%%DATADIR%%/nselib/strbuf.lua
%%DATADIR%%/nselib/strict.lua
%%DATADIR%%/nselib/tab.lua
+%%DATADIR%%/nselib/target.lua
+%%DATADIR%%/nselib/tns.lua
%%DATADIR%%/nselib/unpwdb.lua
+%%DATADIR%%/nselib/upnp.lua
%%DATADIR%%/nselib/url.lua
+%%DATADIR%%/nselib/vnc.lua
+%%DATADIR%%/nselib/wsdd.lua
%%DATADIR%%/scripts/afp-brute.nse
%%DATADIR%%/scripts/afp-path-vuln.nse
%%DATADIR%%/scripts/afp-serverinfo.nse
@@ -80,6 +90,10 @@ bin/nping
%%DATADIR%%/scripts/auth-owners.nse
%%DATADIR%%/scripts/auth-spoof.nse
%%DATADIR%%/scripts/banner.nse
+%%DATADIR%%/scripts/broadcast-dns-service-discovery.nse
+%%DATADIR%%/scripts/broadcast-ms-sql-discover.nse
+%%DATADIR%%/scripts/broadcast-upnp-info.nse
+%%DATADIR%%/scripts/broadcast-wsdd-discover.nse
%%DATADIR%%/scripts/citrix-brute-xml.nse
%%DATADIR%%/scripts/citrix-enum-apps-xml.nse
%%DATADIR%%/scripts/citrix-enum-apps.nse
@@ -89,9 +103,8 @@ bin/nping
%%DATADIR%%/scripts/couchdb-stats.nse
%%DATADIR%%/scripts/daap-get-library.nse
%%DATADIR%%/scripts/daytime.nse
-%%DATADIR%%/scripts/db2-brute.nse
%%DATADIR%%/scripts/db2-das-info.nse
-%%DATADIR%%/scripts/db2-info.nse
+%%DATADIR%%/scripts/db2-discover.nse
%%DATADIR%%/scripts/dhcp-discover.nse
%%DATADIR%%/scripts/dns-cache-snoop.nse
%%DATADIR%%/scripts/dns-fuzz.nse
@@ -100,16 +113,29 @@ bin/nping
%%DATADIR%%/scripts/dns-recursion.nse
%%DATADIR%%/scripts/dns-service-discovery.nse
%%DATADIR%%/scripts/dns-zone-transfer.nse
+%%DATADIR%%/scripts/domcon-brute.nse
+%%DATADIR%%/scripts/domcon-cmd.nse
+%%DATADIR%%/scripts/domino-enum-users.nse
+%%DATADIR%%/scripts/drda-brute.nse
+%%DATADIR%%/scripts/drda-info.nse
%%DATADIR%%/scripts/finger.nse
+%%DATADIR%%/scripts/firewalk.nse
%%DATADIR%%/scripts/ftp-anon.nse
%%DATADIR%%/scripts/ftp-bounce.nse
%%DATADIR%%/scripts/ftp-brute.nse
%%DATADIR%%/scripts/ftp-libopie.nse
-%%DATADIR%%/scripts/html-title.nse
+%%DATADIR%%/scripts/ftp-proftpd-backdoor.nse
+%%DATADIR%%/scripts/giop-info.nse
+%%DATADIR%%/scripts/gopher-ls.nse
+%%DATADIR%%/scripts/hddtemp-info.nse
+%%DATADIR%%/scripts/hostmap.nse
%%DATADIR%%/scripts/http-auth.nse
+%%DATADIR%%/scripts/http-brute.nse
%%DATADIR%%/scripts/http-date.nse
+%%DATADIR%%/scripts/http-domino-enum-passwords.nse
%%DATADIR%%/scripts/http-enum.nse
%%DATADIR%%/scripts/http-favicon.nse
+%%DATADIR%%/scripts/http-form-brute.nse
%%DATADIR%%/scripts/http-headers.nse
%%DATADIR%%/scripts/http-iis-webdav-vuln.nse
%%DATADIR%%/scripts/http-malware-host.nse
@@ -117,19 +143,28 @@ bin/nping
%%DATADIR%%/scripts/http-open-proxy.nse
%%DATADIR%%/scripts/http-passwd.nse
%%DATADIR%%/scripts/http-php-version.nse
+%%DATADIR%%/scripts/http-robots.txt.nse
+%%DATADIR%%/scripts/http-title.nse
%%DATADIR%%/scripts/http-trace.nse
%%DATADIR%%/scripts/http-userdir-enum.nse
+%%DATADIR%%/scripts/http-vhosts.nse
%%DATADIR%%/scripts/http-vmware-path-vuln.nse
%%DATADIR%%/scripts/iax2-version.nse
%%DATADIR%%/scripts/imap-capabilities.nse
+%%DATADIR%%/scripts/informix-brute.nse
+%%DATADIR%%/scripts/informix-query.nse
+%%DATADIR%%/scripts/informix-tables.nse
%%DATADIR%%/scripts/ipidseq.nse
%%DATADIR%%/scripts/irc-info.nse
%%DATADIR%%/scripts/irc-unrealircd-backdoor.nse
+%%DATADIR%%/scripts/iscsi-brute.nse
+%%DATADIR%%/scripts/iscsi-info.nse
%%DATADIR%%/scripts/jdwp-version.nse
%%DATADIR%%/scripts/ldap-brute.nse
%%DATADIR%%/scripts/ldap-rootdse.nse
%%DATADIR%%/scripts/ldap-search.nse
%%DATADIR%%/scripts/lexmark-config.nse
+%%DATADIR%%/scripts/modbus-discover.nse
%%DATADIR%%/scripts/mongodb-databases.nse
%%DATADIR%%/scripts/mongodb-info.nse
%%DATADIR%%/scripts/ms-sql-brute.nse
@@ -146,14 +181,22 @@ bin/nping
%%DATADIR%%/scripts/mysql-info.nse
%%DATADIR%%/scripts/mysql-users.nse
%%DATADIR%%/scripts/mysql-variables.nse
+%%DATADIR%%/scripts/nat-pmp-info.nse
%%DATADIR%%/scripts/nbstat.nse
+%%DATADIR%%/scripts/netbus-auth-bypass.nse
+%%DATADIR%%/scripts/netbus-brute.nse
+%%DATADIR%%/scripts/netbus-info.nse
+%%DATADIR%%/scripts/netbus-version.nse
%%DATADIR%%/scripts/nfs-ls.nse
%%DATADIR%%/scripts/nfs-showmount.nse
%%DATADIR%%/scripts/nfs-statfs.nse
%%DATADIR%%/scripts/ntp-info.nse
%%DATADIR%%/scripts/ntp-monlist.nse
+%%DATADIR%%/scripts/oracle-brute.nse
+%%DATADIR%%/scripts/oracle-enum-users.nse
%%DATADIR%%/scripts/oracle-sid-brute.nse
%%DATADIR%%/scripts/p2p-conficker.nse
+%%DATADIR%%/scripts/path-mtu.nse
%%DATADIR%%/scripts/pgsql-brute.nse
%%DATADIR%%/scripts/pjl-ready-message.nse
%%DATADIR%%/scripts/pop3-brute.nse
@@ -161,7 +204,8 @@ bin/nping
%%DATADIR%%/scripts/pptp-version.nse
%%DATADIR%%/scripts/qscan.nse
%%DATADIR%%/scripts/realvnc-auth-bypass.nse
-%%DATADIR%%/scripts/robots.txt.nse
+%%DATADIR%%/scripts/resolveall.nse
+%%DATADIR%%/scripts/rmi-dumpregistry.nse
%%DATADIR%%/scripts/rpcinfo.nse
%%DATADIR%%/scripts/script.db
%%DATADIR%%/scripts/skypev2-version.nse
@@ -173,6 +217,7 @@ bin/nping
%%DATADIR%%/scripts/smb-enum-sessions.nse
%%DATADIR%%/scripts/smb-enum-shares.nse
%%DATADIR%%/scripts/smb-enum-users.nse
+%%DATADIR%%/scripts/smb-flood.nse
%%DATADIR%%/scripts/smb-os-discovery.nse
%%DATADIR%%/scripts/smb-psexec.nse
%%DATADIR%%/scripts/smb-security-mode.nse
@@ -196,22 +241,28 @@ bin/nping
%%DATADIR%%/scripts/socks-open-proxy.nse
%%DATADIR%%/scripts/sql-injection.nse
%%DATADIR%%/scripts/ssh-hostkey.nse
+%%DATADIR%%/scripts/ssh2-enum-algos.nse
%%DATADIR%%/scripts/sshv1.nse
%%DATADIR%%/scripts/ssl-cert.nse
%%DATADIR%%/scripts/ssl-enum-ciphers.nse
%%DATADIR%%/scripts/sslv2.nse
+%%DATADIR%%/scripts/stuxnet-detect.nse
+%%DATADIR%%/scripts/svn-brute.nse
+%%DATADIR%%/scripts/targets-traceroute.nse
%%DATADIR%%/scripts/telnet-brute.nse
%%DATADIR%%/scripts/upnp-info.nse
+%%DATADIR%%/scripts/vnc-brute.nse
+%%DATADIR%%/scripts/vnc-info.nse
+%%DATADIR%%/scripts/wdb-version.nse
%%DATADIR%%/scripts/whois.nse
+%%DATADIR%%/scripts/wsdd-discover.nse
%%DATADIR%%/scripts/x11-access.nse
@dirrm %%DATADIR%%/scripts
@dirrm %%DATADIR%%/nselib/data/psexec
@dirrm %%DATADIR%%/nselib/data
@dirrm %%DATADIR%%/nselib
@dirrm %%DATADIR%%
-@dirrm %%NPINGDIR%%
-@dirrm %%NCATDATADIR%%
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%WITHSSL%%@dirrm share/ncat
@dirrmtry man/zh/man1
@dirrmtry man/zh
@dirrmtry man/sk/man1
@@ -240,5 +291,3 @@ bin/nping
@dirrmtry man/es
@dirrmtry man/de/man1
@dirrmtry man/de
-@exec mkdir -p %D/%%NCATDATADIR%%
-@exec mkdir -p %D/%%NPINGDIR%%