aboutsummaryrefslogtreecommitdiff
path: root/security/nofgpg
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-03-15 13:13:12 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-03-15 13:13:12 +0000
commit8a2e1cba18e56907db369e31dcd819ccdc97d2ec (patch)
treec504eac6e91794ba0bc5e3892d9105872daa71ea /security/nofgpg
parent8fff289bbbe64a0ff502d177958707ddf1f025cc (diff)
downloadports-8a2e1cba18e56907db369e31dcd819ccdc97d2ec.tar.gz
ports-8a2e1cba18e56907db369e31dcd819ccdc97d2ec.zip
add nofgpg 0.4
No One Fears GPG
Notes
Notes: svn path=/head/; revision=56150
Diffstat (limited to 'security/nofgpg')
-rw-r--r--security/nofgpg/Makefile31
-rw-r--r--security/nofgpg/distinfo1
-rw-r--r--security/nofgpg/pkg-comment1
-rw-r--r--security/nofgpg/pkg-descr3
-rw-r--r--security/nofgpg/pkg-plist1
5 files changed, 37 insertions, 0 deletions
diff --git a/security/nofgpg/Makefile b/security/nofgpg/Makefile
new file mode 100644
index 000000000000..f92304aecfb2
--- /dev/null
+++ b/security/nofgpg/Makefile
@@ -0,0 +1,31 @@
+# ex:ts=8
+# Ports collection makefile for: nofgpg
+# Date created: Mar 15, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= nofgpg
+PORTVERSION= 0.4
+CATEGORIES= security python
+MASTER_SITES= http://www.cgabriel.org/sw/nofgpg/
+
+MAINTAINER= ports@FreeBSD.org
+
+RUN_DEPENDS= gpg:${PORTSDIR}/security/gnupg \
+ ${PYTHON_SITELIBDIR}/gnome/ui.py:${PORTSDIR}/x11-toolkits/py-gnome
+
+USE_PYTHON= yes
+NO_BUILD= yes
+
+MAN1= nofgpg.1
+
+post-patch:
+ @${PERL} -pi -e "s,/usr/share,${X11BASE}/share/gnome,g" ${WRKSRC}/nofgpg
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ @${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MAN1PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/security/nofgpg/distinfo b/security/nofgpg/distinfo
new file mode 100644
index 000000000000..e51d5a9c9e59
--- /dev/null
+++ b/security/nofgpg/distinfo
@@ -0,0 +1 @@
+MD5 (nofgpg-0.4.tar.gz) = 6f4ab30003a616d72be02f4d047bd997
diff --git a/security/nofgpg/pkg-comment b/security/nofgpg/pkg-comment
new file mode 100644
index 000000000000..dec7dbf146d7
--- /dev/null
+++ b/security/nofgpg/pkg-comment
@@ -0,0 +1 @@
+No One Fears GPG
diff --git a/security/nofgpg/pkg-descr b/security/nofgpg/pkg-descr
new file mode 100644
index 000000000000..895b6daa6991
--- /dev/null
+++ b/security/nofgpg/pkg-descr
@@ -0,0 +1,3 @@
+No One Fears GPG
+
+WWW: http://www.cgabriel.org/sw/nofgpg/
diff --git a/security/nofgpg/pkg-plist b/security/nofgpg/pkg-plist
new file mode 100644
index 000000000000..0074fbcf355b
--- /dev/null
+++ b/security/nofgpg/pkg-plist
@@ -0,0 +1 @@
+bin/nofgpg