aboutsummaryrefslogtreecommitdiff
path: root/security/op/Makefile
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2003-09-09 15:52:56 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2003-09-09 15:52:56 +0000
commit4e0429d90d386ff9153908be9b8f44b59bfe5820 (patch)
tree9ad9380524603636db0908661e3c21e32a87ee82 /security/op/Makefile
parent604abc9beff57e9233e04a3d0f0b701b4bd7b31f (diff)
downloadports-4e0429d90d386ff9153908be9b8f44b59bfe5820.tar.gz
ports-4e0429d90d386ff9153908be9b8f44b59bfe5820.zip
Security update with following changes:
Makefile: PLIST_SUB added (CONF_DIR), fix ${NOPORTDOCS}, bump ${PORTREVISION} pkg-plist: etc -> %%CONF_DIR%%, utilize ${DOCSDIR} Setuid misplaced (security fix) for main.c Thanks to cyrill@econ.krasnoyarsk.su for submitting this patch. Also makes portlint happy. Submitted by: Clement Laforet <sheepkiller@cultdeadsheep.org> (maintainer) PR: 56614
Notes
Notes: svn path=/head/; revision=88866
Diffstat (limited to 'security/op/Makefile')
-rw-r--r--security/op/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/security/op/Makefile b/security/op/Makefile
index 727545de97f4..829ea1013598 100644
--- a/security/op/Makefile
+++ b/security/op/Makefile
@@ -7,10 +7,11 @@
PORTNAME= op
PORTVERSION= 1.11
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= ftp://ftp.cerias.purdue.edu/pub/tools/%SUBDIR%/ \
ftp://ftp.rge.com/pub/security/cerias/tools/%SUBDIR%/ \
- ftp://ftp.hacktic.nl/pub/security/coast.cs.purdue.edu/%SUBDIR%/ \
+ ftp://ftp.hacktic.nl/pub/security/coast.cs.purdue.edu/%SUBDIR%/ \
ftp://ftp.nask.pl/pub/mirror/coast.cs.purdue.edu/%SUBDIR%/
MASTER_SITE_SUBDIR= unix/sysutils/${PORTNAME}
@@ -29,6 +30,8 @@ MAKE_ARGS= BASE="${PREFIX}" \
MANOWN=${MANOWN} MANGRP=${MANGRP} MANMODE=${MANMODE}
ALL_TARGET= ${PORTNAME}
+PLIST_SUB= CONF_DIR="${CONF_DIR:S,^${PREFIX}/,,}"
+
MAN8= op.8
PKGDEINSTALL= ${PKGINSTALL}
@@ -82,10 +85,10 @@ install-conf-file:
${PKGINSTALL} ${PKGNAME} POST-INSTALL
install-doc-files:
-.if !defined(NOPORTSDOC)
+.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
-.for file in ${DOC_FILES}
- @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}/${file}
+.for f in ${DOC_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
.endfor
.endif