aboutsummaryrefslogtreecommitdiff
path: root/security/opencryptoki
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2010-12-19 03:43:56 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2010-12-19 03:43:56 +0000
commit72b2fd1028cfc25c28b843150b23a9626406f20c (patch)
tree3b5966bdd97ebe39d954cf1ee5d1a24efa512b5c /security/opencryptoki
parent55403f4819eb77efcd089d0bd7e57cecea17846d (diff)
downloadports-72b2fd1028cfc25c28b843150b23a9626406f20c.tar.gz
ports-72b2fd1028cfc25c28b843150b23a9626406f20c.zip
o Add a important hack to tpmtoken_init(1).
o Bump PORTREVISION, accordingly.
Notes
Notes: svn path=/head/; revision=266563
Diffstat (limited to 'security/opencryptoki')
-rw-r--r--security/opencryptoki/Makefile2
-rw-r--r--security/opencryptoki/files/patch-usr-sbin-pkcsslotd-mutex.c19
2 files changed, 18 insertions, 3 deletions
diff --git a/security/opencryptoki/Makefile b/security/opencryptoki/Makefile
index 9ecb2f5b2b0b..b53785735680 100644
--- a/security/opencryptoki/Makefile
+++ b/security/opencryptoki/Makefile
@@ -7,7 +7,7 @@
PORTNAME= opencryptoki
PORTVERSION= 2.3.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}
diff --git a/security/opencryptoki/files/patch-usr-sbin-pkcsslotd-mutex.c b/security/opencryptoki/files/patch-usr-sbin-pkcsslotd-mutex.c
index 4b8c83064dbe..412566aa9422 100644
--- a/security/opencryptoki/files/patch-usr-sbin-pkcsslotd-mutex.c
+++ b/security/opencryptoki/files/patch-usr-sbin-pkcsslotd-mutex.c
@@ -1,5 +1,5 @@
--- usr/sbin/pkcsslotd/mutex.c.orig 2010-07-29 21:28:41.000000000 +0900
-+++ usr/sbin/pkcsslotd/mutex.c 2010-10-20 01:19:28.613984045 +0900
++++ usr/sbin/pkcsslotd/mutex.c 2010-12-19 12:13:34.837579374 +0900
@@ -293,6 +293,26 @@
#include "pkcsslotd.h"
@@ -27,11 +27,26 @@
#if SYSVSEM
#error "Caveat Emptor... this does not work"
-@@ -315,7 +335,6 @@
+@@ -315,7 +335,7 @@
#include <sys/types.h>
#include <sys/stat.h>
#include <fcntl.h>
-#include <sys/file.h>
++#include <grp.h>
static int xplfd=-1;
#endif
+@@ -349,6 +369,13 @@
+ #elif (SPINXPL)
+
+ xplfd = open (XPL_FILE,O_CREAT|O_RDWR,S_IRWXU|S_IRWXG|S_IRWXO);
++ {
++ struct group *grp;
++ fchmod(xplfd,S_IRUSR|S_IWUSR|S_IRGRP|S_IWGRP|S_IROTH);
++ grp = getgrnam(PKCS11GROUP);
++ if (grp)
++ fchown(xplfd,getuid(),grp->gr_gid);
++ }
+
+ #elif (SYSVSEM)
+ #error "Caveat Emptor... this does not work"