aboutsummaryrefslogtreecommitdiff
path: root/security/opensc/Makefile
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2008-08-26 15:39:09 +0000
committerAlex Dupre <ale@FreeBSD.org>2008-08-26 15:39:09 +0000
commit62556f3805d5f737b54fa383b8a4da7eab299261 (patch)
tree96cb5fb23502887a87bd3a8781fdc9f4ba8af355 /security/opensc/Makefile
parentf3804e98bd8d53a9bdd8526dcb76c099aedea787 (diff)
downloadports-62556f3805d5f737b54fa383b8a4da7eab299261.tar.gz
ports-62556f3805d5f737b54fa383b8a4da7eab299261.zip
Update to 0.11.5 release.
Notes
Notes: svn path=/head/; revision=219232
Diffstat (limited to 'security/opensc/Makefile')
-rw-r--r--security/opensc/Makefile50
1 files changed, 28 insertions, 22 deletions
diff --git a/security/opensc/Makefile b/security/opensc/Makefile
index 00e462f4efca..c638689ac9c3 100644
--- a/security/opensc/Makefile
+++ b/security/opensc/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= opensc
-DISTVERSION= 0.11.4
-PORTREVISION= 2
+PORTVERSION= 0.11.5
CATEGORIES= security devel
MASTER_SITES= http://www.opensc-project.org/files/${PORTNAME}/ \
http://www.opensc-project.org/files/${PORTNAME}/testing/
@@ -23,19 +22,14 @@ USE_AUTOTOOLS= libltdl:15
USE_OPENSSL= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_GNOME= gnomehack pkgconfig
+USE_GNOME= pkgconfig
USE_LDCONFIG= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
- LDFLAGS="${LDFLAGS}" \
+CONFIGURE_ENV= LTLIB_CFLAGS="-I${LOCALBASE}/include" \
+ LTLIB_LIBS="-L${LOCALBASE}/lib -lltdl" \
OPENSSL_CFLAGS="-I${OPENSSLINC}" \
OPENSSL_LIBS="-L${OPENSSLLIB} -lssl"
-DOC_FILES= README *.sh *.xsl *.css *.html api html tools
-
PORTDOCS= *
MANCOMPRESSED= no
@@ -68,14 +62,13 @@ MAN5= pkcs15-profile.5
.if !defined(WITHOUT_OPENCT)
LIB_DEPENDS+= openct.1:${PORTSDIR}/security/openct
-.else
-CONFIGURE_ARGS+=--disable-openct
+CONFIGURE_ARGS+=--enable-openct
.endif
.if defined(WITH_PCSC)
LIB_DEPENDS+= pcsclite.1:${PORTSDIR}/devel/pcsc-lite
-.else
-CONFIGURE_ARGS+=--disable-pcsc-lite
+CONFIGURE_ARGS+=--enable-pcsc \
+ --with-pcsc-provider=${LOCALBASE}/lib/libpcsclite.so
.endif
.if defined(WITH_SIGNER)
@@ -84,21 +77,34 @@ PINENTRY?= ${LOCALBASE}/bin/pinentry
PINENTRY_PORT?= security/pinentry
RUN_DEPENDS+= pinentry:${PORTSDIR}/${PINENTRY_PORT}
USE_XORG= x11
-CONFIGURE_ARGS+=--with-libassuan-prefix=${LOCALBASE} \
- --with-plugin-dir=${LOCALBASE}/lib/browser_plugins \
- --with-pin-entry=${PINENTRY}
+CONFIGURE_ARGS+=--enable-nsplugin \
+ --with-libassuan-prefix=${LOCALBASE} \
+ --with-plugindir=${LOCALBASE}/lib/browser_plugins \
+ --with-pinentry=${PINENTRY}
PLIST_SUB+= SIGNER=""
.else
-CONFIGURE_ARGS+=--disable-nsplugin
PLIST_SUB+= SIGNER="@comment "
.endif
-post-install:
- ${INSTALL_DATA} ${WRKSRC}/etc/opensc.conf ${PREFIX}/etc/opensc.conf-sample
.ifndef(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- @(cd ${WRKSRC}/doc && ${CP} -R ${DOC_FILES} ${DOCSDIR})
+CONFIGURE_ARGS+=--enable-doc
.endif
+
+post-patch:
+ @${REINPLACE_CMD} 's|(libdir)/pkgconfig|(prefix)/libdata/pkgconfig|' \
+ ${WRKSRC}/configure
+.if !defined(WITH_SIGNER)
+ @${REINPLACE_CMD} 's|install-data-am: install-pluginDATA|install-data-am:|' \
+ ${WRKSRC}/src/signer/Makefile.in
+.endif
+.ifdef(NOPORTDOCS)
+ @${REINPLACE_CMD} 's|install-data-am: install-dist_docDATA|install-data-am:|' \
+ ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} 's|install-data-am: install-dist_docDATA install-dist_htmlDATA|install-data-am:|' \
+ ${WRKSRC}/doc/Makefile.in
+.endif
+
+post-install:
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>