aboutsummaryrefslogtreecommitdiff
path: root/security/openssh-portable
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2004-03-26 19:56:41 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2004-03-26 19:56:41 +0000
commit80edc26466fde8fe64ab36eab1be93e169a07fc2 (patch)
treec82176aa591e4245656cdf1604c190c5860d096f /security/openssh-portable
parentdd790268ac140f557d0fa67443e5dde7e4b644ad (diff)
downloadports-80edc26466fde8fe64ab36eab1be93e169a07fc2.tar.gz
ports-80edc26466fde8fe64ab36eab1be93e169a07fc2.zip
- make PKGNAMESUFFIX more flexible
Notes
Notes: svn path=/head/; revision=105368
Diffstat (limited to 'security/openssh-portable')
-rw-r--r--security/openssh-portable/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/security/openssh-portable/Makefile b/security/openssh-portable/Makefile
index 5589503372f9..1914de5e797b 100644
--- a/security/openssh-portable/Makefile
+++ b/security/openssh-portable/Makefile
@@ -10,7 +10,7 @@ PORTVERSION= 3.8p1
CATEGORIES= security ipv6
MASTER_SITES= ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/ \
ftp://carroll.cac.psu.edu/pub/OpenBSD/OpenSSH/portable/
-PKGNAMESUFFIX?= -portable
+PKGNAMESUFFIX?= ${PORTABLE_SUFFIX}${GSSAPI_SUFFIX}${BASE_SUFFIX}${PKGNAMESUFFIX2}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= The portable version of OpenBSD's OpenSSH
@@ -32,6 +32,7 @@ PRECIOUS= ssh_config sshd_config \
ssh_host_rsa_key ssh_host_rsa_key.pub \
ssh_host_dsa_key ssh_host_dsa_key.pub
ETCOLD= ${PREFIX}/etc
+PORTABLE_SUFFIX= -portable
.if exists(/usr/include/security/pam_modules.h)
CONFIGURE_ARGS+= --with-pam
@@ -46,7 +47,8 @@ CONFIGURE_ARGS+= --disable-suid-ssh
.endif
.if defined(KRB5_HOME) && exists(${KRB5_HOME})
-PKGNAMESUFFIX= -gssapi
+PORTABLE_SUFFIX=
+GSSAPI_SUFFIX= -gssapi
CONFLICTS+= openssh-portable-*
CONFIGURE_ARGS+= --with-kerberos5=${KRB5_HOME}
.else
@@ -63,7 +65,7 @@ EXTRA_PATCHES+= ${FILESDIR}/batch.patch
.if defined(OPENSSH_OVERWRITE_BASE)
WITH_OPENSSL_BASE= yes
-PKGNAMESUFFIX= -overwrite-base
+BASE_SUFFIX= -overwrite-base
PREFIX= /usr
MANPREFIX= ${PREFIX}/share
CONFIGURE_ARGS+= --mandir=${MANPREFIX}/man --localstatedir=/var
@@ -87,7 +89,7 @@ CONFIGURE_ARGS+= --sysconfdir=${ETCSSH}
CONFIGURE_ARGS+= --with-privsep-path=${EMPTYDIR}
post-patch:
- @${REINPLACE_CMD} -e 's|-ldes||g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-ldes|-lcrypto|g' ${WRKSRC}/configure
post-configure:
${SED} -e 's:__PREFIX__:${PREFIX}:g' \