aboutsummaryrefslogtreecommitdiff
path: root/security/openssh/Makefile
diff options
context:
space:
mode:
authorBrian Feldman <green@FreeBSD.org>1999-11-15 06:48:02 +0000
committerBrian Feldman <green@FreeBSD.org>1999-11-15 06:48:02 +0000
commitd4dc9aea78ea26a59c113e0809dab52187ad1bc9 (patch)
treedb6a9e04c3a4f64a928ed460642bed64301cd34f /security/openssh/Makefile
parenta6c63233907b1dab230cfec18b4e13f03fd410a2 (diff)
downloadports-d4dc9aea78ea26a59c113e0809dab52187ad1bc9.tar.gz
ports-d4dc9aea78ea26a59c113e0809dab52187ad1bc9.zip
Bump CVS_DATE to a few minutes ago, and update MD5 checksums for updated
files. Also, CVS_RSH can now be specified (to override the ignored environmental CVS_RSH) as PORTS_CVS_RSH. For instance, you can use ssh to check out ssh ( :] ) with "PORTS_CVS_RSH=ssh make fetch".
Notes
Notes: svn path=/head/; revision=23137
Diffstat (limited to 'security/openssh/Makefile')
-rw-r--r--security/openssh/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/security/openssh/Makefile b/security/openssh/Makefile
index b3cef210d607..0037d56810e2 100644
--- a/security/openssh/Makefile
+++ b/security/openssh/Makefile
@@ -21,7 +21,7 @@ CAT?= /bin/cat
DISTFILES!= ${CAT} ${FILESDIR}/distfiles
CVS_CMD?= cvs -z3
-CVS_DATE= Fri Nov 12 20:27:53 EST 1999
+CVS_DATE= Mon Nov 15 01:30:17 EST 1999
CVS_SITE?= anoncvs@anoncvs1.ca.openbsd.org:/cvs
CRYPTOLIBS= -L${PREFIX}/lib -lcrypto
.if defined(USA_RESIDENT) && ${USA_RESIDENT} == YES
@@ -48,6 +48,9 @@ do-fetch:
@if [ ! -e ${STAMPFILE} ] || \
[ "X${CVS_DATE}" != "X$$(${CAT} ${STAMPFILE})" ]; then \
unset CVS_RSH CVS_SERVER || ${TRUE}; \
+ if [ -n "${PORTS_CVS_RSH}" ]; then \
+ export CVS_RSH="${PORTS_CVS_RSH}"; \
+ fi; \
${MKDIR} ${DISTDIR}/${PKGNAME} && \
cd ${DISTDIR}/${PKGNAME} && \
${CVS_CMD} -d ${CVS_SITE} co -D "${CVS_DATE}" ${DISTNAME} && \