aboutsummaryrefslogtreecommitdiff
path: root/security/openssl
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-09-16 16:45:35 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-09-16 16:45:35 +0000
commitcddacdc1a85e239682053f3716b7c685f422ebf4 (patch)
tree62ec5ad5c85e69fd9755b85db994f8c7042a1fc0 /security/openssl
parent1f7b0d3e1b562bcd76f89ebdbd346571511c07c0 (diff)
downloadports-cddacdc1a85e239682053f3716b7c685f422ebf4.tar.gz
ports-cddacdc1a85e239682053f3716b7c685f422ebf4.zip
Convert to new perl framework
Convert USE_GMAKE to USES
Notes
Notes: svn path=/head/; revision=327414
Diffstat (limited to 'security/openssl')
-rw-r--r--security/openssl/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index a2eaa1666195..5b89ac122505 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -48,12 +48,13 @@ MAKE_JOBS_UNSAFE= yes
NOPRECIOUSMAKEVARS= Too many _MLINKS for fetch
NOPRECIOUSSOFTMAKEVARS= Too many _MLINKS for fetch
-USE_PERL5_BUILD= yes
-MAKE_ARGS+= WHOLE_ARCHIVE_FLAG=--whole-archive
-MAKE_ENV+= LIBRPATH="${PREFIX}/lib"
-SUB_FILES= pkg-message
-OPENSSLDIR= ${PREFIX}/openssl
-MANPREFIX= ${PREFIX}
+USES= perl5
+USE_PERL5= build
+MAKE_ARGS+= WHOLE_ARCHIVE_FLAG=--whole-archive
+MAKE_ENV+= LIBRPATH="${PREFIX}/lib"
+SUB_FILES= pkg-message
+OPENSSLDIR= ${PREFIX}/openssl
+MANPREFIX= ${PREFIX}
MAN1= CA.pl.1 asn1parse.1 ca.1 ciphers.1 cms.1 crl.1 crl2pkcs7.1 dgst.1 \
dhparam.1 dsa.1 dsaparam.1 ec.1 ecparam.1 enc.1 errstr.1 gendsa.1 \