aboutsummaryrefslogtreecommitdiff
path: root/security/openvpn-admin/Makefile
diff options
context:
space:
mode:
authorTom McLaughlin <tmclaugh@FreeBSD.org>2007-02-04 23:40:54 +0000
committerTom McLaughlin <tmclaugh@FreeBSD.org>2007-02-04 23:40:54 +0000
commit910ce3d2d420531d1fc9871211ab9e935d78a390 (patch)
tree58b336e923377a1594c66d1682e162bac2d6c0d8 /security/openvpn-admin/Makefile
parent6ca721ccd76581393caff70b18297b19f16bac22 (diff)
downloadports-910ce3d2d420531d1fc9871211ab9e935d78a390.tar.gz
ports-910ce3d2d420531d1fc9871211ab9e935d78a390.zip
- Update to 1.9.3b (required by lang/mono update)
Version 1.9.3b * OpenVPN-Admin start now only with tray icon and not with full screen. (Yeah, I spent a night thinking the app was broken because of this.) * In Certificate Management the Certificate details will show, like Name, Email, City, Expiration Date ... * Proxy support now Authentication and Auth Method * Fix certificate selection on Windows and Linux. Now not full path is added * Certificates with password protection fixed on Windows and Linux * Add Type Server to OpenVPN-Admin * Translation for Brazilian-Portuguese and German improved - USE_GNOME=+gtksharp20 - Remove unnecessary FreeBSD version check - install .desktop correctly - Don't install a pam config file. The one distributed with the port doesn't work on FreeBSD and it's not the port's job to dictate what users can use openvpn-admin.
Notes
Notes: svn path=/head/; revision=184199
Diffstat (limited to 'security/openvpn-admin/Makefile')
-rw-r--r--security/openvpn-admin/Makefile22
1 files changed, 7 insertions, 15 deletions
diff --git a/security/openvpn-admin/Makefile b/security/openvpn-admin/Makefile
index c062aba4e948..e029bf4df205 100644
--- a/security/openvpn-admin/Makefile
+++ b/security/openvpn-admin/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= openvpn-admin
-PORTVERSION= 1.9.2
-PORTREVISION= 3
+PORTVERSION= 1.9.3b
CATEGORIES= security gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,22 +14,16 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= MrL0Lz@gmail.com
COMMENT= GUI frontend to openvpn
-BUILD_DEPENDS= mono:${PORTSDIR}/lang/mono \
- gapi2-codegen:${PORTSDIR}/x11-toolkits/gtk-sharp20
-RUN_DEPENDS= mono:${PORTSDIR}/lang/mono \
- gapi2-codegen:${PORTSDIR}/x11-toolkits/gtk-sharp20 \
- openvpn:${PORTSDIR}/security/openvpn
+RUN_DEPENDS= openvpn:${PORTSDIR}/security/openvpn
+
+WRKSRC= ${WRKDIR}/${DISTNAME:S/b//}
USE_GMAKE= yes
-USE_GNOME= gtk20
+USE_GNOME= gtksharp20
GNU_CONFIGURE= yes
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-BROKEN= Some dependencies don't build on FreeBSD < 5.x
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's,/usr/bin/iconv,${LOCALBASE}/bin/iconv,g' \
${WRKSRC}/intltool-merge.in
@@ -39,9 +32,8 @@ post-patch:
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/openvpn-admin ${PREFIX}/sbin
- ${INSTALL_DATA} ${WRKSRC}/openvpn-admin.pam ${PREFIX}/etc/pam.d/openvpn-admin
- ${MKDIR} ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/openvpn-admin.desktop ${DATADIR}
+ ${MKDIR} ${PREFIX}/share/applications || ${TRUE}
+ ${INSTALL_DATA} ${WRKSRC}/openvpn-admin.desktop ${PREFIX}/share/applications/
${MKDIR} ${PREFIX}/lib/${PORTNAME}
${INSTALL_DATA} ${WRKSRC}/src/openvpn-admin.exe ${PREFIX}/lib/${PORTNAME}
${MKDIR} ${PREFIX}/etc/openvpn