aboutsummaryrefslogtreecommitdiff
path: root/security/openvpn-beta/Makefile
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2012-10-11 20:11:26 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2012-10-11 20:11:26 +0000
commit29193d8a233fa7078b8696244957673599969e58 (patch)
treea5eef44b930a5893cee98bdd079ae5ad4e34e1ca /security/openvpn-beta/Makefile
parentb639546b3c0f0d30c42bd6448d5ca722df92764d (diff)
downloadports-29193d8a233fa7078b8696244957673599969e58.tar.gz
ports-29193d8a233fa7078b8696244957673599969e58.zip
- Properly install symlinks for auth-pam and down-root plugins [1]
- Fix pkg-message description of locations of these plugins [1] - Fix plist for nonexistent DOCSDIR/openvpn PR: ports/172598 [1] Submitted by: Eric F Crist <ecrist@secure-computing.net> (maintainer) [1] Feature safe: yes
Notes
Notes: svn path=/head/; revision=305740
Diffstat (limited to 'security/openvpn-beta/Makefile')
-rw-r--r--security/openvpn-beta/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/security/openvpn-beta/Makefile b/security/openvpn-beta/Makefile
index fe5815059a49..e28d40e6b9ef 100644
--- a/security/openvpn-beta/Makefile
+++ b/security/openvpn-beta/Makefile
@@ -6,6 +6,7 @@ DISTVERSION= 2.3_beta1
CATEGORIES= security net
MASTER_SITES= http://swupdate.openvpn.net/community/releases/
PKGNAMESUFFIX= -beta
+PORTREVISION= 1
MAINTAINER= ecrist@secure-computing.net
COMMENT= Secure IP/Ethernet tunnel daemon
@@ -90,10 +91,9 @@ post-build:
post-install:
${MKDIR} ${PREFIX}/lib
- ${INSTALL_LIB} ${WRKSRC}/src/plugins/down-root/.libs/openvpn-plugin-down-root.so ${PREFIX}/lib/
- ${INSTALL_LIB} ${WRKSRC}/src/plugins/auth-pam/.libs/openvpn-plugin-auth-pam.so ${PREFIX}/lib/
- ${LN} -s ${WRKSRC}/src/plugins/down-root/.libs/openvpn-plugin-down-root.so ${PREFIX}/lib/openvpn-down-root.so
- ${LN} -s ${WRKSRC}/src/plugins/down-root/.libs/openvpn-plugin-auth-pam.so ${PREFIX}/lib/openvpn-auth-pam.so
+ ${LN} -s ${PREFIX}/lib/openvpn/plugins/openvpn-plugin-down-root.so ${PREFIX}/lib/openvpn-down-root.so
+ ${LN} -s ${PREFIX}/lib/openvpn/plugins/openvpn-plugin-auth-pam.so ${PREFIX}/lib/openvpn-auth-pam.so
+
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
.for docs in AUTHORS COPYING COPYRIGHT.GPL ChangeLog INSTALL \