aboutsummaryrefslogtreecommitdiff
path: root/security/openvpn
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2009-01-25 08:10:57 +0000
committerBeech Rintoul <beech@FreeBSD.org>2009-01-25 08:10:57 +0000
commitb222799b625902dec465377894fb3265c7ec0a49 (patch)
tree8011011a06421763539f3bba66a615b55af4a03d /security/openvpn
parent0156d18214e9827766c1806052beb92dae6f1589 (diff)
downloadports-b222799b625902dec465377894fb3265c7ec0a49.tar.gz
ports-b222799b625902dec465377894fb3265c7ec0a49.zip
- Add logging knob
PR: ports/130893 Submitted by: Michael Scheidell <scheidell@secnap.net> Approved by: Matthias Andree <matthias.andree@gmx.de> (maintainer)
Notes
Notes: svn path=/head/; revision=226831
Diffstat (limited to 'security/openvpn')
-rw-r--r--security/openvpn/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/security/openvpn/Makefile b/security/openvpn/Makefile
index af4db0165d5b..152f2075947b 100644
--- a/security/openvpn/Makefile
+++ b/security/openvpn/Makefile
@@ -43,6 +43,22 @@ SUB_LIST+= OSVERSION=${OSVERSION}
SUB_LIST+= RCSFX=${RC_SUBR_SUFFIX}
+.ifdef (LOG_OPENVPN)
+CFLAGS+= -DLOG_OPENVPN=${LOG_OPENVPN}
+.endif
+
+pre-fetch:
+.ifdef (LOG_OPENVPN)
+ @${ECHO} "Building with LOG_OPENVPN=${LOG_OPENVPN}"
+.else
+ @${ECHO} ""
+ @${ECHO} "You may use the following build options:"
+ @${ECHO} ""
+ @${ECHO} " LOG_OPENVPN={Valid syslog facility}"
+ @${ECHO} " EXAMPLE: make LOG_OPENVPN=LOG_DAEMON"
+ @${ECHO} ""
+.endif
+
# NOTE: there is no way to explicitly specify the LZO version to OpenVPN,
# if LZO2 and LZO1 are installed, OpenVPN will pick LZO2.
# So depend on LZO1 only if it's already there and LZO2 isn't.