aboutsummaryrefslogtreecommitdiff
path: root/security/ossec-hids-server/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-06-09 10:41:07 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-06-09 10:41:07 +0000
commit709418bdd15ba908a4a862d0a2783c70b81cb91d (patch)
tree9100605362674c8b2b581f5434ffafe83bce82ef /security/ossec-hids-server/Makefile
parent543cd07370bfe5df0500b7835e310025dc143151 (diff)
downloadports-709418bdd15ba908a4a862d0a2783c70b81cb91d.tar.gz
ports-709418bdd15ba908a4a862d0a2783c70b81cb91d.zip
- Respect DOCS
- Fix pkg-plist - Fix rc script PR: 113259 Submitted by: Paul Schmehl <pauls@utdallas.edu> Approved by: maintainer
Notes
Notes: svn path=/head/; revision=193088
Diffstat (limited to 'security/ossec-hids-server/Makefile')
-rw-r--r--security/ossec-hids-server/Makefile28
1 files changed, 23 insertions, 5 deletions
diff --git a/security/ossec-hids-server/Makefile b/security/ossec-hids-server/Makefile
index 1d91fe92c0a3..8a556335b804 100644
--- a/security/ossec-hids-server/Makefile
+++ b/security/ossec-hids-server/Makefile
@@ -18,6 +18,11 @@ COMMENT= A security tool to monitor and check logs and intrusions
USE_RC_SUBR= ossec-hids
+SUB_LIST= PORTNAME=${PORTNAME}
+SUB_FILES= pkg-message
+PLIST_SUB= PORTNAME=${PORTNAME}
+PORTDOCS= BUGS CONFIG CONTRIB INSTALL LICENSE README
+
.include <bsd.port.pre.mk>
.if defined(CLIENT_ONLY)
@@ -34,8 +39,6 @@ post-patch:
@${REINPLACE_CMD} 's|PREFIX|${PREFIX}/${PORTNAME}|' ${WRKSRC}/src/LOCATION
@${REINPLACE_CMD} 's|PREFIX|${PREFIX}/${PORTNAME}|' ${WRKSRC}/src/headers/defs.h
-do-configure:
-
do-build:
@cd ${WRKSRC}/src;${MAKE} all;${MAKE} build
@@ -51,12 +54,27 @@ do-install:
.endif
post-install:
+.if defined(CLIENT_ONLY)
+ ${CP} ${WRKSRC}/etc/ossec-agent.conf ${PREFIX}/${PORTNAME}/etc/ossec.conf.sample
+ @if [ ! -f ${PREFIX}/${PORTNAME}/etc/ossec.conf ]; then \
+ ${CP} ${WRKSRC}/etc/ossec-agent.conf ${PREFIX}/${PORTNAME}/etc/ossec.conf; \
+ fi
+.elif defined(LOCAL_ONLY)
+ ${CP} ${WRKSRC}/etc/ossec-local.conf ${PREFIX}/${PORTNAME}/etc/ossec.conf.sample
@if [ ! -f ${PREFIX}/${PORTNAME}/etc/ossec.conf ]; then \
- ${CP} ${PREFIX}/${PORTNAME}/etc/ossec.conf.sample ${PREFIX}/${PORTNAME}/etc/ossec.conf ; \
+ ${CP} ${WRKSRC}/etc/ossec-local.conf ${PREFIX}/${PORTNAME}/etc/ossec.conf; \
fi
+.else
+ @if [ ! -f ${PREFIX}/${PORTNAME}/etc/ossec.conf ]; then \
+ ${CP} ${WRKSRC}/etc/ossec-server.conf ${PREFIX}/${PORTNAME}/etc/ossec.conf; \
+ fi
+.endif
-.if defined(CLIENT_ONLY)
-PLIST=${PKGDIR}/pkg-plist.client
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
+ @${CAT} ${PKGMESSAGE}
+
.include <bsd.port.post.mk>