aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Authen-Simple-HTTP
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-22 05:27:24 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-22 05:27:24 +0000
commit87cb63c95ea576ab841980b16859906193f776e1 (patch)
treeaa3eca691970c6596c47460bc4407607e652cb7e /security/p5-Authen-Simple-HTTP
parentdff0afe74caf57c5e6cb03db35459b8c7fef7e36 (diff)
downloadports-87cb63c95ea576ab841980b16859906193f776e1.tar.gz
ports-87cb63c95ea576ab841980b16859906193f776e1.zip
Adding port security/p5-Authen-Simple-HTTP, HTTP extension for security/p5-Authen-Simple.
Approved by: tobez (implicit)
Notes
Notes: svn path=/head/; revision=163069
Diffstat (limited to 'security/p5-Authen-Simple-HTTP')
-rw-r--r--security/p5-Authen-Simple-HTTP/Makefile32
-rw-r--r--security/p5-Authen-Simple-HTTP/distinfo3
-rw-r--r--security/p5-Authen-Simple-HTTP/pkg-descr4
-rw-r--r--security/p5-Authen-Simple-HTTP/pkg-plist3
4 files changed, 42 insertions, 0 deletions
diff --git a/security/p5-Authen-Simple-HTTP/Makefile b/security/p5-Authen-Simple-HTTP/Makefile
new file mode 100644
index 000000000000..af601ace1d9c
--- /dev/null
+++ b/security/p5-Authen-Simple-HTTP/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: Authen-Simple-HTTP
+# Date created: 21 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Authen-Simple-HTTP
+PORTVERSION= 0.2
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Authen
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Simple HTTP authentication
+
+BUILD_DEPENDS= ${SITE_PERL}/Authen/Simple.pm:${PORTSDIR}/security/p5-Authen-Simple \
+ ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Authen::Simple::HTTP.3
+
+PERL_MODBUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires at least Perl 5.8 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/p5-Authen-Simple-HTTP/distinfo b/security/p5-Authen-Simple-HTTP/distinfo
new file mode 100644
index 000000000000..d144cbac126b
--- /dev/null
+++ b/security/p5-Authen-Simple-HTTP/distinfo
@@ -0,0 +1,3 @@
+MD5 (Authen-Simple-HTTP-0.2.tar.gz) = 167e55e7d4845e6a3b1acb8358253b49
+SHA256 (Authen-Simple-HTTP-0.2.tar.gz) = ccdf68e1ef697775da1a970bbcd2d48712385d5298ac957863a4e5a6d104af64
+SIZE (Authen-Simple-HTTP-0.2.tar.gz) = 2999
diff --git a/security/p5-Authen-Simple-HTTP/pkg-descr b/security/p5-Authen-Simple-HTTP/pkg-descr
new file mode 100644
index 000000000000..8963c9b62607
--- /dev/null
+++ b/security/p5-Authen-Simple-HTTP/pkg-descr
@@ -0,0 +1,4 @@
+Authentication via HTTP.
+
+WWW: http://search.cpan.org/dist/Authen-Simple-Net-HTTP
+Author: Christian Hansen <ch@ngmedia.com>
diff --git a/security/p5-Authen-Simple-HTTP/pkg-plist b/security/p5-Authen-Simple-HTTP/pkg-plist
new file mode 100644
index 000000000000..2ee1597eb822
--- /dev/null
+++ b/security/p5-Authen-Simple-HTTP/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/Authen/Simple/HTTP.pm
+@dirrmtry %%SITE_PERL%%/Authen/Simple
+@dirrmtry %%SITE_PERL%%/Authen