aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Crypt-Lite
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2005-12-18 22:06:01 +0000
committerErwin Lansing <erwin@FreeBSD.org>2005-12-18 22:06:01 +0000
commit4d58b3abc6970677ff9b11f32fbd0a3dac3c856b (patch)
tree395cc58ef883502ec6724c2221ec9d6e7927f5f9 /security/p5-Crypt-Lite
parent429feed8fca4ac2199e7ddbed0637f19bd2bcee9 (diff)
downloadports-4d58b3abc6970677ff9b11f32fbd0a3dac3c856b.tar.gz
ports-4d58b3abc6970677ff9b11f32fbd0a3dac3c856b.zip
Sometimes it's necessary to protect some certain data against plain reading
or you intend to send information through the Internet. Another reason might be to assure users cannot modify their previously entered data in a follow-up step of a long Web transaction where you don't want to deal with server-side session data. The goal of Crypt::Lite was to have a pretty simple way to encrypt and decrypt data without the need to install and compile huge packages with lots of dependencies. Crypt::Lite generates every time a different encrypted hash when you re-encrypt the same data with the same secret string. Nevertheless you are able to make double or tripple-encryption with any data to increase the security. Decryption works also on hashes that have been encrypted on a foreign host (try this with an unpatched IDEA installation ;-). WWW: http://search.cpan.org/dist/Crypt-Lite PR: ports/90614 Submitted by: Gabor Kovesdan
Notes
Notes: svn path=/head/; revision=151521
Diffstat (limited to 'security/p5-Crypt-Lite')
-rw-r--r--security/p5-Crypt-Lite/Makefile24
-rw-r--r--security/p5-Crypt-Lite/distinfo3
-rw-r--r--security/p5-Crypt-Lite/pkg-descr14
-rw-r--r--security/p5-Crypt-Lite/pkg-plist7
4 files changed, 48 insertions, 0 deletions
diff --git a/security/p5-Crypt-Lite/Makefile b/security/p5-Crypt-Lite/Makefile
new file mode 100644
index 000000000000..cac66ed10c53
--- /dev/null
+++ b/security/p5-Crypt-Lite/Makefile
@@ -0,0 +1,24 @@
+# New ports collection Makefile for: p5-Crypt-Lite
+# Date created: 18 Dec 2006
+# Whom: Gabor Kovesdan
+# $FreeBSD$
+
+PORTNAME= Crypt-Lite
+PORTVERSION= 0.82.06
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Crypt
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gkovesdan@t-hosting.hu
+COMMENT= Perl extension for a symmetric data encryption and decryption
+
+PERL_CONFIGURE= yes
+
+MAN3= Crypt::Lite.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} <= 500503
+IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/security/p5-Crypt-Lite/distinfo b/security/p5-Crypt-Lite/distinfo
new file mode 100644
index 000000000000..6a0acd449233
--- /dev/null
+++ b/security/p5-Crypt-Lite/distinfo
@@ -0,0 +1,3 @@
+MD5 (Crypt-Lite-0.82.06.tar.gz) = cd7e2f77ef8b257f4404614676c62186
+SHA256 (Crypt-Lite-0.82.06.tar.gz) = 5258e4c770a643d03edc4e3e9bbd3392022403f1ca432cdf35ade67cda26e07b
+SIZE (Crypt-Lite-0.82.06.tar.gz) = 13181
diff --git a/security/p5-Crypt-Lite/pkg-descr b/security/p5-Crypt-Lite/pkg-descr
new file mode 100644
index 000000000000..dd67af50f72d
--- /dev/null
+++ b/security/p5-Crypt-Lite/pkg-descr
@@ -0,0 +1,14 @@
+Sometimes it's necessary to protect some certain data against plain reading
+or you intend to send information through the Internet. Another reason might
+be to assure users cannot modify their previously entered data in a follow-up
+step of a long Web transaction where you don't want to deal with server-side
+session data. The goal of Crypt::Lite was to have a pretty simple way to
+encrypt and decrypt data without the need to install and compile huge
+packages with lots of dependencies.
+Crypt::Lite generates every time a different encrypted hash when you
+re-encrypt the same data with the same secret string. Nevertheless you
+are able to make double or tripple-encryption with any data to increase
+the security. Decryption works also on hashes that have been encrypted
+on a foreign host (try this with an unpatched IDEA installation ;-).
+
+WWW: http://search.cpan.org/dist/Crypt-Lite
diff --git a/security/p5-Crypt-Lite/pkg-plist b/security/p5-Crypt-Lite/pkg-plist
new file mode 100644
index 000000000000..6a9d69d2d300
--- /dev/null
+++ b/security/p5-Crypt-Lite/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Crypt/Lite.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/Lite/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/Lite/Lite.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/Lite/Lite.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/Lite/
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Crypt 2>/dev/null || true