aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Crypt-OpenPGP
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-04-02 12:19:52 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-04-02 12:19:52 +0000
commit7235ac5ca67edb03d39f24db869c97bc01469eca (patch)
tree89a29a12211cbfdf28fe155d4a3c44bcc5a325d9 /security/p5-Crypt-OpenPGP
parent6ac138c01e17ac994ca4d21aa08601d707f359a6 (diff)
downloadports-7235ac5ca67edb03d39f24db869c97bc01469eca.tar.gz
ports-7235ac5ca67edb03d39f24db869c97bc01469eca.zip
update and fix security/p5-Crypt-OpenPGP
- update to 1.03 to make fetcheable - remove NO_PACKAGE (fix PLIST) - take maintainership - replace homegrown BASEPERL with SITEPERL - remove MANPREFIX - make dependencies dependend on perl version for those included in perl 5.8 - add WWW PR: ports/50488 Submitted by: Erwin Lansing <erwin@lansing.dk>
Notes
Notes: svn path=/head/; revision=77976
Diffstat (limited to 'security/p5-Crypt-OpenPGP')
-rw-r--r--security/p5-Crypt-OpenPGP/Makefile54
-rw-r--r--security/p5-Crypt-OpenPGP/distinfo2
-rw-r--r--security/p5-Crypt-OpenPGP/files/patch-makefile56
-rw-r--r--security/p5-Crypt-OpenPGP/pkg-descr2
-rw-r--r--security/p5-Crypt-OpenPGP/pkg-plist92
5 files changed, 104 insertions, 102 deletions
diff --git a/security/p5-Crypt-OpenPGP/Makefile b/security/p5-Crypt-OpenPGP/Makefile
index c4d5dac22878..085726621bab 100644
--- a/security/p5-Crypt-OpenPGP/Makefile
+++ b/security/p5-Crypt-OpenPGP/Makefile
@@ -6,42 +6,41 @@
#
PORTNAME= Crypt-OpenPGP
-PORTVERSION= 0.16
+PORTVERSION= 1.03
CATEGORIES= security perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Crypt
PKGNAMEPREFIX= p5-
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= erwin@lansing.dk
COMMENT= Pure-Perl OpenPGP-compatible PGP implementation
-NO_PACKAGE= "Runaway package build"
-
-PERLBASE= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
-
-BUILD_DEPENDS= ${PERLBASE}/${PERL_ARCH}/Crypt/DES.pm:${PORTSDIR}/security/p5-Crypt-DES \
- ${PERLBASE}/${PERL_ARCH}/Crypt/Blowfish.pm:${PORTSDIR}/security/p5-Crypt-Blowfish \
- ${PERLBASE}/${PERL_ARCH}/Crypt/IDEA.pm:${PORTSDIR}/security/p5-Crypt-IDEA \
- ${PERLBASE}/Crypt/DSA.pm:${PORTSDIR}/security/p5-Crypt-DSA \
- ${PERLBASE}/Crypt/RSA.pm:${PORTSDIR}/security/p5-Crypt-RSA \
- ${PERLBASE}/${PERL_ARCH}/Crypt/RIPEMD160.pm:${PORTSDIR}/security/p5-Crypt-RIPEMD160 \
- ${PERLBASE}/${PERL_ARCH}/Crypt/Rijndael.pm:${PORTSDIR}/security/p5-Crypt-Rijndael \
- ${PERLBASE}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1 \
- ${PERLBASE}/${PERL_ARCH}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib \
- ${PERLBASE}/${PERL_ARCH}/Math/Pari.pm:${PORTSDIR}/math/p5-Math-Pari \
- ${PERLBASE}/Data/Buffer.pm:${PORTSDIR}/misc/p5-Data-Buffer \
- ${PERLBASE}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
- ${PERLBASE}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Crypt/DES.pm:${PORTSDIR}/security/p5-Crypt-DES \
+ ${SITE_PERL}/${PERL_ARCH}/Crypt/Blowfish.pm:${PORTSDIR}/security/p5-Crypt-Blowfish \
+ ${SITE_PERL}/${PERL_ARCH}/Crypt/IDEA.pm:${PORTSDIR}/security/p5-Crypt-IDEA \
+ ${SITE_PERL}/Crypt/DSA.pm:${PORTSDIR}/security/p5-Crypt-DSA \
+ ${SITE_PERL}/Crypt/RSA.pm:${PORTSDIR}/security/p5-Crypt-RSA \
+ ${SITE_PERL}/${PERL_ARCH}/Crypt/RIPEMD160.pm:${PORTSDIR}/security/p5-Crypt-RIPEMD160 \
+ ${SITE_PERL}/${PERL_ARCH}/Crypt/Rijndael.pm:${PORTSDIR}/security/p5-Crypt-Rijndael \
+ ${SITE_PERL}/Crypt/CAST5_PP.pm:${PORTSDIR}/security/p5-Crypt-CAST5_PP \
+ ${SITE_PERL}/Crypt/DES_EDE3.pm:${PORTSDIR}/security/p5-Crypt-DES_EDE3 \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1 \
+ ${SITE_PERL}/${PERL_ARCH}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib \
+ ${SITE_PERL}/${PERL_ARCH}/Math/Pari.pm:${PORTSDIR}/math/p5-Math-Pari \
+ ${SITE_PERL}/Data/Buffer.pm:${PORTSDIR}/misc/p5-Data-Buffer \
+ ${SITE_PERL}/URI/Escape.pm:${PORTSDIR}/net/p5-URI \
+ ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww
+
+RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
-MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Crypt::OpenPGP::ErrorHandler.3 Crypt::OpenPGP::Key.3 \
Crypt::OpenPGP::CFB.3 Crypt::OpenPGP::SKSessionKey.3 \
Crypt::OpenPGP::UserID.3 Crypt::OpenPGP::SessionKey.3 \
Crypt::OpenPGP::Words.3 Crypt::OpenPGP::PacketFactory.3 \
Crypt::OpenPGP::S2k.3 Crypt::OpenPGP.3 \
- Crypt::OpenPGP::Signature.3 Crypt::DES_EDE3.3 \
+ Crypt::OpenPGP::Signature.3 \
Crypt::OpenPGP::KeyBlock.3 Crypt::OpenPGP::MDC.3 \
Crypt::OpenPGP::Compressed.3 Crypt::OpenPGP::Armour.3 \
Crypt::OpenPGP::KeyRing.3 Crypt::OpenPGP::Plaintext.3 \
@@ -50,6 +49,15 @@ MAN3= Crypt::OpenPGP::ErrorHandler.3 Crypt::OpenPGP::Key.3 \
Crypt::OpenPGP::Util.3 Crypt::OpenPGP::Digest.3 \
Crypt::OpenPGP::Ciphertext.3 Crypt::OpenPGP::Marker.3 \
Crypt::OpenPGP::Trust.3 Crypt::OpenPGP::Certificate.3 \
- Crypt::OpenPGP::Message.3
+ Crypt::OpenPGP::Message.3 Crypt::OpenPGP::KeyServer.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/p5-Crypt-OpenPGP/distinfo b/security/p5-Crypt-OpenPGP/distinfo
index 05740a37c36f..de4e7807603e 100644
--- a/security/p5-Crypt-OpenPGP/distinfo
+++ b/security/p5-Crypt-OpenPGP/distinfo
@@ -1 +1 @@
-MD5 (Crypt-OpenPGP-0.16.tar.gz) = cda01e391e4e23084b66db00bddfee8f
+MD5 (Crypt-OpenPGP-1.03.tar.gz) = 020141cf2a3c22b50373fc5aeb7914d2
diff --git a/security/p5-Crypt-OpenPGP/files/patch-makefile b/security/p5-Crypt-OpenPGP/files/patch-makefile
index cc2dfe5e76ae..047d459ac5bc 100644
--- a/security/p5-Crypt-OpenPGP/files/patch-makefile
+++ b/security/p5-Crypt-OpenPGP/files/patch-makefile
@@ -1,35 +1,25 @@
---- Makefile.PL.orig Tue Sep 11 10:23:45 2001
-+++ Makefile.PL Tue Sep 11 10:25:39 2001
-@@ -49,9 +49,9 @@
- MSG
- my $i = 1;
- for my $ciph (@cryptmod) {
-- printf " [%d] %s\n", $i++, $ciph->[0];
-+ #printf " [%d] %s\n", $i++, $ciph->[0];
- }
--my $c = prompt("\nEnter your choices, separated by spaces:", 1);
-+my $c = "1 2 5";
- print "\n";
+--- Makefile.PL.orig Mon Mar 31 17:57:10 2003
++++ Makefile.PL Mon Mar 31 17:58:26 2003
+@@ -43,22 +43,6 @@
+ 'Crypt::RIPEMD160' => 0,
+ ],
- for my $id (split /\s+/, $c) {
-@@ -70,9 +70,9 @@
- MSG
- my $i = 1;
- for my $ciph (@dgstmod) {
-- printf " [%d] %s\n", $i++, $ciph->[0];
-+ #printf " [%d] %s\n", $i++, $ciph->[0];
- }
--my $c = prompt("\nEnter your choices, separated by spaces:", 2);
-+my $c = "1 2";
- print "\n";
+- 'Support for all ciphers' => [
+- -default => $is_sdk,
+- 'Crypt::IDEA' => 0,
+- 'Crypt::DES_EDE3' => 0,
+- 'Crypt::CAST5_PP' => 0,
+- 'Crypt::Blowfish' => 0,
+- 'Crypt::Twofish' => '2.00',
+- 'Crypt::Rijndael' => 0,
+- ],
+-
+- 'Support for all digests' => [
+- -default => $is_sdk,
+- 'Digest::MD5' => 0,
+- 'Digest::SHA1' => 0,
+- 'Crypt::RIPEMD160' => 0,
+- ],
+ );
- for my $id (split /\s+/, $c) {
-@@ -98,7 +98,7 @@
- for my $pk (@pkmod) {
- printf " [%d] %s\n", $i++, $pk->[0];
- }
--my $c = prompt("\nEnter your choices, separated by spaces:", '1 2');
-+my $c = "1 2";
- print "\n";
-
- for my $id (split /\s+/, $c) {
+ WriteMakefile(
diff --git a/security/p5-Crypt-OpenPGP/pkg-descr b/security/p5-Crypt-OpenPGP/pkg-descr
index f26496b779a0..84486c43eeb0 100644
--- a/security/p5-Crypt-OpenPGP/pkg-descr
+++ b/security/p5-Crypt-OpenPGP/pkg-descr
@@ -19,3 +19,5 @@ ciphers 3DES, Blowfish, IDEA, Twofish, and Rijndael (AES). Rijndael is
supported for key sizes of 128, 192, and 256 bits. Crypt::OpenPGP
supports the digest algorithms MD5, SHA-1, and RIPE-MD/160. And it
supports ZIP and Zlib compression.
+
+WWW: http://search.cpan.org/dist/Crypt-OpenPGP/
diff --git a/security/p5-Crypt-OpenPGP/pkg-plist b/security/p5-Crypt-OpenPGP/pkg-plist
index 34ecea5ef7da..58794e59172f 100644
--- a/security/p5-Crypt-OpenPGP/pkg-plist
+++ b/security/p5-Crypt-OpenPGP/pkg-plist
@@ -1,45 +1,47 @@
-lib/perl5/site_perl/%%PERL_VER%%/Crypt/OpenPGP/Key.pm
-lib/perl5/site_perl/%%PERL_VER%%/Crypt/OpenPGP/CFB.pm
-lib/perl5/site_perl/%%PERL_VER%%/Crypt/OpenPGP/UserID.pm
-lib/perl5/site_perl/%%PERL_VER%%/Crypt/OpenPGP/S2k.pm
-lib/perl5/site_perl/%%PERL_VER%%/Crypt/OpenPGP/Key/Secret/RSA.pm
-lib/perl5/site_perl/%%PERL_VER%%/Crypt/OpenPGP/Key/Secret/ElGamal.pm
-lib/perl5/site_perl/%%PERL_VER%%/Crypt/OpenPGP/Key/Secret/DSA.pm
-lib/perl5/site_perl/%%PERL_VER%%/Crypt/OpenPGP/Key/Public/ElGamal.pm
-lib/perl5/site_perl/%%PERL_VER%%/Crypt/OpenPGP/Key/Public/DSA.pm
-lib/perl5/site_perl/%%PERL_VER%%/Crypt/OpenPGP/Key/Public/RSA.pm
-lib/perl5/site_perl/%%PERL_VER%%/Crypt/OpenPGP/Key/Secret.pm
-lib/perl5/site_perl/%%PERL_VER%%/Crypt/OpenPGP/Key/Public.pm
-lib/perl5/site_perl/%%PERL_VER%%/Crypt/OpenPGP/Armour.pm
-lib/perl5/site_perl/%%PERL_VER%%/Crypt/OpenPGP/Plaintext.pm
-lib/perl5/site_perl/%%PERL_VER%%/Crypt/OpenPGP/KeyRing.pm
-lib/perl5/site_perl/%%PERL_VER%%/Crypt/OpenPGP/Constants.pm
-lib/perl5/site_perl/%%PERL_VER%%/Crypt/OpenPGP/Util.pm
-lib/perl5/site_perl/%%PERL_VER%%/Crypt/OpenPGP/Ciphertext.pm
-lib/perl5/site_perl/%%PERL_VER%%/Crypt/OpenPGP/Digest.pm
-lib/perl5/site_perl/%%PERL_VER%%/Crypt/OpenPGP/Marker.pm
-lib/perl5/site_perl/%%PERL_VER%%/Crypt/OpenPGP/Trust.pm
-lib/perl5/site_perl/%%PERL_VER%%/Crypt/OpenPGP/Certificate.pm
-lib/perl5/site_perl/%%PERL_VER%%/Crypt/OpenPGP/Message.pm
-lib/perl5/site_perl/%%PERL_VER%%/Crypt/OpenPGP/ErrorHandler.pm
-lib/perl5/site_perl/%%PERL_VER%%/Crypt/OpenPGP/SKSessionKey.pm
-lib/perl5/site_perl/%%PERL_VER%%/Crypt/OpenPGP/SessionKey.pm
-lib/perl5/site_perl/%%PERL_VER%%/Crypt/OpenPGP/Words.pm
-lib/perl5/site_perl/%%PERL_VER%%/Crypt/OpenPGP/PacketFactory.pm
-lib/perl5/site_perl/%%PERL_VER%%/Crypt/OpenPGP/Signature.pm
-lib/perl5/site_perl/%%PERL_VER%%/Crypt/OpenPGP/KeyBlock.pm
-lib/perl5/site_perl/%%PERL_VER%%/Crypt/OpenPGP/MDC.pm
-lib/perl5/site_perl/%%PERL_VER%%/Crypt/OpenPGP/Compressed.pm
-lib/perl5/site_perl/%%PERL_VER%%/Crypt/OpenPGP/Buffer.pm
-lib/perl5/site_perl/%%PERL_VER%%/Crypt/OpenPGP/Cipher.pm
-lib/perl5/site_perl/%%PERL_VER%%/Crypt/OpenPGP/OnePassSig.pm
-lib/perl5/site_perl/%%PERL_VER%%/Crypt/OpenPGP/Signature/SubPacket.pm
-lib/perl5/site_perl/%%PERL_VER%%/Crypt/OpenPGP.pm
-lib/perl5/site_perl/%%PERL_VER%%/Crypt/DES_EDE3.pm
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt/OpenPGP/.packlist
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/Crypt/OpenPGP/Key/Secret
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/Crypt/OpenPGP/Key/Public
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/Crypt/OpenPGP/Key
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/Crypt/OpenPGP/Signature
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/Crypt/OpenPGP
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt/OpenPGP
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/OpenPGP/.packlist
+%%SITE_PERL%%/Crypt/OpenPGP.pm
+%%SITE_PERL%%/Crypt/OpenPGP/Words.pm
+%%SITE_PERL%%/Crypt/OpenPGP/Digest.pm
+%%SITE_PERL%%/Crypt/OpenPGP/Key.pm
+%%SITE_PERL%%/Crypt/OpenPGP/KeyRing.pm
+%%SITE_PERL%%/Crypt/OpenPGP/Cipher.pm
+%%SITE_PERL%%/Crypt/OpenPGP/S2k.pm
+%%SITE_PERL%%/Crypt/OpenPGP/Armour.pm
+%%SITE_PERL%%/Crypt/OpenPGP/Certificate.pm
+%%SITE_PERL%%/Crypt/OpenPGP/Compressed.pm
+%%SITE_PERL%%/Crypt/OpenPGP/Message.pm
+%%SITE_PERL%%/Crypt/OpenPGP/OnePassSig.pm
+%%SITE_PERL%%/Crypt/OpenPGP/Util.pm
+%%SITE_PERL%%/Crypt/OpenPGP/SKSessionKey.pm
+%%SITE_PERL%%/Crypt/OpenPGP/MDC.pm
+%%SITE_PERL%%/Crypt/OpenPGP/CFB.pm
+%%SITE_PERL%%/Crypt/OpenPGP/PacketFactory.pm
+%%SITE_PERL%%/Crypt/OpenPGP/Signature.pm
+%%SITE_PERL%%/Crypt/OpenPGP/Marker.pm
+%%SITE_PERL%%/Crypt/OpenPGP/Buffer.pm
+%%SITE_PERL%%/Crypt/OpenPGP/KeyBlock.pm
+%%SITE_PERL%%/Crypt/OpenPGP/ErrorHandler.pm
+%%SITE_PERL%%/Crypt/OpenPGP/KeyServer.pm
+%%SITE_PERL%%/Crypt/OpenPGP/Config.pm
+%%SITE_PERL%%/Crypt/OpenPGP/Key/Public.pm
+%%SITE_PERL%%/Crypt/OpenPGP/Key/Secret.pm
+%%SITE_PERL%%/Crypt/OpenPGP/Key/Secret/DSA.pm
+%%SITE_PERL%%/Crypt/OpenPGP/Key/Secret/RSA.pm
+%%SITE_PERL%%/Crypt/OpenPGP/Key/Secret/ElGamal.pm
+%%SITE_PERL%%/Crypt/OpenPGP/Key/Public/RSA.pm
+%%SITE_PERL%%/Crypt/OpenPGP/Key/Public/DSA.pm
+%%SITE_PERL%%/Crypt/OpenPGP/Key/Public/ElGamal.pm
+%%SITE_PERL%%/Crypt/OpenPGP/SessionKey.pm
+%%SITE_PERL%%/Crypt/OpenPGP/Constants.pm
+%%SITE_PERL%%/Crypt/OpenPGP/Trust.pm
+%%SITE_PERL%%/Crypt/OpenPGP/UserID.pm
+%%SITE_PERL%%/Crypt/OpenPGP/Plaintext.pm
+%%SITE_PERL%%/Crypt/OpenPGP/Ciphertext.pm
+%%SITE_PERL%%/Crypt/OpenPGP/Signature/SubPacket.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/OpenPGP
+@dirrm %%SITE_PERL%%/Crypt/OpenPGP/Key/Secret
+@dirrm %%SITE_PERL%%/Crypt/OpenPGP/Key/Public
+@dirrm %%SITE_PERL%%/Crypt/OpenPGP/Key
+@dirrm %%SITE_PERL%%/Crypt/OpenPGP/Signature
+@dirrm %%SITE_PERL%%/Crypt/OpenPGP
+@unexec rmdir %D/%%SITE_PERL%%/Crypt 2>/dev/null || true