aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Crypt-OpenSSL-Random
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-09-11 08:57:11 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-09-11 08:57:11 +0000
commit543ac930586104af21012750f0fa0dc6c6768e4b (patch)
tree06bb15e246bb7796f801d4386e6079ad54006f14 /security/p5-Crypt-OpenSSL-Random
parented7de446e6f286b1d4eee8a53d59603a997b731a (diff)
downloadports-543ac930586104af21012750f0fa0dc6c6768e4b.tar.gz
ports-543ac930586104af21012750f0fa0dc6c6768e4b.zip
Add p5-Crypt-OpenSSL-Random, a Perl5 interface to the OpenSSL
pseudo-random number generator. PR: ports/30107 Submitted by: Norikatsu Shigemura <nork@cityfujisawa.ne.jp>
Notes
Notes: svn path=/head/; revision=47648
Diffstat (limited to 'security/p5-Crypt-OpenSSL-Random')
-rw-r--r--security/p5-Crypt-OpenSSL-Random/Makefile25
-rw-r--r--security/p5-Crypt-OpenSSL-Random/distinfo1
-rw-r--r--security/p5-Crypt-OpenSSL-Random/pkg-comment1
-rw-r--r--security/p5-Crypt-OpenSSL-Random/pkg-descr2
-rw-r--r--security/p5-Crypt-OpenSSL-Random/pkg-plist10
5 files changed, 39 insertions, 0 deletions
diff --git a/security/p5-Crypt-OpenSSL-Random/Makefile b/security/p5-Crypt-OpenSSL-Random/Makefile
new file mode 100644
index 000000000000..85c893086fe1
--- /dev/null
+++ b/security/p5-Crypt-OpenSSL-Random/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Crypt-OpenSSL-Random
+# Date created: 2001/08/27
+# Whom: nork@cityfujisawa.ne.jp
+#
+# $FreeBSD$
+#
+
+PORTNAME= Crypt-OpenSSL-Random
+PORTVERSION= 0.02
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Crypt
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= nork@cityfujisawa.ne.jp
+
+RESTRICTED= "Crypto; export-controlled"
+
+PERL_CONFIGURE= yes
+
+MAN3= Crypt::OpenSSL::Random.3
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-OpenSSL-Random/distinfo b/security/p5-Crypt-OpenSSL-Random/distinfo
new file mode 100644
index 000000000000..26872a98630c
--- /dev/null
+++ b/security/p5-Crypt-OpenSSL-Random/distinfo
@@ -0,0 +1 @@
+MD5 (Crypt-OpenSSL-Random-0.02.tar.gz) = ac1bdfd627c9fc825316e6f414db7c5f
diff --git a/security/p5-Crypt-OpenSSL-Random/pkg-comment b/security/p5-Crypt-OpenSSL-Random/pkg-comment
new file mode 100644
index 000000000000..72a4aa7360a0
--- /dev/null
+++ b/security/p5-Crypt-OpenSSL-Random/pkg-comment
@@ -0,0 +1 @@
+Perl5 interface to the OpenSSL pseudo-random number generator
diff --git a/security/p5-Crypt-OpenSSL-Random/pkg-descr b/security/p5-Crypt-OpenSSL-Random/pkg-descr
new file mode 100644
index 000000000000..ff57201e2b48
--- /dev/null
+++ b/security/p5-Crypt-OpenSSL-Random/pkg-descr
@@ -0,0 +1,2 @@
+Crypt::OpenSSL::Random provides the ability to seed and
+query the OpenSSL library's pseudo-random number generator.
diff --git a/security/p5-Crypt-OpenSSL-Random/pkg-plist b/security/p5-Crypt-OpenSSL-Random/pkg-plist
new file mode 100644
index 000000000000..a342134ec782
--- /dev/null
+++ b/security/p5-Crypt-OpenSSL-Random/pkg-plist
@@ -0,0 +1,10 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Crypt/OpenSSL/Random.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt/OpenSSL/Random/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt/OpenSSL/Random/Random.so
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt/OpenSSL/Random/Random.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt/OpenSSL/Random/autosplit.ix
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt/OpenSSL/Random
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Crypt 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Crypt/OpenSSL 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt/OpenSSL 2>/dev/null || true