aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Crypt-Primes
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2015-03-13 17:29:58 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2015-03-13 17:29:58 +0000
commit10f22ecd6d1808866406972dd09e2e107e41ceb2 (patch)
tree31d423e420103f6111ac7dcc29da77612438b7a3 /security/p5-Crypt-Primes
parent42651c13cd4978964674808cab47a30c8726769b (diff)
downloadports-10f22ecd6d1808866406972dd09e2e107e41ceb2.tar.gz
ports-10f22ecd6d1808866406972dd09e2e107e41ceb2.zip
Clean up the rest of the perl@ Makefiles a bit.
- Remove dependencies on modules distributed as part of perl core - Remove references to FreeBSD < 8 and perl < 5.16 - Ensure that DOCS and EXAMPLES options exist for ports installing PORTDOCS or PORTEXAMPLES - Reduce unnecessary inclusions of bsd.port.options.mk by using OPTIONS helpers and the like - Fix some cases where dependencies were only assigned to BUILD_DEPENDS - Fix a few of the cases where dependencies were only assigned to RUN_DEPENDS. This one happens in many, many ports. I only applied it in cases where it interfered with 'make test' but it should maybe be done more generally. - Mute ${MKDIR} in installation - Parethesize compound commands - In www/p5-URI-Fetch, remove the ZLIB option that wasn't used
Notes
Notes: svn path=/head/; revision=381221
Diffstat (limited to 'security/p5-Crypt-Primes')
-rw-r--r--security/p5-Crypt-Primes/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/security/p5-Crypt-Primes/Makefile b/security/p5-Crypt-Primes/Makefile
index 30cfae4f72ea..798ed8f5e107 100644
--- a/security/p5-Crypt-Primes/Makefile
+++ b/security/p5-Crypt-Primes/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Crypt-Primes
PORTVERSION= 0.50
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -13,6 +13,7 @@ COMMENT= Provable Prime Number Generator suitable for Cryptographic Applications
BUILD_DEPENDS= p5-Crypt-Random>=0:${PORTSDIR}/security/p5-Crypt-Random \
p5-Math-Pari>=0:${PORTSDIR}/math/p5-Math-Pari
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= configure