aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Crypt-Salt
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2005-12-21 16:31:51 +0000
committerErwin Lansing <erwin@FreeBSD.org>2005-12-21 16:31:51 +0000
commit01308ef90f602cac3932a9bb2e132b7d2cd46ddb (patch)
tree5adb635bfa0a3c790c378f77362a53685906ad1d /security/p5-Crypt-Salt
parent8a84e5857382ccce7b00992c2d1a1b71f5efa5ee (diff)
downloadports-01308ef90f602cac3932a9bb2e132b7d2cd46ddb.tar.gz
ports-01308ef90f602cac3932a9bb2e132b7d2cd46ddb.zip
The single exported subroutine in this module is for generating a salt
suitable for being fed to crypt() and other similar functions. WWW: http://search.cpan.org/dist/Crypt-Salt PR: ports/90696 Submitted by: Gabor Kovesdan
Notes
Notes: svn path=/head/; revision=151768
Diffstat (limited to 'security/p5-Crypt-Salt')
-rw-r--r--security/p5-Crypt-Salt/Makefile24
-rw-r--r--security/p5-Crypt-Salt/distinfo3
-rw-r--r--security/p5-Crypt-Salt/pkg-descr4
-rw-r--r--security/p5-Crypt-Salt/pkg-plist5
4 files changed, 36 insertions, 0 deletions
diff --git a/security/p5-Crypt-Salt/Makefile b/security/p5-Crypt-Salt/Makefile
new file mode 100644
index 000000000000..4f3e4d3d3468
--- /dev/null
+++ b/security/p5-Crypt-Salt/Makefile
@@ -0,0 +1,24 @@
+# New ports collection Makefile for: p5-Crypt-Salt
+# Date created: 20 Dec 2006
+# Whom: Gabor Kovesdan
+# $FreeBSD$
+
+PORTNAME= Crypt-Salt
+PORTVERSION= 0.01
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Crypt
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gkovesdan@t-hosting.hu
+COMMENT= Perl extension to generate a salt to be fed into crypt
+
+PERL_CONFIGURE= yes
+
+MAN3= Crypt::Salt.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} <= 500503
+IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/security/p5-Crypt-Salt/distinfo b/security/p5-Crypt-Salt/distinfo
new file mode 100644
index 000000000000..fe5f9ec42c1d
--- /dev/null
+++ b/security/p5-Crypt-Salt/distinfo
@@ -0,0 +1,3 @@
+MD5 (Crypt-Salt-0.01.tar.gz) = acf14eb915beec773d4ea99ded753352
+SHA256 (Crypt-Salt-0.01.tar.gz) = 400b696319980762ad415d459c28262392990d105992b3a3de6b93ea20b567fa
+SIZE (Crypt-Salt-0.01.tar.gz) = 9784
diff --git a/security/p5-Crypt-Salt/pkg-descr b/security/p5-Crypt-Salt/pkg-descr
new file mode 100644
index 000000000000..6661a5c189b5
--- /dev/null
+++ b/security/p5-Crypt-Salt/pkg-descr
@@ -0,0 +1,4 @@
+The single exported subroutine in this module is for generating a salt
+suitable for being fed to crypt() and other similar functions.
+
+WWW: http://search.cpan.org/dist/Crypt-Salt
diff --git a/security/p5-Crypt-Salt/pkg-plist b/security/p5-Crypt-Salt/pkg-plist
new file mode 100644
index 000000000000..8ab5a43bf5cd
--- /dev/null
+++ b/security/p5-Crypt-Salt/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Crypt/Salt.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/Salt/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/Salt/
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Crypt 2>/dev/null || true