aboutsummaryrefslogtreecommitdiff
path: root/security/p5-GnuPG-Interface/Makefile
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2001-05-12 07:50:59 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2001-05-12 07:50:59 +0000
commit4f320235c8c49e859ca4eef371ad6ee0f1b6a999 (patch)
tree538155535e5f0b4421bcd58218af619966c1c49e /security/p5-GnuPG-Interface/Makefile
parent7db585eae49e874ba64f5792566aae25207acf26 (diff)
downloadports-4f320235c8c49e859ca4eef371ad6ee0f1b6a999.tar.gz
ports-4f320235c8c49e859ca4eef371ad6ee0f1b6a999.zip
Update to 0.31. Arrange list of man pages alphabetically. Add
new master site. Submitted by: ijliao, vanilla PR: 27155
Notes
Notes: svn path=/head/; revision=42549
Diffstat (limited to 'security/p5-GnuPG-Interface/Makefile')
-rw-r--r--security/p5-GnuPG-Interface/Makefile25
1 files changed, 14 insertions, 11 deletions
diff --git a/security/p5-GnuPG-Interface/Makefile b/security/p5-GnuPG-Interface/Makefile
index 6c9dc6813031..3349e898ce2f 100644
--- a/security/p5-GnuPG-Interface/Makefile
+++ b/security/p5-GnuPG-Interface/Makefile
@@ -6,29 +6,32 @@
#
PORTNAME= GnuPG-Interface
-PORTVERSION= 0.11
+PORTVERSION= 0.31
CATEGORIES= security perl5
-MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
-MASTER_SITE_SUBDIR= GnuPG
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN} \
+ ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= GnuPG gnupg-interface
PKGNAMEPREFIX= p5-
MAINTAINER= trevor@FreeBSD.org
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Class/MethodMaker.pm:${PORTSDIR}/devel/p5-Class-MethodMaker
RUN_DEPENDS= gpg:${PORTSDIR}/security/gnupg \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Class/MethodMaker.pm:${PORTSDIR}/devel/p5-Class-MethodMaker
+ ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
-MAN3= GnuPG::Handles.3 \
- GnuPG::SecretKey.3 \
+MAN3= GnuPG::Fingerprint.3 \
+ GnuPG::Handles.3 \
GnuPG::Interface.3 \
+ GnuPG::Key.3 \
+ GnuPG::Options.3 \
+ GnuPG::PrimaryKey.3 \
+ GnuPG::PublicKey.3 \
+ GnuPG::SecretKey.3 \
GnuPG::Signature.3 \
GnuPG::SubKey.3 \
- GnuPG::Fingerprint.3 \
- GnuPG::PublicKey.3 \
- GnuPG::Key.3 \
- GnuPG::UserId.3 \
- GnuPG::Options.3
+ GnuPG::UserId.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
.include <bsd.port.mk>