aboutsummaryrefslogtreecommitdiff
path: root/security/p5-IO-Async-SSL/Makefile
diff options
context:
space:
mode:
authorDennis Herrmann <dhn@FreeBSD.org>2011-03-07 11:40:06 +0000
committerDennis Herrmann <dhn@FreeBSD.org>2011-03-07 11:40:06 +0000
commit88cfd861c1f40bf291fb88bdc4c811306a1714c1 (patch)
tree4b95ba6b4461da2b7087bf576a7b89b7954189cc /security/p5-IO-Async-SSL/Makefile
parentf1424f21a9aa718c0ca4a98542fb728a78e30875 (diff)
downloadports-88cfd861c1f40bf291fb88bdc4c811306a1714c1.tar.gz
ports-88cfd861c1f40bf291fb88bdc4c811306a1714c1.zip
This module extends existing IO::Async classes with extra methods to
allow the use of SSL or TLS-based connections using IO::Socket::SSL. WWW: http://search.cpan.org/dist/IO-Async-SSL/ PR: ports/155336 Submitted by: "ports@c0decafe.net" <ports@c0decafe.net>
Notes
Notes: svn path=/head/; revision=270429
Diffstat (limited to 'security/p5-IO-Async-SSL/Makefile')
-rw-r--r--security/p5-IO-Async-SSL/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/security/p5-IO-Async-SSL/Makefile b/security/p5-IO-Async-SSL/Makefile
new file mode 100644
index 000000000000..72efd86d516b
--- /dev/null
+++ b/security/p5-IO-Async-SSL/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-IO-Async-SSL
+# Date created: 2011-03-07
+# Whom: <ports@c0decafe.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= IO-Async-SSL
+PORTVERSION= 0.06
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/P/PE/PEVANS
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@c0decafe.net
+COMMENT= Use SSL/TLS with IO::Async
+
+RUN_DEPENDS= p5-IO-Async>=0.29:${PORTSDIR}/devel/p5-IO-Async\
+ p5-IO-Socket-SSL>=0:${PORTSDIR}/security/p5-IO-Socket-SSL
+
+PERL_CONFIGURE= yes
+
+MAN3= IO::Async::SSLStream.3 IO::Async::SSL.3
+
+.include <bsd.port.mk>