aboutsummaryrefslogtreecommitdiff
path: root/security/p5-SHA
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-02-04 23:59:39 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-02-04 23:59:39 +0000
commit675b0f4d9c0a17349d1cee81780965a6e86d6195 (patch)
treef511ad9946fd35beb13cf9c55508fabf2043665b /security/p5-SHA
parent89932ed0a8b97509e3e65fee08e2964b7d237ee6 (diff)
downloadports-675b0f4d9c0a17349d1cee81780965a6e86d6195.tar.gz
ports-675b0f4d9c0a17349d1cee81780965a6e86d6195.zip
New Port: security/p5-SHA
The SHA module allows you to use the NIST SHA message digest algorithm from within Perl programs. The final message digest value is returned by the digest operation as a 20-byte binary string. This operation delivers the result of operations since the last new or reset operation. Once the operation has been performed, the context must be reset before being used to calculate another digest value. PR: ports/43799 Submitted by: Jim Geovedi <negative@toxic.magnesium.net>
Notes
Notes: svn path=/head/; revision=74700
Diffstat (limited to 'security/p5-SHA')
-rw-r--r--security/p5-SHA/Makefile22
-rw-r--r--security/p5-SHA/distinfo1
-rw-r--r--security/p5-SHA/files/patch-Makefile.PL11
-rw-r--r--security/p5-SHA/pkg-comment1
-rw-r--r--security/p5-SHA/pkg-descr8
-rw-r--r--security/p5-SHA/pkg-plist8
6 files changed, 51 insertions, 0 deletions
diff --git a/security/p5-SHA/Makefile b/security/p5-SHA/Makefile
new file mode 100644
index 000000000000..5580724f099f
--- /dev/null
+++ b/security/p5-SHA/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-SHA
+# Date created: Sep 30, 2002
+# Whom: Jim Geovedi <jim@corebsd.or.id>
+#
+# $FreeBSD$
+#
+
+PORTNAME= SHA
+PORTVERSION= 1.2
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= SHA
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= jim@corebsd.or.id
+
+PERL_CONFIGURE= yes
+
+MAN3= SHA.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/security/p5-SHA/distinfo b/security/p5-SHA/distinfo
new file mode 100644
index 000000000000..de7f4acaa442
--- /dev/null
+++ b/security/p5-SHA/distinfo
@@ -0,0 +1 @@
+MD5 (SHA-1.2.tar.gz) = fc23793219770f156d32fa676ab49be4
diff --git a/security/p5-SHA/files/patch-Makefile.PL b/security/p5-SHA/files/patch-Makefile.PL
new file mode 100644
index 000000000000..7f08d4876df6
--- /dev/null
+++ b/security/p5-SHA/files/patch-Makefile.PL
@@ -0,0 +1,11 @@
+--- Makefile.PL.orig Mon Sep 30 04:33:16 2002
++++ Makefile.PL Mon Sep 30 04:34:51 2002
+@@ -20,7 +20,7 @@ if (exists($Config{'byteorder'}) and def
+ print "Writing endian.h for SHA\n";
+ }
+ print "Do you want to use the original SHA or the new standard SHA-1?\nEnter 0 for the original or 1 for the new standard. [1]";
+- $resp = <STDIN>;
++ $resp = 1;
+ if (defined($resp)) {
+ $resp =~ s/^\s+//;
+ $resp =~ s/\s+$//;
diff --git a/security/p5-SHA/pkg-comment b/security/p5-SHA/pkg-comment
new file mode 100644
index 000000000000..45b9a94e21fe
--- /dev/null
+++ b/security/p5-SHA/pkg-comment
@@ -0,0 +1 @@
+Perl5 interface to the SHA1 algorithm
diff --git a/security/p5-SHA/pkg-descr b/security/p5-SHA/pkg-descr
new file mode 100644
index 000000000000..584611c9ebee
--- /dev/null
+++ b/security/p5-SHA/pkg-descr
@@ -0,0 +1,8 @@
+The SHA module allows you to use the NIST SHA message digest algorithm
+from within Perl programs.
+
+The final message digest value is returned by the digest operation as
+a 20-byte binary string. This operation delivers the result of
+operations since the last new or reset operation. Once the operation
+has been performed, the context must be reset before being used to
+calculate another digest value.
diff --git a/security/p5-SHA/pkg-plist b/security/p5-SHA/pkg-plist
new file mode 100644
index 000000000000..ae5679f86e22
--- /dev/null
+++ b/security/p5-SHA/pkg-plist
@@ -0,0 +1,8 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/SHA.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/SHA.pod
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/sha_driver.pl
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/SHA/SHA.so
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/SHA/SHA.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/SHA/autosplit.ix
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/SHA/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/SHA