aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Tie-EncryptedHash
diff options
context:
space:
mode:
authorMichael Haro <mharo@FreeBSD.org>2001-09-12 00:49:14 +0000
committerMichael Haro <mharo@FreeBSD.org>2001-09-12 00:49:14 +0000
commitab5036213c0a88aeb0751c212f558b220e512e8b (patch)
tree13ee23f15f58612a7dc259ca87be1cd44062043b /security/p5-Tie-EncryptedHash
parent8ca909d45cdffb833f8c96f1128197fbe4e51b80 (diff)
downloadports-ab5036213c0a88aeb0751c212f558b220e512e8b.tar.gz
ports-ab5036213c0a88aeb0751c212f558b220e512e8b.zip
Tie::EncryptedHash augments Perl hash semantics to build secure, encrypting
containers of data.
Notes
Notes: svn path=/head/; revision=47723
Diffstat (limited to 'security/p5-Tie-EncryptedHash')
-rw-r--r--security/p5-Tie-EncryptedHash/Makefile30
-rw-r--r--security/p5-Tie-EncryptedHash/distinfo1
-rw-r--r--security/p5-Tie-EncryptedHash/pkg-comment1
-rw-r--r--security/p5-Tie-EncryptedHash/pkg-descr12
-rw-r--r--security/p5-Tie-EncryptedHash/pkg-plist3
5 files changed, 47 insertions, 0 deletions
diff --git a/security/p5-Tie-EncryptedHash/Makefile b/security/p5-Tie-EncryptedHash/Makefile
new file mode 100644
index 000000000000..cc1b8db89ccb
--- /dev/null
+++ b/security/p5-Tie-EncryptedHash/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-Tie-EncryptedHash
+# Date created: Tue Sep 11 10:31:23 PDT 2001
+# Whom: Michael Haro <mharo@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Tie-EncryptedHash
+PORTVERSION= 1.1
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Tie
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mharo@FreeBSD.org
+
+PERLBASE= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+
+BUILD_DEPENDS= ${PERLBASE}/Crypt/CBC.pm:${PORTSDIR}/security/p5-Crypt-CBC \
+ ${PERLBASE}/${PERL_ARCH}/Crypt/DES.pm:${PORTSDIR}/security/p5-Crypt-DES \
+ ${PERLBASE}/${PERL_ARCH}/Crypt/Blowfish.pm:${PORTSDIR}/security/p5-Crypt-Blowfish
+
+RESTRICTED= "Crypto; export-controlled"
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Tie::EncryptedHash.3
+
+.include <bsd.port.mk>
diff --git a/security/p5-Tie-EncryptedHash/distinfo b/security/p5-Tie-EncryptedHash/distinfo
new file mode 100644
index 000000000000..09c8713e9eee
--- /dev/null
+++ b/security/p5-Tie-EncryptedHash/distinfo
@@ -0,0 +1 @@
+MD5 (Tie-EncryptedHash-1.1.tar.gz) = 4f13c0f95a86c33acd84ab0ba2ba2906
diff --git a/security/p5-Tie-EncryptedHash/pkg-comment b/security/p5-Tie-EncryptedHash/pkg-comment
new file mode 100644
index 000000000000..75a2e427e8b1
--- /dev/null
+++ b/security/p5-Tie-EncryptedHash/pkg-comment
@@ -0,0 +1 @@
+Hashes (and objects based on hashes) with encrypting fields
diff --git a/security/p5-Tie-EncryptedHash/pkg-descr b/security/p5-Tie-EncryptedHash/pkg-descr
new file mode 100644
index 000000000000..dbd175a0de31
--- /dev/null
+++ b/security/p5-Tie-EncryptedHash/pkg-descr
@@ -0,0 +1,12 @@
+Tie::EncryptedHash augments Perl hash semantics to build secure, encrypting
+containers of data. Tie::EncryptedHash introduces special hash fields that are
+coupled with encrypt/decrypt routines to encrypt assignments at STORE() and
+decrypt retrievals at FETCH(). By design, encrypting fields are associated with
+keys that begin in single underscore. The remaining keyspace is used for
+accessing normal hash fields, which are retained without modification.
+
+While the password is set, a Tie::EncryptedHash behaves exactly like a standard
+Perl hash. This is its transparent mode of access. Encrypting and normal fields
+are identical in this mode. When password is deleted, encrypting fields are
+accessible only as ciphertext. This is Tie::EncryptedHash's opaque mode of
+access, optimized for serialization.
diff --git a/security/p5-Tie-EncryptedHash/pkg-plist b/security/p5-Tie-EncryptedHash/pkg-plist
new file mode 100644
index 000000000000..d85995af1e3f
--- /dev/null
+++ b/security/p5-Tie-EncryptedHash/pkg-plist
@@ -0,0 +1,3 @@
+lib/perl5/site_perl/%%PERL_VER%%/Tie/EncryptedHash.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Tie/EncryptedHash/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Tie/EncryptedHash