aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Yahoo-BBAuth
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2007-07-09 02:16:06 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2007-07-09 02:16:06 +0000
commitd925706034a1f3a17ca8770f954423d250a15b98 (patch)
treebc0a2eaf776d545fae8c057b867433ed23688cc4 /security/p5-Yahoo-BBAuth
parent1892b391b65996f51ed84b96842ba70133ffc79b (diff)
downloadports-d925706034a1f3a17ca8770f954423d250a15b98.tar.gz
ports-d925706034a1f3a17ca8770f954423d250a15b98.zip
This module priovides an Object Oriented interface for Yahoo!
Browser-Based Authentication. This module is ported from the official PHP class which is located on this page: http://developer.yahoo.com/php WWW: http://search.cpan.org/dist/Yahoo-BBAuth/ PR: ports/114345 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Notes
Notes: svn path=/head/; revision=195248
Diffstat (limited to 'security/p5-Yahoo-BBAuth')
-rw-r--r--security/p5-Yahoo-BBAuth/Makefile30
-rw-r--r--security/p5-Yahoo-BBAuth/distinfo3
-rw-r--r--security/p5-Yahoo-BBAuth/pkg-descr7
-rw-r--r--security/p5-Yahoo-BBAuth/pkg-plist10
4 files changed, 50 insertions, 0 deletions
diff --git a/security/p5-Yahoo-BBAuth/Makefile b/security/p5-Yahoo-BBAuth/Makefile
new file mode 100644
index 000000000000..b10d8f393fe9
--- /dev/null
+++ b/security/p5-Yahoo-BBAuth/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-Yahoo-BBAuth
+# Date created: 2007-07-06
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Yahoo-BBAuth
+PORTVERSION= 0.50
+CATEGORIES= security www
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Yahoo
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Perl interface to the Yahoo! Browser-Based Authentication
+
+RUN_DEPENDS= ${SITE_PERL}/Class/Accessor.pm:${PORTSDIR}/devel/p5-Class-Accessor \
+ ${SITE_PERL}/JSON.pm:${PORTSDIR}/converters/p5-JSON \
+ ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww
+
+PERL_CONFIGURE= yes
+
+MAN3= Yahoo::BBAuth.3
+
+post-install:
+ ${MKDIR} ${WWWDIR}/cgi-bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/eg/* ${WWWDIR}/cgi-bin
+
+.include <bsd.port.mk>
diff --git a/security/p5-Yahoo-BBAuth/distinfo b/security/p5-Yahoo-BBAuth/distinfo
new file mode 100644
index 000000000000..ee40199a5955
--- /dev/null
+++ b/security/p5-Yahoo-BBAuth/distinfo
@@ -0,0 +1,3 @@
+MD5 (Yahoo-BBAuth-0.50.tar.gz) = 87959d704605e812b31b75ec80b0fefb
+SHA256 (Yahoo-BBAuth-0.50.tar.gz) = 1f5d671aa113d26fec6c50447ca91e03cfe6e4351d5e8bf13d09675e1591920e
+SIZE (Yahoo-BBAuth-0.50.tar.gz) = 5775
diff --git a/security/p5-Yahoo-BBAuth/pkg-descr b/security/p5-Yahoo-BBAuth/pkg-descr
new file mode 100644
index 000000000000..4c29ba38bed7
--- /dev/null
+++ b/security/p5-Yahoo-BBAuth/pkg-descr
@@ -0,0 +1,7 @@
+This module priovides an Object Oriented interface for Yahoo!
+Browser-Based Authentication.
+
+This module is ported from the official PHP class which is located on
+this page: http://developer.yahoo.com/php
+
+WWW: http://search.cpan.org/dist/Yahoo-BBAuth/
diff --git a/security/p5-Yahoo-BBAuth/pkg-plist b/security/p5-Yahoo-BBAuth/pkg-plist
new file mode 100644
index 000000000000..2cfd3b4c2158
--- /dev/null
+++ b/security/p5-Yahoo-BBAuth/pkg-plist
@@ -0,0 +1,10 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Yahoo/BBAuth/.packlist
+%%SITE_PERL%%/Yahoo/BBAuth.pm
+%%WWWDIR%%/cgi-bin/testMAIL.cgi
+%%WWWDIR%%/cgi-bin/testPHOTOS.cgi
+@dirrmtry %%WWWDIR%%/cgi-bin
+@dirrmtry %%WWWDIR%%
+@dirrmtry %%SITE_PERL%%/Yahoo
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Yahoo/BBAuth
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Yahoo