aboutsummaryrefslogtreecommitdiff
path: root/security/p5-openxpki-client
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-10-07 12:29:03 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-10-07 12:29:03 +0000
commit84542c0a32ded4b5c1b1c2dda5d5ff08aaf2a451 (patch)
treeee293b28ce7dec4e5920fc2a921d1df366b82351 /security/p5-openxpki-client
parent63973baf98142d3175ac6dcd8d73263455df42e2 (diff)
downloadports-84542c0a32ded4b5c1b1c2dda5d5ff08aaf2a451.tar.gz
ports-84542c0a32ded4b5c1b1c2dda5d5ff08aaf2a451.zip
Add p5-openxpki-client 0.9.450, perl based trustcenter software for PKI:
base class for actual clients. PR: ports/103943 Submitted by: Sergei Vyshenski <svysh at cryptocom.ru>
Notes
Notes: svn path=/head/; revision=174757
Diffstat (limited to 'security/p5-openxpki-client')
-rw-r--r--security/p5-openxpki-client/Makefile30
-rw-r--r--security/p5-openxpki-client/distinfo3
-rw-r--r--security/p5-openxpki-client/pkg-descr24
-rw-r--r--security/p5-openxpki-client/pkg-plist7
4 files changed, 64 insertions, 0 deletions
diff --git a/security/p5-openxpki-client/Makefile b/security/p5-openxpki-client/Makefile
new file mode 100644
index 000000000000..962bc804d76a
--- /dev/null
+++ b/security/p5-openxpki-client/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-openxpki-client
+# Date created: 03 Oct 2006
+# Whom: svysh
+#
+# $FreeBSD$
+#
+
+PORTNAME= openxpki-client
+PORTVERSION= 0.9.450
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= openxpki
+PKGNAMEPREFIX= p5-
+DISTNAME= OpenXPKI-Client-${PORTVERSION}
+DIST_SUBDIR= openxpki
+
+MAINTAINER= svysh@cryptocom.ru
+COMMENT= Perl based trustcenter software for PKI: base class for actual clients
+
+BUILD_DEPENDS= \
+ ${SITE_PERL}/${PERL_ARCH}/OpenXPKI.pm:${PORTSDIR}/security/p5-openxpki
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= OpenXPKI::Client.3 \
+ OpenXPKI::Client::API.3
+USE_PERL5= yes
+USE_GMAKE= yes
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/security/p5-openxpki-client/distinfo b/security/p5-openxpki-client/distinfo
new file mode 100644
index 000000000000..bbedb73d1b6f
--- /dev/null
+++ b/security/p5-openxpki-client/distinfo
@@ -0,0 +1,3 @@
+MD5 (openxpki/OpenXPKI-Client-0.9.450.tar.gz) = 7dfdbb9cca092bddeeb6a84a84a6384f
+SHA256 (openxpki/OpenXPKI-Client-0.9.450.tar.gz) = 1383280e9d7630782c0e33372a713d937b41ad509062248b5c88a09b7de11d5a
+SIZE (openxpki/OpenXPKI-Client-0.9.450.tar.gz) = 12482
diff --git a/security/p5-openxpki-client/pkg-descr b/security/p5-openxpki-client/pkg-descr
new file mode 100644
index 000000000000..dccf2ae39cd6
--- /dev/null
+++ b/security/p5-openxpki-client/pkg-descr
@@ -0,0 +1,24 @@
+A collection of ports for the OpenXPKI suite - Perl based trustcenter
+software for PKI: server and client parts along with deployment tools.
+
+p5-openxpki: core for server part
+p5-openxpki-client: base class for actual clients
+p5-openxpki-i18n: internationalization of the user interface
+p5-openxpki-client-cli: command line interface to local OpenXPKI daemon
+p5-openxpki-client-html-mason: web interface to local OpenXPKI daemon
+p5-openxpki-client-scep: set of SCEP tools
+p5-openxpki-client-soap-lite: set of SOAP-Lite tools
+p5-openxpki-deployment: set or deployment tools
+
+Dependencies of OpenXPKI ports ("A --> B" means that port B depends on port A):
+
+ p5-openxpki-client <-- p5-openxpki (server) --> p5-openxpki-i18n
+ \
+ \ | p5-openxpki-client-cli, p5-openxpki-client-html-mason,
+ \--> | p5-openxpki-client-scep, p5-openxpki-client-soap-lite,
+ | p5-openxpki-deployment.
+Notes:
+I18n is needed for the English interface too. For effective use of deployment,
+it is recommended to install at least one of the clients: ...-cli or ...-mason.
+
+WWW: http://www.openxpki.org/
diff --git a/security/p5-openxpki-client/pkg-plist b/security/p5-openxpki-client/pkg-plist
new file mode 100644
index 000000000000..fd6ad66ad0bb
--- /dev/null
+++ b/security/p5-openxpki-client/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/OpenXPKI/Client.pm
+%%SITE_PERL%%/OpenXPKI/Client/API.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/OpenXPKI/Client/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/OpenXPKI/Client
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/OpenXPKI
+@dirrmtry %%SITE_PERL%%/OpenXPKI/Client
+@dirrmtry %%SITE_PERL%%/OpenXPKI