aboutsummaryrefslogtreecommitdiff
path: root/security/p5-openxpki
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2010-08-18 12:42:19 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2010-08-18 12:42:19 +0000
commitee40034e80a1f2e31d3c140f7d2d2e715d2037a1 (patch)
tree7c5822995ca51d509a75d5b21b227b147e2c4eb9 /security/p5-openxpki
parent53efcf8c3d174206dbc4600398fd4847a7c93687 (diff)
downloadports-ee40034e80a1f2e31d3c140f7d2d2e715d2037a1.tar.gz
ports-ee40034e80a1f2e31d3c140f7d2d2e715d2037a1.zip
- Fix dependency list
- Convert to USERS/GROUPS macros - Add license - Bump portrevision PR: ports/149740 Submitted by: Sergei Vyshenski <svysh _at_ pn.sinp.msu.ru> (maintainer) Approved by: tabthorpe (mentor)
Notes
Notes: svn path=/head/; revision=259500
Diffstat (limited to 'security/p5-openxpki')
-rw-r--r--security/p5-openxpki/Makefile17
-rw-r--r--security/p5-openxpki/pkg-install41
2 files changed, 10 insertions, 48 deletions
diff --git a/security/p5-openxpki/Makefile b/security/p5-openxpki/Makefile
index 825f1a7aa269..1492f22e1453 100644
--- a/security/p5-openxpki/Makefile
+++ b/security/p5-openxpki/Makefile
@@ -7,7 +7,7 @@
PORTNAME= openxpki
PORTVERSION= 0.9.1389
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security perl5
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/0.9.1300
PKGNAMEPREFIX= p5-
@@ -287,6 +287,11 @@ USE_GMAKE= yes
USE_OPENSSL= yes
PERL_CONFIGURE= 5.8.6+
+USERS= openxpki
+GROUPS= openxpki
+
+LICENSE= ART20
+
OPTIONS= DEVELOPER "Install development tools for OpenXPKI?" off \
GRAPHVIZ "With graphical visualization of workflows?" off
# If DEVELOPER is checked, then docbook, Java and Xorg libraries are installed.
@@ -313,16 +318,14 @@ WITH_OPENSSL_BASE= yes
.include <bsd.port.pre.mk>
.if defined(WITH_DEVELOPER)
-RUN_DEPENDS+= fop:${PORTSDIR}/textproc/fop \
- xsltproc:${PORTSDIR}/textproc/libxslt \
+RUN_DEPENDS+= ${LOCALBASE}/bin/fop:${PORTSDIR}/textproc/fop \
+ ${LOCALBASE}/bin/xsltproc:${PORTSDIR}/textproc/libxslt \
${LOCALBASE}/share/xsl/docbook/html/chunk.xsl:${PORTSDIR}/textproc/docbook-xsl \
${LOCALBASE}/share/java/jai/lib/libmlib_jai.so:${PORTSDIR}/java/jai
.endif
.if defined(WITH_GRAPHVIZ)
-RUN_DEPENDS+= ${LOCALBASE}/bin/dot:${PORTSDIR}/graphics/graphviz
+RUN_DEPENDS+= ${LOCALBASE}/bin/dot:${PORTSDIR}/graphics/graphviz \
+ ${LOCALBASE}/bin/imgsize:${PORTSDIR}/graphics/p5-Image-Size
.endif
-post-install:
- ${SH} ${PKGINSTALL} ${PORTNAME} POST-INSTALL
-
.include <bsd.port.post.mk>
diff --git a/security/p5-openxpki/pkg-install b/security/p5-openxpki/pkg-install
deleted file mode 100644
index dd9c86fa2a8b..000000000000
--- a/security/p5-openxpki/pkg-install
+++ /dev/null
@@ -1,41 +0,0 @@
-#! /bin/sh
-# $FreeBSD$
-
-PATH=/bin:/usr/sbin
-OPENXPKIUSER=openxpki
-HOME_DIR="/nonexistent"
-SHELL="/usr/sbin/nologin"
-COMMENT="OpenXPKI Owner"
-
-case $2 in
-POST-INSTALL)
- USER=${OPENXPKIUSER}
- GROUP=${USER}
- UID=777
- GID=${UID}
-
- if pw group show "${GROUP}" 2>/dev/null; then
- echo "You already have a group \"${GROUP}\", so I will use it."
- else
- if pw groupadd ${GROUP} -g ${GID}; then
- echo "Added group \"${GROUP}\"."
- else
- echo "Adding group \"${GROUP}\" failed..."
- exit 1
- fi
- fi
-
- if pw user show "${USER}" 2>/dev/null; then
- echo "You already have a user \"${USER}\", so I will use it."
- else
- if pw useradd ${USER} -u ${UID} -g ${GROUP} -h - \
- -d ${HOME_DIR} -c "${COMMENT}" -s ${SHELL}
- then
- echo "Added user \"${USER}\"."
- else
- echo "Adding user \"${USER}\" failed..."
- exit 1
- fi
- fi
- ;;
-esac