aboutsummaryrefslogtreecommitdiff
path: root/security/pam-mysql/Makefile
diff options
context:
space:
mode:
authorChris D. Faulhaber <jedgar@FreeBSD.org>2000-09-10 12:57:49 +0000
committerChris D. Faulhaber <jedgar@FreeBSD.org>2000-09-10 12:57:49 +0000
commita81bfebeba7964f9b8d9abe3f28ccd307d9e9a83 (patch)
treeee8d265386eba119a73f94ec268f7a88486c02b7 /security/pam-mysql/Makefile
parentc51ce4fa919719451f448f26966d7752f7ce3c19 (diff)
downloadports-a81bfebeba7964f9b8d9abe3f28ccd307d9e9a83.tar.gz
ports-a81bfebeba7964f9b8d9abe3f28ccd307d9e9a83.zip
New port: pam-mysql
This is a port of the Linux MySQL PAM module. You can authenticate any PAMified service with MySQL using this module. PR: 20915 Submitted by: Anders Nordby <anders@fix.no>
Notes
Notes: svn path=/head/; revision=32491
Diffstat (limited to 'security/pam-mysql/Makefile')
-rw-r--r--security/pam-mysql/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/security/pam-mysql/Makefile b/security/pam-mysql/Makefile
new file mode 100644
index 000000000000..d51d4d948fbc
--- /dev/null
+++ b/security/pam-mysql/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: pam_mysql
+# Date created: 29 August 2000
+# Whom: Anders Nordby <anders@fix.no>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pam_mysql
+PORTVERSION= 0.4
+CATEGORIES= security databases
+MASTER_SITES= http://download.sourceforge.net/pam-mysql/ \
+ http://www.freenix.no/~anders/
+
+MAINTAINER= anders@fix.no
+
+LIB_DEPENDS= mysqlclient.6:${PORTSDIR}/databases/mysql322-client
+
+USE_GMAKE= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+post-patch:
+ @cd ${WRKSRC} && ${GMAKE} clean
+
+do-build:
+ ${CC} -O -pipe -fpic -DPIC -Wall -I${PREFIX}/include -c ${WRKSRC}/pam_mysql.c -o ${WRKSRC}/pam_mysql.o
+ ${LD} -x --shared -o ${WRKSRC}/pam_mysql.so ${WRKSRC}/pam_mysql.o -lpam -lcrypt -L${PREFIX}/lib/mysql -lmysqlclient
+
+do-install:
+ @${INSTALL_DATA} ${WRKSRC}/pam_mysql.so ${PREFIX}/lib
+ @${INSTALL} -d -o root -g wheel -m 0755 ${PREFIX}/share/doc/pam_mysql
+ @${INSTALL_DATA} ${WRKSRC}/Changelog ${PREFIX}/share/doc/pam_mysql/
+ @${INSTALL_DATA} ${WRKSRC}/CREDITS ${PREFIX}/share/doc/pam_mysql/
+ @${INSTALL_DATA} ${WRKSRC}/Readme ${PREFIX}/share/doc/pam_mysql/
+
+post-install:
+ @${ECHO} "================================================================================"
+ @${ECHO} "Copy/move/symlink ${PREFIX}/lib/pam_mysql.so to /usr/lib/pam_mysql.so"
+ @${ECHO} "to be able to use it. Read files in ${PREFIX}/share/doc/pam_mysql"
+ @${ECHO} "for info on how to set up."
+ @${ECHO} "================================================================================"
+
+.include <bsd.port.mk>