aboutsummaryrefslogtreecommitdiff
path: root/security/pam_alreadyloggedin
diff options
context:
space:
mode:
authorBrian Feldman <green@FreeBSD.org>2004-12-23 06:19:23 +0000
committerBrian Feldman <green@FreeBSD.org>2004-12-23 06:19:23 +0000
commit1dd8be6ecf778bb42c190cab460c76079b990e72 (patch)
treeb4921db1c980286b438c9e23cf5ed5108e3b42a3 /security/pam_alreadyloggedin
parent845e9f737dee110b6895b6bcbe946ff11e99bdd8 (diff)
downloadports-1dd8be6ecf778bb42c190cab460c76079b990e72.tar.gz
ports-1dd8be6ecf778bb42c190cab460c76079b990e72.zip
Attempt to make pam_alreadyloggedin work on 4.x again.
Submitted by: vs
Notes
Notes: svn path=/head/; revision=124905
Diffstat (limited to 'security/pam_alreadyloggedin')
-rw-r--r--security/pam_alreadyloggedin/Makefile5
-rw-r--r--security/pam_alreadyloggedin/files/patch-pam_alreadyloggedin.c14
2 files changed, 15 insertions, 4 deletions
diff --git a/security/pam_alreadyloggedin/Makefile b/security/pam_alreadyloggedin/Makefile
index c4089d1e7db8..7936aff7f154 100644
--- a/security/pam_alreadyloggedin/Makefile
+++ b/security/pam_alreadyloggedin/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pam_alreadyloggedin
PORTVERSION= 0.3
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_LOCAL} \
http://green.homeunix.org/~green/
@@ -19,10 +20,6 @@ MANCOMPRESSED= yes
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-BROKEN= "Does not compile on FreeBSD 4.x"
-.endif
-
.if defined(NOPROFILE)
PLIST_SUB+= PROFILE="@comment "
.else
diff --git a/security/pam_alreadyloggedin/files/patch-pam_alreadyloggedin.c b/security/pam_alreadyloggedin/files/patch-pam_alreadyloggedin.c
new file mode 100644
index 000000000000..f676d9a38c5d
--- /dev/null
+++ b/security/pam_alreadyloggedin/files/patch-pam_alreadyloggedin.c
@@ -0,0 +1,14 @@
+--- pam_alreadyloggedin.c.orig Tue Sep 21 17:41:20 2004
++++ pam_alreadyloggedin.c Thu Dec 23 00:58:02 2004
+@@ -70,6 +70,11 @@
+ int inutmp(struct utmp *utmp, const char *lineglob, const char *username,
+ uid_t uid);
+
++#ifdef PAM_MAX_OPTIONS
++/* The old PAM requires this structure. */
++static struct options options;
++#endif
++
+ PAM_EXTERN int
+ pam_sm_authenticate(pam_handle_t *pamh, int flags __unused, int argc,
+ const char **argv)