aboutsummaryrefslogtreecommitdiff
path: root/security/pam_pgina
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2004-06-26 02:37:46 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2004-06-26 02:37:46 +0000
commit04e5859dd6178b2e9199cb1eb5d849834fcfb863 (patch)
treeeac17bf2869f718a6343d8d0e42078b10760e445 /security/pam_pgina
parentef7a6d06f203b7833067691774ec33b333e2b5b3 (diff)
downloadports-04e5859dd6178b2e9199cb1eb5d849834fcfb863.tar.gz
ports-04e5859dd6178b2e9199cb1eb5d849834fcfb863.zip
New port pam_pGina version 1.1.3: Daemon for allowing a pGina plugin
to authenticate against Unix PAM
Notes
Notes: svn path=/head/; revision=112288
Diffstat (limited to 'security/pam_pgina')
-rw-r--r--security/pam_pgina/Makefile50
-rw-r--r--security/pam_pgina/distinfo2
-rw-r--r--security/pam_pgina/files/patch-src::access.c10
-rw-r--r--security/pam_pgina/files/patch-src::actions.c10
-rw-r--r--security/pam_pgina/files/patch-src::pgina_pam_server.c14
-rw-r--r--security/pam_pgina/pkg-descr16
-rw-r--r--security/pam_pgina/pkg-plist9
7 files changed, 111 insertions, 0 deletions
diff --git a/security/pam_pgina/Makefile b/security/pam_pgina/Makefile
new file mode 100644
index 000000000000..be6e499f635f
--- /dev/null
+++ b/security/pam_pgina/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: pam_pGina
+# Date created: Thu Apr 29 16:03:45 UTC 2004
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pam_pGina
+PORTVERSION= 1.1.3
+CATEGORIES= security
+MASTER_SITES= http://pgina.xpasystems.com/downloads/
+DISTNAME= pgina_pam-${PORTVERSION}
+
+MAINTAINER= lioux@FreeBSD.org
+COMMENT= Daemon for allowing a pGina plugin to authenticate against Unix PAM
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_OPENSSL= yes
+USE_PERL5_RUN= yes
+USE_REINPLACE= yes
+
+post-patch:
+# PREFIX safeness
+# Use correct PAM 'password change' service name
+ @${REINPLACE_CMD} -E \
+ -e 's|/etc/|${PREFIX}/etc/|' \
+ -e 's|passwd|password|' \
+ ${WRKSRC}/src/pgina_pam_server.c
+# {OPENSSL,PERL} location safeness
+# PREFIX safeness
+ @${REINPLACE_CMD} -E \
+ -e 's|/usr/bin/openssl|${OPENSSLBASE}/bin/openssl|' \
+ -e 's|/usr/bin/perl|${PERL}|' \
+ -e 's|/etc/|${PREFIX}/etc/|' \
+ ${WRKSRC}/make_cert.pl
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/src/${DISTNAME:S/-${PORTVERSION}$$//} \
+ ${PREFIX}/sbin
+# share scripts
+ @${MKDIR} ${PREFIX}/share/${DISTNAME:S/-${PORTVERSION}$$//}
+ @${INSTALL_SCRIPT} ${WRKSRC}/make_cert.pl \
+ ${PREFIX}/share/${DISTNAME:S/-${PORTVERSION}$$//}
+# etc config files
+ @${MKDIR} ${PREFIX}/etc/${DISTNAME:S/-${PORTVERSION}$$//}
+ @${INSTALL_DATA} ${WRKSRC}/authasst.conf/* \
+ ${PREFIX}/etc/${DISTNAME:S/-${PORTVERSION}$$//}
+
+.include <bsd.port.mk>
diff --git a/security/pam_pgina/distinfo b/security/pam_pgina/distinfo
new file mode 100644
index 000000000000..cb392d5c4468
--- /dev/null
+++ b/security/pam_pgina/distinfo
@@ -0,0 +1,2 @@
+MD5 (pgina_pam-1.1.3.tar.gz) = 23c85cee741647b7628ab459d8c9bc2a
+SIZE (pgina_pam-1.1.3.tar.gz) = 87708
diff --git a/security/pam_pgina/files/patch-src::access.c b/security/pam_pgina/files/patch-src::access.c
new file mode 100644
index 000000000000..c075e82a7bbe
--- /dev/null
+++ b/security/pam_pgina/files/patch-src::access.c
@@ -0,0 +1,10 @@
+--- src/access.c.orig Fri Jun 25 23:33:28 2004
++++ src/access.c Fri Jun 25 23:34:23 2004
+@@ -72,6 +72,7 @@
+ #include "pgina_pam_server.h"
+ #include <sys/types.h>
+ #include <sys/socket.h>
++#include <netinet/in.h>
+ #include <netdb.h>
+ #include <arpa/inet.h>
+
diff --git a/security/pam_pgina/files/patch-src::actions.c b/security/pam_pgina/files/patch-src::actions.c
new file mode 100644
index 000000000000..4a7a574c2f55
--- /dev/null
+++ b/security/pam_pgina/files/patch-src::actions.c
@@ -0,0 +1,10 @@
+--- src/actions.c.orig Fri Sep 12 10:30:13 2003
++++ src/actions.c Thu Apr 29 13:11:51 2004
+@@ -131,6 +131,7 @@
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ #include <netdb.h>
++#include <netinet/in.h>
+ #include <arpa/inet.h>
+
+
diff --git a/security/pam_pgina/files/patch-src::pgina_pam_server.c b/security/pam_pgina/files/patch-src::pgina_pam_server.c
new file mode 100644
index 000000000000..f0fde8949381
--- /dev/null
+++ b/security/pam_pgina/files/patch-src::pgina_pam_server.c
@@ -0,0 +1,14 @@
+--- src/pgina_pam_server.c.orig Fri Sep 12 10:30:13 2003
++++ src/pgina_pam_server.c Thu Apr 29 13:11:51 2004
+@@ -148,6 +148,11 @@
+
+ */
+
++#include <sys/types.h>
++#include <sys/socket.h>
++#include <netinet/in.h>
++#include <arpa/inet.h>
++
+ #include "pgina_pam_server.h"
+ #include "access.h"
+ #include "actions.h"
diff --git a/security/pam_pgina/pkg-descr b/security/pam_pgina/pkg-descr
new file mode 100644
index 000000000000..128672167fd5
--- /dev/null
+++ b/security/pam_pgina/pkg-descr
@@ -0,0 +1,16 @@
+[ excerpt (with adaptations) from developer's WWW site ]
+
+This is the Unix daemon required for the pGina PAM plugin.
+
+We have developed this plugin to allow for authentication using
+PAM. This means you can authenticate your windows machines against
+an existing Unix user base without substantial changes!
+
+Just install the Unix daemon, and the pGina plugin on windows and
+your set!
+
+Sound too good to be true? It's not!
+
+As always, your mileage may vary.
+
+WWW: http://pgina.xpasystems.com/
diff --git a/security/pam_pgina/pkg-plist b/security/pam_pgina/pkg-plist
new file mode 100644
index 000000000000..7412e8fd7826
--- /dev/null
+++ b/security/pam_pgina/pkg-plist
@@ -0,0 +1,9 @@
+etc/pgina_pam/authasst.allow
+etc/pgina_pam/authasst.deny
+etc/pgina_pam/authasst.groups
+etc/pgina_pam/authasst.hosts
+etc/pgina_pam/authasst.users
+share/pgina_pam/make_cert.pl
+sbin/pgina_pam
+@dirrm share/pgina_pam
+@unexec rmdir %D/etc/pgina_pam 2>/dev/null || echo "If you are permanently removing this port, you should do a ``rm -rf ${PKG_PREFIX}/etc/pgina_pam`` to remove any configuration files left." | fmt