aboutsummaryrefslogtreecommitdiff
path: root/security/parano
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-05-08 14:06:14 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-05-08 14:06:14 +0000
commit0922dea7a2b864c1e2e4cb632234821faed17637 (patch)
tree6d84a34701cf1f0f9c2f7991036cf91767f12ae5 /security/parano
parentef6a6b2985f7fbf4a5a3f2049658b9bd0ca80106 (diff)
downloadports-0922dea7a2b864c1e2e4cb632234821faed17637.tar.gz
ports-0922dea7a2b864c1e2e4cb632234821faed17637.zip
Add parano: A Gnome program to deal with hashfiles
PR: ports/96710 Submitted by: sat Approved by: krion (mentor)
Notes
Notes: svn path=/head/; revision=161710
Diffstat (limited to 'security/parano')
-rw-r--r--security/parano/Makefile32
-rw-r--r--security/parano/distinfo3
-rw-r--r--security/parano/pkg-descr4
-rw-r--r--security/parano/pkg-plist14
4 files changed, 53 insertions, 0 deletions
diff --git a/security/parano/Makefile b/security/parano/Makefile
new file mode 100644
index 000000000000..838993054b54
--- /dev/null
+++ b/security/parano/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: parano
+# Date created: 3 May 2006
+# Whom: Andrew Pantyukhin <infofarmer@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= parano
+PORTVERSION= 0.3.0
+CATEGORIES= security
+MASTER_SITES= http://download.berlios.de/%SUBDIR%/ \
+ http://download2.berlios.de/%SUBDIR%/
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= infofarmer@gmail.com
+COMMENT= A Gnome program to deal with hashfiles
+
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/gtk-2.0/gtk/__init__.py:${PORTSDIR}/x11-toolkits/py-gtk2
+
+GNU_CONFIGURE= yes
+USE_PYTHON= yes
+USE_X_PREFIX= yes
+USE_GNOME= gtk20
+USE_GETTEXT= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+post-patch:
+ ${REINPLACE_CMD} -e 's/$$</$$>/' ${WRKSRC}/src/Makefile.in
+ ${REINPLACE_CMD} -e 's,#!.*python,#!${PYTHON_CMD},' ${WRKSRC}/src/parano.py
+
+.include <bsd.port.mk>
diff --git a/security/parano/distinfo b/security/parano/distinfo
new file mode 100644
index 000000000000..40664b8e9c5a
--- /dev/null
+++ b/security/parano/distinfo
@@ -0,0 +1,3 @@
+MD5 (parano-0.3.0.tar.gz) = b7f141a8a2bb449d5781d8d06596b7ef
+SHA256 (parano-0.3.0.tar.gz) = 35daf0231614b0b60cd69fd09671ee84e7231542c8f31d323fdaf3d174233dc1
+SIZE (parano-0.3.0.tar.gz) = 149931
diff --git a/security/parano/pkg-descr b/security/parano/pkg-descr
new file mode 100644
index 000000000000..e03d94fffff4
--- /dev/null
+++ b/security/parano/pkg-descr
@@ -0,0 +1,4 @@
+Parano is a GNOME program to create, edit and verify hashfiles.
+For now MD5, SHA1 and SFV formats are supported.
+
+WWW: http://parano.berlios.de/
diff --git a/security/parano/pkg-plist b/security/parano/pkg-plist
new file mode 100644
index 000000000000..c2439dfca035
--- /dev/null
+++ b/security/parano/pkg-plist
@@ -0,0 +1,14 @@
+bin/parano
+share/locale/fr/LC_MESSAGES/parano.mo
+share/mime/packages/parano.xml
+share/applications/parano.desktop
+share/application-registry/parano.applications
+share/mime-info/parano.keys
+share/mime-info/parano.mime
+share/pixmaps/parano-icon.png
+%%DATADIR%%/parano.png
+%%DATADIR%%/parano-icon.png
+%%DATADIR%%/parano.glade
+@dirrm %%DATADIR%%
+@exec %%LOCALBASE%%/bin/update-mime-database %D/share/mime
+@unexec %%LOCALBASE%%/bin/update-mime-database %D/share/mime